7 Replies Latest reply: Jan 12, 2009 7:06 AM by 3zzy
Brian Johns Level 1 (30 points)
I have two Windows XP computers and one Ubuntu computer that I want to share screens with my MacPro (OSX 10.5.5).

I have TightVNC one one of the Windows XP computers and RealVNC on the other. Both computers have Bonjour installed -- for what it's worth.

My goal is to have all three of my networked computers show up for screen sharing in the Finder's SHARING section.

I enabled Remote Desktop on the Ubuntu computer and "ta-da" it showed up in the Finder's "Sharing" section to screen share with no other intervention whatsoever.

I can't figure out how to make the Windows XP computer show up in the Finder's sidebar.

Note I can use Chicken of the VNC to connect to ALL machines on my network via their static IP addresses. It works fine -- it's just that I think it's very slick and convenient to do it the OSX "way" instead of using the CotVNC client.

What does it take for the Windows XP computers to advertise their screen sharing capability so they'll show up in the Finder's "Shared" sidebar??

MacPro 2x3 Ghz Dual-Core Intel Xeon, 2 GB 667 MHz DDR2 FB-DIMM, Mac OS X (10.5.2), Also, PowerMac G4 "Sawtooth" and PowerMac G4 "Gigabit Ethernet"
  • BobHarris Level 6 (17,050 points)
    What does it take for the Windows XP computers to advertise their screen sharing capability so they'll show up in the Finder's "Shared" sidebar??

    I think you have to get Windows and Ubuntu to advertise via Bonjour.

    Get the Mac utility *Bonjour Browser* from some place like VersionTracker.com or MacUpdate.com. It will show you what services are being advertised via Bonjour on your local network.

    When I look at my network, the systems that I can see in my sidebar have a *Bonjour Browser* entry of the form:

    Remote Frame Buffer (rb.tcp.) -1
  • Brian Johns Level 1 (30 points)
    I checked Bonjour Browser and there are no entries for VNC (or screen sharing) for either of the Windows computers. Ubuntu publishes itself just fine and shows up in the Finder sidebar. That's what I want both my Windows computers to do.

    Both Windows computers have Bonjour installed, and I'm able to screen-share with both through Chicken of the VNC, as long as I enter the IP address. The "Listen" mode in Chicken-of-the-VNC shows the Ubuntu screen share, but nothing for Windows there either.

    Any other ideas, anyone? How does one get screen sharing with Windows to show up in the Finder sidebar?

  • Brian Johns Level 1 (30 points)

    What VNC software for Windows can be configured to make it show up in the sidebar in Apple's Finder windows?
  • mduaneh Level 1 (0 points)
    I'm trying to figure out the EXACT same scenario.
    I have ubuntu showing up perfectly with its built in screen share, and AFP now by the way too.

    I have the same setup as you on the XP machine, I'm trying to figure out a way for XP to do the broadcast as well.
  • mduaneh Level 1 (0 points)
    Ok, browsing around, I found a few links.
    If your vnc server does not self-register, then you'll need to
    1) Request that they support zero-conf
    2) Workaround until then:
    Run the following command on the commandline in XP (or figure out how to start it as a service)

    dns-sd -R <Name> rfb.tcp . <portyour_vnc_server_is_runningon Default is 5900>
    Replacing Name with the Name of your machine, and the long <port_...> thing with either 5900 or whatever port you are running your vncserver on.
  • J. Everett Level 1 (35 points)
    Actually, the 'dns-sd -R' command only registers a service running on the machine on which you are running the command. Notice how there is no parameter for the remote host's IP.

    To register a service running on another machine, you have to use the proxy command, 'dns-sd -P'.

    The syntax, per the command help, is:
    dns-sd -P <Name> <Type> <Domain> <Port> <Host> <IP> \[<TXT>...\]

    Playing around with it, I've only been able to get it to work as such:
    dns-sd -P label rfb.tcp local. 5900 name.example.com

    Strangely enough, I had to pass it both a fully-qualified host name that resolves properly in DNS (or maybe .hosts -- I didn't test that) AND the IP address (even though I'd think if it had one, it wouldn't need the other.) Also, just the host name without the fully-qualified domain didn't work either, even though it resolves fine for ping, etc.

    Alternatively, one could use a program like Rendezvous Proxy.
  • 3zzy Level 1 (0 points)
    I have this exact same issue. I have a PC (XP) with RealVNC installed. Although I can connect to it using 'Chicken of the VNC' but with manual configuration.

    I have Bonjour installed on the PC, what do I need to do so that mac and other devices (iphone) automatically finds it?