4 Replies Latest reply: Feb 1, 2009 1:27 PM by David Kahauolopua
Linda P Level 2 (160 points)
Suddenly today I can not access iTunes. I get a message saying +"The iTunes Library file is locked, on a locked disk, or you do not have write permission for this file."+

I'm totally bewildered and don't know what to do. Advice will be so very, very welcome. The only thing I can think of is that perhaps the version of iTunes was upgraded inadvertently. The computer I'm having a problem with is an iMac running on OS 10.3.0.

I'm just hoping this will be easily resolved and I haven't lost my library.

Thanks in advance for any help you can give.


iMac, Mac OS X (10.3.x)
  • Diane Wordsmith Level 5 (6,000 points)
    Well, first things first: You need to navigage to your iTunes application thru Finder and Get Info on the application to see what version it is. (iTunes 8 will NOT run on your system...which I am personally very aware of, as I'm on 10.3.9). If you have 8, which I rather doubt, it's not going to work.

    More likely, your permissions have gotten messed up. Navigate to the iTunes Music Folder on your hard drive. Get Info on that outermost folder. Look under Ownership & Permissions to see that you have Read & Write permissions on the folder. If you don't, change it. And then, very important, click Details and click Apply to Enclosed Items.

    Post back and let us know if you have any luck.
  • Linda P Level 2 (160 points)
    Diane -- thank you so much for responding to my question. Somehow I managed to get iTunes up and running. I noticed that my desktop didn't look right either, so I shut down my computer and restarted. Still no luck, so I tried again and the result was a happy computer -- for whatever reason.

    Again -- thanks!
  • Heather Leah Level 1 (0 points)
    I'm having the same problem... I let my brother borrow my macbook to type a paper, and now whenever I attempt to open itunes, I get the "locked itunes library file" error message. I've checked all the permissions for every itunes related file, and I still have read-write access. Some forums suggest copying and deleting the xml file, but do I really have to resort to that or is there a better way to fix the issue?

    thank you for any help,

  • David Kahauolopua Level 1 (25 points)
    copied this from another post hope it helps you, i am having the same issue now:

    You need to check and see that you have both Read AND Write permission on the iTunes Music folder AND on all folders within it. Log in to the account where the library resides and navigate to the music folder thru Finder. Get Info and check your permissions. To change them, you may need to input the Admin password. Also, and very important, make sure that Read and Write permission is applied to ALL enclosed folders. (Check this under details.) Set your pemissions to allow you Read/Write permissions to the iTunes folder (\Music\iTunes\)and everything in that folder.

    I had copied over my entire iTunes folder. This included the following:
    iTunes Library
    iTunes Library Extras.itdb
    iTunes Library Genius.itdb
    iTunes Music Library.xml

    Because they were set to default to the admin acct, when they copied over they retained the admin only read/write access.
    I had originally only checked the iTunes Music Library.xml file for access issues.
    Thank you for your help!!!