Previous 1 2 3 Next 169 Replies Latest reply: Jul 17, 2010 2:14 PM by BDAqua
Jona Level 1 (65 points)
This currently reported problem, which manifests after applying Security Update 2008-06, can be fixed permanently by removing the following preferences files:

Go to Library/Preferences/SystemConfiguration and delete the following (suggest make copies to the desktop first if in doubt):

com.apple.airport.preferences.plist
NetworkInterfaces.plist
preferences.plist
com.apple.nat.plist

All these files will regenerate as necessary when the associated system features are accessed. If you're using Airport or Internet Sharing you'll have to reestablish the appropriate settings, because these will have been lost when the preferences files are removed. Small price to pay, however for a permanent, and very simple solution to this irritating problem.

MacBook Pro 2.16 GHz, 2GB RAM, 100 GB Seagate 7200rpm drive., Mac OS X (10.4.11)
  • BDAqua Level 10 (122,202 points)
    Thank you Jona, just linked to your Post!
  • WZZZ Level 6 (12,835 points)
    Since these files are owned, I believe, by system what do you need to do to move them to the desktop?

    Thanks
  • Jona Level 1 (65 points)
    Bless you, BDAqua!

    There are a multitude of complex and temporary workarounds being posted here, but so far the good old-fashioned approach still seems to be the easiest and the best: merely trash those associated preference files...
  • Jona Level 1 (65 points)
    WZZZ,

    First drag them to the desktop to make COPIES.
    Then drag the ORIGINALS to the trash. You'll be asked to authenticate this action, so just type in your password and you'll be able to trash the files.
    Then restart, and the problem should be solved.
  • WZZZ Level 6 (12,835 points)
    Thanks. I didn't think I'd be allowed to do anything with them at all. even drag them to the desktop to make copies.
  • roobp57 Level 1 (0 points)
    hope this does not sound stupid, I tried this methodology and the new preferences were not generated. Basically, after dragging those prefs out of that location, the next time i restarted the computer i was unable to connect to the internet. When i looked into the system config folder it was empty. Once i placed the saved prefs back in that folder i was able to connect again. Did i miss on a step there? how do i get system prefs to restore my network connections?
  • jawnl Level 1 (25 points)
    You'd have to open up your Network Panel and reinsert the appropriate data into it... then your new network preferences would be created...
  • edrixc Level 1 (50 points)
    Hey JOna! Thanks so much. This is working for me!! Can't believe that i went through so much threads before seeing yours.

    Im currently monitoring it if it changes. But for the past 15 minutes its been good
  • edrixc Level 1 (50 points)
    Oh another thing for everyone reading this thread...

    Try to write down on textedit or on a piece of paper your network preferences. Because everything will be erased. this is the unfortunate consequence of THE SOLUTION.

    I have five locations, so I needed to write it down, plus I had bluetooth settings for my nokia e90 to connect to the internet if wifi wasn't available. I also had ethernet settings for my PPPoe internet service, I had automatic wireless settings for my router.. etc.etc..

    So you gotta write it down

    Thanks again Jona!

    -edrix
  • MikeUnit11 Level 1 (15 points)
    Thanks Jona.

    Your solution fixed my MacBook as well. It's a small price to pay to have to go through the network setup again but well worth it. I hope the many others who have this problem direct themselves to your solution.

    Mike
  • kevinkendall Level 1 (115 points)
    wow.
    kool.
    I am gonna give it a whirl, Jona. ThankyaThankyaThankya!!
    That Network pop-down window was makin' me CUSS, man!
    My temp solution to the prob was to click the OK button on the popdown, & then quickly get my mouse arrow over to the "Location" miniwindow that the popdown covers (sometimes took me 10-15 tries..... gotta be quick) & left-clicked on it. After I finally got it, I'd then add a new Location (I have only 1, so I ended up just serializing the things.... 1, 2, 3, 4, 5...... made me mad.
    I couldn't believe that a bug THIS obvious (& apparently now ubiquitous due to its entrenchment in the R-6 "fix"'s fundamental code, having nothing at all to do with a machine's hardware particulars, it appears to me in these posts).

    Funny how the 98, XP, 2000, & WinMac (Vista) simplest procedural fixes are the complete opposite to Macintosh's simplest procedural fix:
    PCs: Overwrite or add 1 or a gazillion files. IN their proper locations!
    Mac: Dump 1 or 2 files, restart the app, reset the prefs.
    hehehe

    I'm a reinstated Machound, having started on SE's in the late 80's, then got sucked into Gates' darkside for longlong (used to work for Gateway, MS & HP even), but now I'm a Mackie. No more Windows stuff. Frankly, it used to be an ego trip, I now surmise, for me to fix the silly things. Which was a constant chore. CONSTANT. Now, I just want the darned things to work, PERIOD. I'm gettin' too old to be thrilled by clever fixes of intrinsically flawed machines. Childish, really.... <G>

    <Edited by Moderator>
  • titanman Level 1 (0 points)
    When I go to Library/Preferences there is no SystemConfiguration file to open????
  • BDAqua Level 10 (122,202 points)
    Hi titanman, and a warm welcome to the forums!

    Perhaps you're not in the right Library!?

    There is one at root, and one in your User's folder...

    Library/Preferences/SystemConfiguration/

    Users/YourUserName//Library/Preferences/
  • edrixc Level 1 (50 points)
    To be more specific:

    macintosh HD (or whatever the name of your hard drive is)/library/preferences and system configuration.

    Not:

    Users/YourUserName//Library/Preferences/

    Hope it helps.
Previous 1 2 3 Next