Previous 1 2 3 4 Next 169 Replies Latest reply: Jul 17, 2010 2:14 PM by BDAqua Go to original post
  • kevinkendall Level 1 (115 points)
    This is to Jona:
    -----
    Jona wrote:
    This currently reported problem, which manifests after applying Security Update 2008-06, can be fixed permanently by removing the following preferences files:

    -----
    I did it, & _+*it worked!*+_
    My next step, if the procedures you posted hadn't worked was to run the 10.4.11 combo update DMG that fixed a CarbonLib error window problem I had a month or so ago. But didn't have to take that road....
    Regarding the R-6 update, it appears that the codemakers gaff was to leave out code that would remove one or more of the preference files you listed, or to leave out reformatting one or more of those prefs for proper cooperation with the update's other inclusions/alterations/etc.
    Thankyou for the help, Jona!
    kevinkendall
  • Carolyn Samit Level 10 (103,365 points)
    That's many thumbs up for your post Jona. I linked to it also.

    Thanks!

    Carolyn
  • chowderhead51 Level 1 (0 points)
    It works! Piece o' cake. Thanks a million, Jona.
  • Saxman Level 2 (175 points)
    edrixc wrote:
    Oh another thing for everyone reading this thread...

    Try to write down on textedit or on a piece of paper your network preferences. Because everything will be erased. this is the unfortunate consequence of THE SOLUTION.


    So you gotta write it down

    Thanks again Jona!

    -edrix



    I'd just like to know how I can write down the network preferences, when that window that won't go away is blocking access to my network settings?
  • MikeUnit11 Level 1 (15 points)
    Try this little trick:-

    Get to the state where that pesky dialog box arrives; it will have a blue 'OK' button. hover your mouse pointer over something like 'Assist' further down. Now, press the enter/return key and as soon as the box disappears (you have a fraction of a second!), click your mouse. You may need several goes but at least you'll temporarily get to your network pane. You can then quit normally if you want rather than force quit. As you step through, you may have to repeat the procedure.
  • David Hollar Level 1 (0 points)
    I have read the posts for THE SOLUTION but I am unable to find the files listed. I have gone to Users on my HD and then to my user name. I then open Library/Preferences. I find many .plist files but not the four mentioned.
    400mHz Pismo running OS X 10.4.11. I have it set up for two users. Will this make a difference on the location of these files?
    thank you
  • Adrian Clarke1 Level 4 (3,580 points)
    Hi David, You should be looking in Macintosh HD/Library not Macintosh HD/Users/Username/Library.

    "Go to Library/Preferences/SystemConfiguration and delete the following (suggest make copies to the desktop first if in doubt):

    com.apple.airport.preferences.plist
    NetworkInterfaces.plist
    preferences.plist
    com.apple.nat.plist
    "

    Good luck,

    Adrian
  • David Hollar Level 1 (0 points)
    Thank you Adrian, I found the files. I decided to try this one at a time. After backing up to desktop, I removed the preferences.plist. Restarted and re-entered my various network settings. Restarted again just to be sure. So far, the problem has cleared up!
    Again, thank you
    David
  • JJBraunius Level 1 (105 points)
    Worked for me, thanks!
  • pfil Level 1 (0 points)
    This is not a solution. It's a workaround for sysadmins. Where do we post bug notices for Max OS X?
  • tobias Eichner Level 3 (570 points)
    This is not a solution. It's a workaround for sysadmins. Where do we post bug notices for Max OS X?


    I agree. The original poster's tip is surely worth being mentioned here and works well. But I'm also not willing to lose all of my network preferences to fix this. It is a bug of Mac OS X (or being more specific, a bug of a recent security update) that needs to get fixed by the vendor.

    Waiting for the next security update...
  • Hugo Perezcano Level 1 (20 points)
    I had the same problem. In addition, it screwed up the internet connection for all standard user accounts. After installing the update from Apple, in addition to the endless loop, the system began requiring an administrator's name and password in order to allow standard users to connect to the internet every time they logged in. When airport card tried to connect to the wireless network for a standard user, a dialog box popped-up requiring an administrator's name and password in order to allow changes to Mac OS X. It did not connect otherwise (although the wireless station was visible).

    Clicking "Require password to unlock each secure system preference" in Security preferences, as suggested in the http://discussions.apple.com/thread.jspa?threadID=1712387 thread, solved the loop problem, but no the internet connection for standard users.

    Trashing the System Configuration preferences as suggested by Jona solved both.

    Thanks.
  • IchMe Level 1 (0 points)
    I have a correlated issue with a brand new Tiger installation (combo and software updates made, of course). The network preferences pane crashes when you wish to see the airport settings. The removal of /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist fixes it at least temporarily.
    Looks like a conflict between modifications made to this file from the prefs pane or the airport settings in the menu bar.

    BTW, the naming convention and the owner of this file make me think it should be in ~/Library/Preferences.
  • BDAqua Level 10 (122,252 points)
    Hi,

    /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist

    Is the correct location.
  • IchMe Level 1 (0 points)
    At least it's where it was in Panther.
    It's not so much the owner (system, fine) but the group which is odd: when the file is created by the airport settings in menubar, it's wheel, when it's created by the network prefs pane, it's the user's group. Funny!
Previous 1 2 3 4 Next