1 2 Previous Next 18 Replies Latest reply: Nov 3, 2008 4:19 AM by Chris Murphy Go to original post
  • 15. Re: Java Applet Won't Launch after Apple Software Update to Java Release 7
    steve5719 Level 1 Level 1 (0 points)
    Good morning William. I had the same problem and contacted eTrade. They are working on resolving the problem ( Mac only gave them 24 hours notice of the new version of Java ). The estimated time is 2 weeks. In the meantime your only option is to reinstall OSX from your disk that came with your MAC. Before you do so, make sure that you know how to "Archive" your old system, if you just reinstall, you may loose a lot of info. The number to call is 1-800-275-2273 for assistance. Before you start anything please " BACKUP " !!! When all this is done the MAC will prompt you to "Update Software", you need to uncheck the last software update that contains the new version of Java, it is stuck in the big bundle !!!!! Good luck.
  • 16. Re: Java Applet Won't Launch after Apple Software Update to Java Release 7
    William W. Higgins Jr. Level 1 Level 1 (5 points)
    All-

    E*Trade has a workaround. It worked for me, and is less onerous than re-installing Mac OS X v10.4 from scratch (and skipping the Java update). I'll do my best to reproduce E*Trade's workaround here, but usual disclaimers apply (may not work for you, don't blame me, etc.).

    Big Picture: Remove a specific line of code from the file "etpro_launch.jnlp" that is downloaded to your Mac each and every time you click the "Launch" button (Power E*Trade Pro) from E*Trade's web site.

    Detailed Instructions:

    1) Log into E*Trade in the usual manner, and click on the "Launch" button for Power E*trade Pro.
    2) A file named "etpro_launch.jnlp" will be downloaded to your Mac. The file name may be slightly different and/or suffixed with a numerical index if previous versions of the file were not automatically deleted after each session.
    3) The file should be located at ~/Library/Caches/TemporaryItems/
    4) Control-click on the file "etpro_launch.jnlp" and choose "Open With->Other..." Open with TextEdit (or similar).
    5) IMPORTANT: This step deletes a line of code. Be sure you delete the right one!
    Scroll down to the very bottom of the file, and delete the line that reads:

    <j2se version="1.6" initial-heap-size="256m" max-heap-size="512m"/>

    This line is one of two VERY similar lines in the file. White space surrounds these two lines, so they should be easy to find. The line to be deleted was the first of the two. The second of the two lines remains.

    6) Save the file (no need to change the name or location, etc.).
    7) Double click on the file just saved.
    8) Power E*trade Pro should launch properly.


    I'll use this workaround until E*Trade comes up with a more permanent fix/makes their launch routine compatible with Java for Mac OS X v10.4, Release 7. No need to do clean install of OS.
  • 17. Re: Java Applet Won't Launch after Apple Software Update to Java Release 7
    steve5719 Level 1 Level 1 (0 points)
    I have to go and cook dinner now, but if this works, I will buy you a drink !
    I will try it as soon as I can. Thank you for the post. I feel better now that I know that I am not the only one having this problem. All the experts always make you feel like you are stupid and just not understand it. Thank you again from the bottom of my heart.
  • 18. Re: Java Applet Won't Launch after Apple Software Update to Java Release 7
    Chris Murphy Level 1 Level 1 (0 points)
    This worked after a couple of tries. Trick was to get a fresh etpro_launch.jnlp by logging into etrade and launching poweretrade. Then modified the file as described. Seems to be working now.


    Thank you, Thank you!
1 2 Previous Next