12 Replies Latest reply: Oct 8, 2008 1:40 PM by HawaiianHippie
HawaiianHippie Level 1 Level 1 (0 points)
I've got 26 students working on their first projects, and this has popped up twice now.

Start with a clip on the timeline. Select it. Go to video effects. Choose an effect. Watch the preview. Click "apply." Wait for the render to complete. POOF! What once was a video clip is now silent black!

I tried restarting, deleting preferences, and permission repair. I even tried moving the project to an adjacent computer (a time-consuming process via gigabit ethernet). No luck.

No shortage of drive space... all the machines have an excess of 100 GB free.

In one case, the offending effect was "Earthquake." In the other case, the effect was "Fast / Slow / Reverse"

All the machines in question are Intel based iMacs. One is last year's white plastic 20" model, the others are brand-new aluminum 20". All upgraded to 2 GB RAM. All running OS 10.5.4 and iMovie 6.0.4

How do I make it work?

Thanks!!

Various and sundry, Mac OS X (10.5.5), Run a lab, got a lot.
  • Bengt Wärleby Level 6 Level 6 (19,460 points)
    Hi

    Are they connected to a server ?

    100Gb free space. On what drive. Free space is only of interest when it concerns
    the drive with Mac OS and iMovie.

    iMovie can't address any other scratch disks and iDVD is even worse regarding this.

    If the Macs are run individually/solitary not as part of a network.
    • And there is more than 25Gb free space on booth drive (after material is imported)
    • Start a new User/account and log into this and have a re-try

    Net-work situations: Contact administrator for an eventually re-start of Network-system

    Yours Bengt W
  • HawaiianHippie Level 1 Level 1 (0 points)
    The free disk space is on the local drive for each machine.

    Starting a new user account doesn't change the problem.

    There is a file server available to the students, but it isn't used for video storage. And, specifically, the two projects I'm referencing are not on the server, but on the local desktop.
  • Bengt Wärleby Level 6 Level 6 (19,460 points)
    Hi

    And Mac OS is on the local drive or on the Server ?

    Yours Bengt W
  • HawaiianHippie Level 1 Level 1 (0 points)
    The OS is on the local drive.

    iMovie is on the local drive.

    The projects are on the local drive.

    And the local drives all have exceedingly large amounts of free space, well over 100 GB.
  • Bengt Wärleby Level 6 Level 6 (19,460 points)
    Hi

    *Not knowing the origin to Your problem - General approach when in trouble is as follows:*

    • Free space on internal (start-up) hard disk if it is less than 10Gb should rather have 25Gb

    • Hard disk is untidy: Repair Permissions, Repair Hard disk (Apple Disc Util tool)

    • Delete iMovie pref file - or rather start a new user/account - log into this and re-try

    • Third party plug-ins that doesn't work OK (not relevant for iMovie’08)

    • Program miss-match: iMovie 5.0.2, up to Mac OS X.4.11 AND QuickTime 7.4.1 - is OK
    • Program miss-match: iMovie 6.0.3 or 6.0.4, Mac OS X.4.11 AND QuickTime 7.4.1 - is OK (might work under Leopard)
    • Program miss-match: iMovie’08 v. 7.0.1, Mac OS X.4.11 AND QuickTime 7.4.1 - is OK (might work under Leopard)

    • Screen must be set to Million-colors

    iMovie pref file resides:
    Mac Hard Disk (start-up HD)/Users/"Your account"/Library/Preferences and is named: com.apple.iMovie.plist
    While iMovie is NOT RUNNING - move this file out to desk-top.
    Now restart iMovie.

    From LKN 1935: (in this case = iMovie HD (5), I tried it all, but nothing worked.
    Your answer (above) has been helpfull insofar as all the different trials led to the conclusion that
    there was something wrong with my iMovie software. I therefore threw everything away and reinstalled
    iMovie from the HD. After that the exportation of DV videos (there has not been any problem with HDV videos)
    to my Sony camcorders worked properly as it did before.

    Yours Bengt W
  • HawaiianHippie Level 1 Level 1 (0 points)
    Most of these have been tried. Let me be systematic in replying, though:

    -origin of the project: standard definition NTSC DV footage, capture from various models of Sony camcorder. Both are short projects, under 2 minutes.

    -Free space: ample. Well over the 25 GB recommended.

    -untidy disk: ran permission repair; did Unix daily, weekly, and monthly housekeeping; restarted; zapped PRAM

    -iMovie prefs: deleted

    -user account: tried creating a new one

    -third party plug in: none installed

    -program mis match: using iMovie 6.0.4, OS 10.5.4, Quicktime 7.5

    -screen setting: million colors

    -deleting and reinstalling software: not tried, but seems an unlikely solution since when the projects are transported to other computers, the problem persists.
  • Bengt Wärleby Level 6 Level 6 (19,460 points)
    Hi

    • +projects are transported to other computers, the problem persists+ •

    Can it be so that it has been transported via an external hard disk that are
    wrongly formatted ?

    It HAS TO BE - Mac OS Extended (hfs+) formatted:

    UNIX/DOS/FAT32/Mac OS Exchange WILL NOT WORK - BUT HARMS THE PROJECT

    Yours Bengt W
  • Frank Cushing Level 2 Level 2 (340 points)
    I'm between classes but this is a guess. I think it's a quicktime problem. A search seems to indicate problems started with the last quicktime version update. In my classroom I never upgrade since they are not networked and we won't go beyong imovie 6 unless I go to FCE.

    If you could try downgrading a version that might fix it.

    Another try would be to export the offending clip as a full quality QT and then reimport it and apply the effect. I fixed a slow motion clip using this method.

    This is all off the wall advise but an archive search shows no one has fixed the problem.
  • HawaiianHippie Level 1 Level 1 (0 points)
    Thanks, Frank.

    I searched the forums before posting, and also noticed that others with this exact problem never found resolution. I didn't catch the coincidence between the date of the reports and the release of the latest QT. How would one go about downgrading?

    I'll try the export. It's a pretty clumsy work-around, but I suppose that's better than a non-functional effect!
  • HawaiianHippie Level 1 Level 1 (0 points)
    Aloha Bengt

    As I mentioned in the initial post, I transported the projects over the Ethernet network. External drives are not used for this class in any circumstances.
  • Bengt Wärleby Level 6 Level 6 (19,460 points)
    Hi

    But but but . . . Isn't there hard disks on the other end of the Ethernet system ?

    Can it be so that there is a PC-server on the other end ?

    If so. Then I doubt that this way to work will be fruitfull. My spontaneous guess
    would have been - Can't work with movie files more than 4Gb in size (20min) totally.

    I would even have guessed that it wouldn't work at all.

    But this is more my lack of knowledge that visdom.

    Yours out on a slippery ice. Bengt W
  • HawaiianHippie Level 1 Level 1 (0 points)
    Aloha Bengt!

    You're needlessly complicating this. Sure, there are other computers on the network. Sure, some of them are PCs. Some of them are servers. Heck, some of them are printers and scanners! The network spans our entire campus. And it is completely irrelevant.

    All of the machines in the lab are physically, directly connected to the same ethernet switch. When you enable file sharing, these machines can send files directly to each other. There is no external hard drive, no server, no PC involved. If you were to take two of my macs and connect them directly to each other using a crossover ethernet cable, it would be the same thing. The issue, whatever it is, has nothing to do with corrupted project files or incompatible hard drives. I move projects around this way all the time for grading, and have never had any problem (other than lack of patience shuffling massive files over ethernet).

    The project files aren't large. One of them is a :30 second commercial, the other is about 2 minutes, a trailer for a horror movie. Neither has more than 15 minutes of total footage, and none of the individual clips are longer than a minute. Nothing approaching 4 GB.

    I'm increasingly certain that this is a bug. It's something unique to iMovie 6.0.4 or QT 7.5.5. Looking over this forum, I've seen 4 other posts where people were reporting this exact problem. 3 of them were never resolved, the 4th "fixed" it by reinstalling his OS, Quicktime, and iMovie. That's not something I can do to 21 computers in mid-semester.