7 Replies Latest reply: Oct 9, 2008 10:47 AM by JohnMcL69
Gully Level 1 (100 points)
Hi all...I've been using my bluetooth headset with my 3G since I bought it. I hadn't used it in about a week and the bluetooth setting on the phone was turned off.

When I attempted to turn it on under "settings" this morning, it just won't turn on. The spinning graphic just keeps spinning and the bluetooth menu that usually opens will not open. It just hangs.

Is anyone having this problem or does anyone know what is causing it?


iMac 20" Intel (Early 2006); PowerBook Pro 17", MacBook, iPhone 2G, iPhone 3G, Mac OS X (10.5.4)
  • DaVBMan Level 6 (9,265 points)
    Try a reboot (described below).
    Think of it this way, the iPhone is more of a computer than a phone. It suffers from being a new OS and nobody can deny there are not bugs and memory leaks. The longer left running, the more things start to fail or slow down (I have had the iPhone since day one of original phone and I am just speaking from my experience). Thus I equate it to like when Windows95 came out...not sure of your age or if you remember those days...but back then it was a running joke of how many days you can keep Windows 95 running before you had to reboot. I am sorry to say but the iPhone is the same way right now (but getting better with a few hiccups back during the 2.0 release). So for me, I reboot daily when I leave in the morning and take it off the charger. By doing so I rarely see any lag or problems.

    A reset/reboot is:

    Go to Home Screen
    Press and Hold Home Button
    Keep holding and press and hold Lock Button
    Keep holding Both
    You will see Slide to Turn Off (Don't let go to slide, just keep holding)
    The phone will turn off (in time, but screen will look like it has some white lines)
    Keep Holding
    When you see the Apple Logo, you can let go.

    Turning off via the Slide to Turn off while good and fine to turn off, is more like the Sleep Mode on a computer. Thus any locked up issues in memory remain when you turn back on. A reboot as described is like doing a real Turn off and Turn On on a computer.

    You may also wish to read this tread about reboots and odd application behavior.
  • Gully Level 1 (100 points)
    Thanks for the suggestion...but I have done that three times already. I usually reboot twice per day.

  • Gully Level 1 (100 points)
    Anyone out there having this issue? It's the weirdest thing...it just want start up. I've rebooted several times.

  • icebike Level 3 (740 points)
    The spinning thing happens even on a phone that has bluetooth on. All it means is that it is looking for devices, and is discoverable. So I don't put much stock in that.

    The iPhone has the most seamless pairing of any phone I've owned. With all others that I have had you always had to do something on the phone to pair. With iPhone i just turn on my headset and its paired instantly.

    Have you tried unpairing?
  • Gully Level 1 (100 points)
    I agree that it's seamless...and it has been for the three months I've had the phone. But now, it won't recognize my headset even when it's in pairing mode.

    It's just not working.
  • Gully Level 1 (100 points)
    PROBLEM SOLVED! I just went to the settings reset and it worked.

    Thanks to all.
  • JohnMcL69 Level 1 (0 points)
    So, let me get this straight...

    In order to get my bluetooth turned back ON, I need to reset the entire device? Please explain your 'solution' in further detail please. This is entirely NOT enough information.

    I have an orig 16Gb iPhone with version 2.1 of the iPhone OS installed. I have rebooted (using the method provided) twice.

    When the device powers back up, I go to general settings, bluetooth, and the service is set to OFF. I tap the ON button and the progress indicator spins endlessly until the screen dims and finally the saver kicks in.

    The service never appears to fully initialize.

    I have also attempted to pair my brand new jawbone 2 headset while this progress indicator is rolling but the two devices do not identify each other. The jawbone is IN pairing mode, but, the iPhone never recognizes this device. The progress indicator just rolls and rolls and rolls.

    I'm going to repost this as a new issue.