9 Replies Latest reply: Oct 22, 2008 8:40 AM by Drew Reece (Re:co)
pamboat Level 1 Level 1 (0 points)
I'm trying to SAVE my project and I keep getting an error that says "Operation not allowed." I am using FCP 6.0. I've tried saving on both my external hard drive and my internal HD, and still nothing. I don't want to loose my work. Nothing else is running but FCP.

Any ideas?

Macbook Pro
  • FCPSteve Level 1 Level 1 (10 points)
    Hi,

    Have you tried using 'Save As..' and saving the project under a different name. If that doesn't work export your sequences and bins as xml files, then re-import them into a newly created, empty project.
  • Drew Reece (Re:co) Level 2 Level 2 (310 points)
    Did you manage to resolve this issue?

    It has happened to me on a MacBook…

    Some info from Apple System Profile
    Model Identifier: MacBook1,1
    Processor Name: Intel Core Duo
    Processor Speed: 2 GHz
    Memory: 2 GB
    OS : 10.4.11
    Final Cut Pro 5.1.4

    I was working on a project, I put the laptop to sleep for 2 minutes. I returned, played the timeline and hit Command-S and was given a dialog stating 'Operation not allowed'. Choosing the menu item also produces the error.

    My actual project file and media files are on an external drive.

    If I try Save as… I also get 'Operation not allowed' when saving to the HD or an external drive, but the name of the project changes. If I wait for an auto save to run, it asks to provide a name to save the project (as if its a new project), then the save fails, closely followed by the auto save failing - same error.

    It makes no difference where I try to save.

    This is insane - how can I avoid loosing work! Does XML keep all the audio levels and generator text I have applied to my sequences?

    I managed to export an XML file.
  • RedTruck Level 4 Level 4 (2,145 points)
    try going to the file where it lives, with FCP still open. Select the file, choose GET INFO form the file menu or press cmd-I, go down to the Sharing and Permissions section and make sure you have Read and Write access to the file. If not, click on the lock, type your password, and change it. If you let the computer go to sleep and you require a password to wake, you might have created some corruption in the file. Worth a shot. Not sure what else to do.
  • Kevan D. Holdsworth Level 4 Level 4 (3,320 points)
    Might also try opening your most recent 'autosave' version and see if you can re-save it with an updated filename.

    Hopefully, you've got autosave working.

    K
  • Drew Reece (Re:co) Level 2 Level 2 (310 points)
    RedTruck,
    The file is owned by my user account, and I have read & write permissions. I also cannot save it anywhere else so permissions doesn't seem to be the issue.

    Kevan D,
    Autosave was set to 15 minutes, but the last one is almost an hour old. maybe it gave up saving them and didn't warn me. I'll try restoring it if I don't get everything back when I create a new project using the XML export.

    Thank you both for the suggestions.

    Drew
  • RedTruck Level 4 Level 4 (2,145 points)
    okay, I have only one comment, because I am not sure if this applies to FCP, but this is in relation to a Microsoft Word issue I had once.
    There is something called an "open file limit" for every operating system, as well as for every application. The limits are different. If you think about what gives you the ability to "undo" something, it means there are open files for every version (undoable actions) that you can make. So if you have 99 undoes set in your preferences, you have 99 files open in the background. There is a limit to how much you can have open all at once. In Word, it wouldn't let me save a project and the autosave had stopped saving over four hours earlier, without warning. When I tried to save the document it said the same "operation not allowed" and said it was out of memory. I tried to do a save as and it "quit" on me, and I lost a ton of work. I found a post explaining this topic, and the fix was to locate the open file location, which I sure is different for FCP and I don't know where it is, and then delete all of the open files. This is called "nuking the undoes..." Once you do this, you can no longer undo anything, but at least you can save your project.
    Maybe letting the computer go to sleep while in the middle of a project is a bad idea. I don't know, but I would NEVER let my computer go to sleep with a project open. I would save it, then close it, and re-open it when I returned.
    Hope you get this figured out.
  • Drew Reece (Re:co) Level 2 Level 2 (310 points)
    Interesting point.

    I had the set option to keep 50 copies of the project via the Autosave feature. I don't think it keeps these files in open in memory, but the undo operations certainly are kept there. I only have 10 levels of undo set, and at the time of the error I had free memory (I checked in activity viewer).

    If it happens again I'll try some Terminal commands to see what files are open.

    For what its worth the XML does seem to keep most of the settings in my sequence, so the titles & audio leves are the same. I started with a new project and reimported the media.
  • David Bogie Chq-1 Level 7 Level 7 (25,175 points)
    There are so many weird things that can cause a file to return "operation not allowed." Hard to even begin to guess where to start looking on your system since I'm not looking over your shoulder but try searching the forum for the error term. We've been trying to help folks with this issue for many years and only a few of the solutions have ever been similar. And, even worse, most of the folks we've tried to help with this error have never bothered to close their threads so we don't know if anything we offered helped.

    This error can be returned for any file in any application so you might try searching the OS10 forum also.

    bogiesan
  • Drew Reece (Re:co) Level 2 Level 2 (310 points)
    I thought it was just another useless FCP error, but now I think about it FCP errors usually have a useful error code with them.

    I'll try searching if it happens again, bogiesan. I'm right in the middle of a deadline project at the moment, and I'm working on the MacBook because my G5 ceased working with 2 processors.
    http://discussions.apple.com/message.jspa?messageID=8317951#8317951

    Not a good month for me with Apple kit.