12 Replies Latest reply: Nov 14, 2008 12:54 AM by hOUSEMEiSTER
Stereobot Level 1 Level 1 (0 points)
I have a 1st Gen 32GB iPod Touch, less than 2 weeks out of the box. I recently had a Mac Genius do a factory restore on it and upgrade the firmware to 2.1 successfully.

Last night I bought (some were free) about 8 apps using the App store directly from my iPod. I first had to log into my iTunes account, no prob. The choses apps downloaded and installed just fine.

NONE of the downloaded and installed apps will work. I open them, and within about 3 seconds I get kicked back to the Main Menu. I tried turning off the iPod and turning it back on, no luck.

I called Apple Care and the guy I talked to gave me a weak generic answer. He said to "RESTORE" the iPod, then sync it back up to the computer, re-install the apps.

#1 I'm not going to restore my iPod again, why should I? It had nothing on it when I downloaded the apps, so redoing exactly what was done won't help. I explained this but he did not elaborate on why it would work.

#2 Why should I have to sync my iPod to the computer or to iTunes? Doesn't that defeat the purpose of having the app store right on my iPod?

#3 These aren't obscure Apps, they all have at least 5 reviews.


Anyone know what is going on? How can this be fixed? I did try Resetting my iPod (Turning it off then on again), no luck.


I did receive an invoice via e-mail, so I am 100% that the apps downloaded fully and properly. If I am paying for these apps, they really should work, I guess that isn't too much to ask..

PowerMac G5, 12" Powerbook G4, iPod Touch 32GB, Mac OS X (10.4.11), Current Apple Care Customer
  • Stereobot Level 1 Level 1 (0 points)
    Just like the time I had to figure out the Airport Extreme for myself, didn't get the help I needed when I called Apple Care, I will answer my own question here too..

    I could not open the apps that I bought and downloaded, all kicked me back to the main menu. I bought the apps using App Store directly on my iPod, I have an iTunes account. When I downloaded the apps I had to log into my iTunes account.

    The next day (yesterday) I tried downloading another free app while I was waiting for a haircut using the WiFi in the salon. I was asked to put my password in for my iTunes account again. After that, ALL my apps worked.

    I did NOT have to sync my iPod up to the computer or do a restore. It looks like this is some bug with the iPod not understanding that you are authorized to use the apps, if you do it again (log into the iTunes account from the iPod), it should work, at least it did for me.

    Try downloading another app using a different network (or try with the same, I just happened to be in a different place). Maybe clear your cookies/ cache so that you HAVE to provide account info again when you get an app.

    The key seems to be that you have to provide user info again to verify your iTunes account.

    So before you listed to an Apple Care rep read from a script and tell you to do a factory restore when that clearly won't help anything, try my suggestion.

    (edit) I have had many more positive experiences with Apple than negative, I don't mean to paint a bad picture of my experiences, its just that from my last few experiences, I don't think I can justify paying for Apple Care when I am able to solve my problems better and think more abstractly than the Apple Care "geniuses".

    Message was edited by: Stereobot
  • Rosemary McClure Level 1 Level 1 (0 points)
    I am having the same problem as stereobot. The other night I bought 17 apps using the App store directly from my iPod (I paid for 2 of them). I first had to log into my iTunes account, then downloaded the applications with ease; now none of them work. I get kicked back to the main menu within a few seconds.
  • Duddo Level 4 Level 4 (1,470 points)
    Stereobot wrote:
    ...I did try Resetting my iPod (Turning it off then on again), no luck.



    That's a "Restart", have you actually tried a "Reset"? Hold both buttons, ignore the "slide to turn off" instruction and let go when the "Apple" symbol appears.

    Sometimes this does the trick.

    Good luck,

    Dud.
  • Susan D Fischer Level 1 Level 1 (0 points)
    I'm having the same problem, and tried the suggestion of doing a reset, and it didn't work.
  • Susan D Fischer Level 1 Level 1 (0 points)
    Addendum: downloading another app and entering my Apple ID & password did work, at least for now.
  • pailo Level 1 Level 1 (5 points)
    same thing here.

    i got so mad but, found out. if your apps fail going to the app store and reentering
    your info as far as itunes account and password, it all comes back. i have been having the
    same issues for two weeks, and i wanted to scream until i figured this out!!! AHHHHHH!!!


    joseph
  • bassmann710 Level 1 Level 1 (0 points)
    I am having the exact same problem. Either it needs you to login to let it know you are authorized to use the apps, or there is some kind of memory problem going on - read my thread (it's the only other thread I have posted). Apple please help!!!!!
  • pailo Level 1 Level 1 (5 points)
    also regarding this app "lockout", when trying to take music from my music folder in itunes (8.0.1) my ipod touch will lock me out of my music being uploaded by "drag and drop" method. the only way to put music, movies, tv shows, podcasts, ect.... YOU MUST USE SYNC!!! this never happened before this new itunes update.

    all of my music in the library has been uploaded from my cd collection, and from emusic.com.
    thats really all i have. about 32 gb.

    i want to drag and drop things like before but now i just have to make a sync to that specific playlist to upload any content onto the ipod touch, and making sure i am properly logged into the apple itunes store. if not, everything locks me out.

    it seems very secure, in case your ipod gets in anyone else's hands. but it will make it frustrating if you are not on a wireless network to ensure you are logged into itunes. if you somehow loose that connection (sometimes powering down will cause this to happen) you apps will act dead (the pause load screen and kickback to the main screen for no reason).

    i am just glad others are having the same issue cause i thought i did something wrong after restoring the ipod 5 times.
  • Rosemary McClure Level 1 Level 1 (0 points)
    I finally solved this problem by deleting a few songs off my iPod. I think my ipod just didn't have enough room for the apps, which i was downloading via wi-fi to an already-crammed-full 8gb. Hopefully that works for you!
  • storyline_kid Level 1 Level 1 (30 points)
    This happened to me as well. What I ended up doing was Deleting the Apps then just downloading them from my computer and putting them on my ipod and they have worked fine since then. I am not sure if it works, but someone said try restarting your Ipod (actually turning it off then back on) before you run the app for the first time. But I think apple needs to address this issue
  • sam0147 Level 1 Level 1 (0 points)
    Hi This problem happense often to me, but it usually happens when im not home and i am trying to find out why this problem happense because when I am not at my place and people dont have internet connections it is very frustrating.

    If someone knows why this porblem happense just let me know plz also if you have a solution to that let me know too.

    Oh and by the way the thing that you download an other app and enter your itunes account info really works but just like i said when this happens and your not home and u dont have a connection... what do u do???

    Message was edited by: sam0147
  • hOUSEMEiSTER Level 1 Level 1 (0 points)
    I got exactly the same problem with my ipod touch 2g. I changed my ipod and got an new one from apple in order to see if it has something to do with the hardware but it doesn't.
    Its very frustrating and it really seems that it has to do with the rights. Are there the same problems on the iphone? Apple do something!! Without the apps the ipod touch is useless and i can rather have an classic.