6 Replies Latest reply: Oct 2, 2008 8:23 AM by Envision99
idot Level 1 (0 points)
OK this is driving me mad:

wifi works perfectly for a month or so from new. Then it breaks mid iplayer stream and that's it... no more connections; any attempt to connect to any wifi network results in the "Unable to join the network..."

Now, here's the things i've tried to repair this issue:

reset network settings
turned airplane mode on/off many times
turned wifi on/off many times
hard reset
hard reset + restore of iphone to original state
hard reset + restore of iphone to original state on a different computer
multiple reboots of two different routers
changes of various types of encryption, turning encryption off, changing channel number and network name
full reset of the iphone locally on the device to factory settings

The only thing that has showed a glimmer of possibility is that the iphone will connect to a computer to computer network created by a macbook pro no problem. Though, connecting it to a shared network from the same laptop also fails.

i've even tried bashing the iphone a bit. That didn't work either.

i have tried every possibly combination of reboot, reset, restore, on off on off, possible across multiple routers.


macbook pro, Mac OS X (10.5.5), iphone 3g 2.1
  • Fredrrr Level 2 (150 points)
    When all else fails, I go back to the obvious.

    I assume that your laptop (or whatever) connects to the router just fine...

    Have the phone "forget" the wi-fi then re-look for it. It should then need a password - assuming you have a password on the wi-fi.

    Next up would be to make sure that the phone can not connect to any other wi-fi.
  • idot Level 1 (0 points)
    thanks fredrrr - forget network option is no longer there - have now tried to connect to 3 different wifi networks (different location, different router hardware) to n avail. I can't help but thing this is some kind of IP stack failure in the iphone that isn't fixed by a restore?!

    both laptops, and ipod touch will connect no problems to either of my routers (dlink and time capsule) and get to the internet.

    the other odd thing is that networks in the list now come and go, even when inches from the routers, and never show 3 "bars" but only ever one or two... but when connected to the computer to computer network it shows 3 bars, as expected. This further leads me think that the "signal" displayed in the wifi networks list isn't just about proximity to device, but ability to connect?

    as an IT pro i'm out of ideas on this one!

    Message was edited by: idot
  • Fredrrr Level 2 (150 points)
    I would guess the IP stack failure, but I can't imagine it is not fixed with a restore...let me think about this one...
  • Envision99 Level 4 (1,165 points)
    If the phone isn't working after everything you've tried then it's either a hardware problem, or a newer firmware problem with your phone. You could try reverting back to an older firmware and see what happens.

    Also, when you did your restore, did you also restore your backup file? If you did, try doing a factory restore with only the firmware and don't restore you're backup file (if you haven't already done this).
  • idot Level 1 (0 points)
    OK - as an experiment - how do i downgrade to 2.0? i'm downloading it now but unsure how to apply it?
  • Envision99 Level 4 (1,165 points)
    Turn off your iPhone completely (hold sleep button until the power off slider shows up and turn off the phone)

    Hold the sleep and home button simultaneously for 10 seconds or so and then release the sleep button while still holding in the home button. This will put your iPhone into recovery mode.

    If you haven't already, download the older version of the firmware. Go to this website and download the firmware that is right for your iPhone. When you go to this site, make sure that you download the correct firmware for your 2g iPhone or 3g iPhone. http://www.iclarified.com/entry/index.php?enid=750

    Now connect your iPhone to your computer and open iTunes. iTunes will detect that your iphone is in recovery mode and tell you that you need to restore it. If you are using a Mac you need to hold down the option button and click restore, if you are using a Windows PC hold down the shift button and click restore. This will allow you to choose the firmware file you want to restore to. So when it asks to choose the firmware, browse to the firmware you downloaded from above and it should restore to that version of the firmware.

    Let us know how this works for you. If this method doesn't work either, then I would say it is definitely a hardware problem, even though it already sounds like a hardware problem.