1 22 23 24 25 26 27 Previous Next 391 Replies Latest reply: May 27, 2014 5:47 PM by criddlenation Go to original post
  • 345. Re: MacBook Air no audio output device found ???????? *please help*
    Dinan101 Level 1 Level 1 (0 points)

    I fought with this problem today and creating another login solved the issue.

  • 346. Re: MacBook Air no audio output device found ???????? *please help*
    Dinan101 Level 1 Level 1 (0 points)

    ...and this morning it's not working again. 

  • 347. Re: MacBook Air no audio output device found ???????? *please help*
    marcopolo Level 1 Level 1 (0 points)

    Dinan101

     

    This issue seems to plague the MacAir and no one seems to have the best answer. I was able to correct the problem on my daughter's MacAir by deleting the preference "bezel services". We previously replaced the audio cable and then the problem came back. Since deleting bezel services the issue has not returned for six months.

     

    Here are all of the known steps to recover your audio. (copied from HighTechDad.com)

    How to fix the “No Output Devices found” issue on your Mac:

     

    Reboot – rebooting your computer is a tried and true method for “fixing” all sorts of problems (and it is not limited to just Macs, it works for PCs too!). Sometimes your computer simply gets confused.

    Repair Permissions – this is a good thing to do regularly anyway, especially before and after you install new system software updates. Repairing permissions via the Disk Utility is something that is easy to do but can take a little bit of time.

    Reinstall the latest OS X Software Update – this is a great fix for all sorts of issues as well. Go to the Apple site and download the latest Combo Update for your version of OS X. And be sure to Repair Permissions after installing the combo update.

    Start in Safe Mode – try booting in “Safe Mode” by holding down the Shift key when starting up. Check to see if the audio is working after that. If it does work, there may be some other type of conflict going on and I would continue with the tips below.

    Delete the BezelServices preferences file – this is a mysteriously magical file. It controls those on-screen images that you see when you change the volume, eject DVDs/CDs, change brightness, etc.  But it also seems to be the source of all sorts of odd issues that you can never figure out, and tends to get corrupted. But the fix is easy and relatively safe. Go this preference file (location shown below) and just delete it and reboot. Location & filename:

    ~Library/Preferences/com.apple.BezelServices.plist

    Plug in a USB headset – sometimes your Mac simply gets confused and needs to be literally poked by another audio output device. If you have a USB headset or speaker, plug that in and see if you get audio output through that device. If you do, that’s great! Then try unplugging the USB device and see if your on-board audio output device starts working. (Give it a reboot as well just to be sure it “sticks”).

    Plug in standard headphones – the funny thing is, the fastest and easiest fix is the one that actually worked for me. I just took some headphones from my iPhone and plugged it into the headphone jack and magically the on-board audio output started working (it might have worked had I tried the USB headset fix above – but I couldn’t find one). This was another case of the Mac just needing to be prodded by something to get it going. I DON’T recommend sticking anything else into that headphone jack though (grin!).

    I would love to find out what solution worked for you or if none of them worked. I saw plenty of threads on the Apple Discussion forums around this issue and it seems to happen to any type of portable Mac. If it still doesn’t work, you can take it the Apple Store to get fixed. If you have a MacBook Air, you might want to check out iFixIt.com for an Audio Cable replacement and install which you can potentially do yourself (but only for those who know what they are doing please!).

     

    Remember, if you just keep digging around, you will eventually find a solution.

     

    HTD says: Let me know if this did or did not work for you. Best of luck.

  • 348. Re: MacBook Air no audio output device found ???????? *please help*
    Dinan101 Level 1 Level 1 (0 points)

    Ended up taking it to the Genius Bar.  Needed a new logic board.  All's well now.

  • 349. Re: MacBook Air no audio output device found ???????? *please help*
    WillPar Level 1 Level 1 (0 points)

    I tried everything described above and can't get my "No output devices found" to go away. Got to be a hardware problem.

     

    My Mac Air is out of contract. What is the cost for a new logic board?

  • 350. Re: MacBook Air no audio output device found ???????? *please help*
    airbeau Level 1 Level 1 (0 points)

    I had the same problem, here's how I fixed it; Open Disk Utility, select Macintosh HD (or whatever your hard drive is named), Repair Disk Permissions, once complete-Restart.  Sound is back for now.  Fingers crossed.

  • 351. Re: MacBook Air no audio output device found ???????? *please help*
    airbeau Level 1 Level 1 (0 points)

    Well the previous fix lasted all of 2 hours.  Now I have the sound working again by resetting the PRAM.  Here's how;

    1. Shut down your Mac.
    2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.

    We'll see how long this fix lasts...

  • 352. Re: MacBook Air no audio output device found ???????? *please help*
    airbeau Level 1 Level 1 (0 points)

    A new record!  That fix lasted 10 minutes.  I put the MBA to sleep, when it woke up no sound.  Getting frustrated.

    I've updated my osx, deleted the "bezelservices" file, reset the PRAM, and repaired permissions all to no avail.

  • 353. Re: MacBook Air no audio output device found ???????? *please help*
    WillPar Level 1 Level 1 (0 points)

    I decided to bring it to the genuis bar. They are trying two things. One, see if it is the I/O board (~70), if not, they will send to the repair center for a flat rate fix rate (~280)

  • 354. Re: MacBook Air no audio output device found ???????? *please help*
    M.A Level 2 Level 2 (260 points)

    Everyone....

     

    This is NOT only a Macbook Air issue, My 15" MBP suffers from this as well as my 2012 Ultimate 11" MBA. The minute I installed Mountain Lion and updated to 10.8.2 this issue began for me. Up until then I NEVER had any audio output failure.

     

    This is NOT a hardware issue, very clear that this is a Mountain Lion issue, at least for me.

  • 355. Re: MacBook Air no audio output device found ???????? *please help*
    MLEX Level 1 Level 1 (0 points)

    I recently purchased the newly announced (2012) 13" model MacBook Air (MBA) and I'm running OSX 10.8.2 with 8 GB of RAM (1600 MHz DDR3).  My MBA has a 1.8 GHZ Intel Core i5. 

     

    I'm having problems with my audio, which sometimes cuts off and will not work unless I restart my MBA.  Similar to reports posted in 2008, if I try rebooting/restarting my MBA that will restablish the audio temporarily.  As with some of the reports in this thread, I too have taken my MBA to the Genius Bar only to be told that they will "attempt to repair." 

     

    Has anyone faced and resolved this issue and how?  Please help!

  • 356. Re: MacBook Air no audio output device found ???????? *please help*
    astasf Level 1 Level 1 (0 points)

    I was dealing with the same issue. It happened after updating software.

    I have a Macbook Air Original running Mac OS X Lion 10.7.5 (11G63) (cannot update to Mountain Lion).

     

    I restarted, deleted the Bezel file, reset PRAM and SMC, and now finally after repairing the permissions using disk utility, the sound seems back on.

     

    So, at least for me, it seems a software issue.

  • 357. Re: MacBook Air no audio output device found ???????? *please help*
    Changren Yong Level 1 Level 1 (100 points)

    It's not worth it to get a replacement logic board: $599

     

    http://www.ifixit.com/MacBook-Parts/MacBook-Air-1-6-GHz-Original-Logic-Board-/IF 188-005?utm_source=ifixit_guide&utm_medium=guide_intro&utm_content=required_item s&utm_term=macbook_air_models_a1237_and_a1304

     

    I think i am having the same problem. I thought it was the audio board so i bought one and replaced it but still no sound. I'm not going to spend $599 on my 3-year old MBA.

  • 358. Re: MacBook Air no audio output device found ???????? *please help*
    ianwood Level 1 Level 1 (5 points)

    This problem has been around for years and 24 pages and no one seems to know even if it's hardware or software. My internal speakers have vanished but when I plug in headphones they come back. As result, I would guess it is a software issue but Apple seems to be super keen to replace logic boards at great cost sometimes fixing the problem and sometimes not.

  • 359. Re: MacBook Air no audio output device found ???????? *please help*
    blt26a Level 1 Level 1 (0 points)

    Don't know if this was just me or if it is relevant here but I had this problem this morning.  Had been watching a film via Apple TV from my MacBook Air.  Turned on computer this morning and no sound.

    Fix.

    System Preferences - Sound - Output

    Setting was Apple TV and not Internal Speakers.  Seems like it sometimes resets and sometimes doesn't.