1 2 Previous Next 26 Replies Latest reply: Jan 9, 2009 3:06 AM by mcTsui
blakieto Level 1 Level 1 (10 points)
I am starting to receive repeated situations where the OS reports that my disk is full, and any or all disks are also reported full...
I have emptied my trash, cleared all caches, deleted all logs, removed Apps I don't use (and their data in the Library's Application Support area), every language other than the various flavors of English, and I am still receiving this error.

I have 35 gigs of 148 free on my startup disk, 342 of 465 free on a secondary drive, and when I try Flash drives or drives from a mounted server they also are reported as full.

This sure looks like a OS X 10.4.11 (my OS version) bug to me...

Note, I have to use 10.4.11 because the OpenGL drivers on 10.5 are troublesome for my application development needs. (I write 3D graphics code on this machine.)

Any clues anyone?

MacBook Pro, Mac OS X (10.4.11), X Serve owner, software developer
  • 1. Re: "Disk Full" error when disk is not full
    Carolyn Samit Level 10 Level 10 (89,725 points)
    Hello and Welcome to Apple Discussions...

    "I have 35 gigs of 148 free on my startup disk"

    FYI... a Mac needs at minimum 15% available disk space just to boot, 20% preferred. So you are kind of on the edge... and if you are running 3D graphics code... that probably is a variable. One way to keep a close eye on available disk space is... in your Finder/View/Show View Options. Make sure where it says: Show Item Info is checked. Capacity and Available disk space will be displayed under the MacintoshHD icon on your Destkop.

    If you can, copy files over to an external source, but remember to delete the original files on your Mac and see if the OS no longer reports disk space full. A good little utility to see the size of files is this gem: http://www.versiontracker.com/dyn/moreinfo/macosx/21149 Get "WhatSize' .. very handy!

    Carolyn

    Message was edited by: Carolyn Samit
  • 2. Re: "Disk Full" error when disk is not full
    BDAqua Level 10 Level 10 (116,480 points)
    Hi blakieto, and a warm welcome to the forums!

    Are you using FileVault perchance?
  • 3. Re: "Disk Full" error when disk is not full
    blakieto Level 1 Level 1 (10 points)
    Thanks for your input. I've also downloaded two programs to help solve this issue:

    1) "Cocktail" is a utility that lets one delete caches, logs and so on, plus run various system maintenance scripts. (Since this is a laptop, it is closed at night when such maintenance scripts are usually set to run.) I've deleted all caches, logs and run all the daily/weekly/monthly maintenance scripts.

    2) "TechTool Deluxe" from Apple support runs a bunch of diagnostic tests - which I ran all the tests and all were passed.

    In another discussion on this same topic, someone recommended "fixing the volume permissions". One of my business partners (also a mac developer) remembered having the same issue once, and fixing the volume permissions may have solved it for him (he is not sure - it was a while ago). That Cocktail program has a "fix volume permissions" option, so I ran that too.

    Now it is simply a "time will tell" situation.

    FWIW, I only get this situation when using MS Word... which really is a problem, since I'm using MS Word to write complex technical documents, and being unable to save my work is a serious pain!
  • 4. Re: "Disk Full" error when disk is not full
    blakieto Level 1 Level 1 (10 points)
    Not that I know of. I don't even know what that is...
    Okay, I just looked it up. Nope, I'm not using it.
  • 5. Re: "Disk Full" error when disk is not full
    BDAqua Level 10 Level 10 (116,480 points)
    Hmm, with Word®, does it have a setting for Drives to use for Cache files?

    Have Activity Monitor open and sorted by Memory%, see when it reports that if you are out of VM, or how big the VM is.
  • 6. Re: "Disk Full" error when disk is not full
    blakieto Level 1 Level 1 (10 points)
    Well, I just got the error again. Wreaking about a half hour of work... grrr...

    I'm in Word. That Firefox & Mail are the only applications open. Word is reporting that my disks (all of them) are full...

    My startup disk has 37 of 148 gigs free.
    My virtual memory is 11.37 gigs.

    This is starting to seem like a MS Word bug, since no other applications are reporting this problem. For example, I can open a terminal window, and with the VI text editor create a file several megs in size and save it fine.

    Is anyone else an avid user of MS Word that is not seeing this?!?
  • 7. Re: "Disk Full" error when disk is not full
    Carolyn Samit Level 10 Level 10 (89,725 points)
    Hello,

    I don't use Word but something occurred to me. In Word, from the Menu Bar/File... is there an option to report a bug??? The sooner users report bugs, the sooner bugs get fixed.

    Carolyn
  • 8. Re: "Disk Full" error when disk is not full
    blakieto Level 1 Level 1 (10 points)
    As I continue to research this, I think it may have something to do with embedded graphics being unable to be updated during a save operation, triggering the "default save failure" dialog, claiming the disk is full.

    I'm not sure. I'm at wits end here. I just lost a bunch of work.

    The issue here is the document I'm working on is 66 pages of rather intense embedded graphics, excel worksheets, and text boxes on every single page. The document was originally created on my Win32 laptop, but I just made the switch to using OS X as my main work computer... it took be two weeks to update all the document-to-external-file links... do I have to go back to using my junky hated old win32 box?!?!
  • 9. Re: "Disk Full" error when disk is not full
    Carolyn Samit Level 10 Level 10 (89,725 points)
    Ack! Not Win....

    I'm so sorry you have been through so much stress with this. I've read this post over and over and realize how much time and effort you've put into this particular Word file.

    Have you used your restore disk lately that came with your MBPro and checked the disk???
    Try Disk Utility
    1. Insert the Mac OS X Install disc that came with your computer, then restart the computer while holding the C key.
    2. When your computer finishes starting up from the disc, choose Disk Utility from the Installer menu. (In Mac OS X 10.4 or later, you must select your language first.)
Important: Do not click Continue in the first screen of the Installer. If you do, you must restart from the disc again to access Disk Utility.
    3. Click the First Aid tab.
    4. Click the disclosure triangle to the left of the hard drive icon to display the names of your hard disk volumes and partitions.
    5. Select your Mac OS X volume.
    6. Click Repair. Disk Utility checks and repairs the disk.

    While you have Disk Utility open, Repair Disk Permissions. When DU is finished, from the Menu Bar select Utilities/Startup Disk and then select MacintoshHD 10.4.x and click Restart.

    See if that helps...

    Carolyn

    Message was edited by: Carolyn Samit
  • 10. Re: "Disk Full" error when disk is not full
    Texas Mac Man Level 8 Level 8 (45,805 points)
    How large in MB or GB is this 66 page document?

    Look at these links.

    Where did my disk space go?
    http://www.macfixitforums.com/showflat.php?Cat=&Board=Forum38&Number=770243
    Download & use WhatSize described in this link or Disk Inventory X @ http://www.derlien.com/

    Freeing space on your Mac OS X startup disk
    http://www.thexlab.com/faqs/freeingspace.html

    Amazing Disappearing Drive Space
    http://www.pinkmutant.com/articles/TigerMisc.html

    Increase HD Free Space
    http://macosx.com/forums/howto-faqs/275191-how-easily-increase-hd free-space-laptop.html

    How to free up my disk space
    http://www.macmaps.com/diskfull.html

     Cheers, Tom

  • 11. Re: "Disk Full" error when disk is not full
    blakieto Level 1 Level 1 (10 points)
    Hi Tom,

    The Word document is 10.6 MB. Not too big...

    Thanks for the links, but I'm fairly sure this is a Microsoft Word bug. I've been reading reports that one should never copy and paste embedded graphics from one location in a Word document to another. Apparently, that "corrupts" some internal linkage within the document. When attempting to save the document, the corrupted link reference fails to find the data to save the copied embedded graphic, causing the "default save failure" dialog to pop. (With the default save failure dialog being "disk full".)

    This seems consistent with the behavior that Word reports all disks to be full, even ones with well over 50% free. Plus, while this error is happening, I can open up other programs and write large files to the disk fine.

    This behavior does not exist on Word in Win32, because I've been creating large complex documents like this for years (with lots of embedded graphics, often copied to multiple places in the same document from a single insert from file operation).

    This is a series issue for me. It may force me to return to Win32, at least for my complex document processing needs...

    Is Apple's "iWork" any good? I tried OpenOffice a while ago, and that was a pretty poor experience. Our "Microsoft monoculture" is a big problem for word processing and spreadsheet applications... sure, others like iWork exist, but nobody uses them, so you can't share the documents.
  • 12. Re: "Disk Full" error when disk is not full
    Adrian Clarke1 Level 4 Level 4 (3,580 points)
    Hi. Have you run Microsoft Auto Update recently? There might be a patch...

    Good luck,

    Adrian
  • 13. Re: "Disk Full" error when disk is not full
    David Talaga Level 1 Level 1 (0 points)
    I have this error right now.

    For everyone else: Please. Before "answering," read the posts.

    The bug is that MS word claims the disk is full in spite of it not being full. Saving to another (also not full) volume results in the same error message.

    Posting links to how to free up hard drive space is insulting a waste of everybody's time.

    What is really needed is a work around so that one can successfully salvage the unsaved document.

    Help?!
  • 14. Re: "Disk Full" error when disk is not full
    David Talaga Level 1 Level 1 (0 points)
    I tried repairing disk permissions. No luck.

    For what it's worth, I found that saving in the .docx format instead of the .doc format solved the problem. ymmv.

    Good luck.
1 2 Previous Next