7 Replies Latest reply: Oct 22, 2008 6:41 AM by Waker
rabber82 Level 1 (0 points)
I have a LaCie HDD connected to my MacBook Pro via FW800. All of a sudden, it won't mount. I can't see it under System Profiler or Disk Utility and none of the partitions are mounting under the finder. It mounts fine on a different MBP.

Any troubleshooting ideas?

MacBook Pro, Mac OS X (10.5.5)
  • rabber82 Level 1 (0 points)
    A couple more things. If I boot into Windows using BootCamp, the drives do not mount. If I restart the Mac and the drive is connected, the computer hangs during the boot process and will never boot until I unplug the computer and remove the battery. The drive has a triple interface - FW800, FW400 and USB. I have tried mounting under all three interfaces get the same result.
  • V.K. Level 9 (56,110 points)
    do you have other external drives you can try with the same computer? the fact that this drive doesn't mount with either USB or firewire would indicate a problem with the drive. however, the fact that the drive doesnn't show up in windows means nothing. windows can't read HFS+ formatted drives. or is the drive formatted FAT?
  • petrock Level 3 (975 points)
    V.K. wrote:
    do you have other external drives you can try with the same computer? the fact that this drive doesn't mount with either USB or firewire would indicate a problem with the drive.

    Agreed, but the OP states the drive mounts fine on another machine. I suspect that it actually isn't a real problem with the drive, but the OS may think there is a problem. This can happen if the drive was disconnected at some point without ejecting/unmounting the drive properly. The next time the drive is connected, the OS will run fsck in the background on the drive before its fully mounted. This can take quite a while depending on the size of the drive and amount of data on it. When its done, the drive should appear. The catch-22 is, if its fsck'ing the drive and you disconnect it, you make the problem worse. The bug, IMO, is that the OS doesn't tell you whats going on and you end up thinking there is a problem with the drive.

    Try this. Before you go to bed, turn the machine on (make sure its set to never go to sleep) and plug the drive in. Make sure it spins up etc. Let it sit overnight. In the morning, if the drive hasn't mounted, then there is something else going on... Goodl luck...
  • rabber82 Level 1 (0 points)
    I wanted to provide an update on solving this issue. I tried letting the drive sit for about 8 hours trying to run through an FSCK. No change. I spoke to Apple about this and they suggested resetting the PRAM. I did this and now the drive mounts using USB, but not Firewire 400 or 800. I will be bringing it to Apple later today. They believe that I have an issue with the logic board. The thought was that the Firewire ports and the left USB port are all connected to the logic board together and this could be a sign of failure there. However, since it works on the USB ports on both sides and I can plug in an external mouse on the left side, it may be that only the Firewire portion is broken.

    I will provide another update after taking it to my local Genius Bar.
  • slearmartin Level 1 (0 points)
    I started having the same problem with my external LaCie - the only change was a software update that was pushed from Apple on Sept. 30. I noticed that the Disk Utility was one of the updates...
  • rabber82 Level 1 (0 points)
    According to Apple, it looks as if I may have a failure on the logic board. Unfortunately, I have a small ding on the corner of the computer which means that I am no longer covered by AppleCare for this. Oh well - I guess I will live with USB for a while since the drive mounts this way. If the failure gets too much I will try to repair or replace.
  • Waker Level 1 (5 points)
    I am having a similar problem. I have a 2Ghz white macbook w 1 gig of ram. Immediately after installing the following updates I could no longer connect an external LaCie hardrive via firewire or usb:
    Java for Mac OS X 10.4 Release 7 1.0
    Quicktime 7.5.5
    Digital Camera Raw Compatibility Update 2.2
    Migration and DVD/CD Sharing Update 1.1
    Security Update 2008-007 (Intel) 1.0