7 Replies Latest reply: Oct 7, 2008 2:25 AM by Ercole49
Steve Jolly Level 1 (35 points)
When I go to System Prefs and choose Network, I immediately get a message saying, "Your network settings have been changed by another application" and an OK box. No matter how many times I click "OK," the message will immediately come up again, and I can't use System Preferences at all until I force quit it and then re-enter. Even then, any return to Network settings immediately produces the same situation - System Prefs that are locked into the "Your network settings have been changed..." message loop. There are NO other applications running except System Prefs, Firefox (however, message continues even after quitting Firefox) and of course Finder. Note: nothing changed after a Restart -- still getting the message immediately upon going to Sys Prefs/network.

I am still online and on the net, and Built-in Ethernet still changes my IP address to adjust (DHCP) for other computers coming onto the LAN to access the internet - but I can't use Network to alter or lock in any settings, or even to Renew DHCP Lease, except if I act in the brief moment before the message comes back up again. HELP!

Background: I had to activate Network Utility briefly today to help troubleshoot a connection to an internet DSL router, but (so far as I know) the only thing I did was to use it to for a moment to ping the router. For a brief moment, somehow, Console opened (I didn't choose to open it), and heaven help me if somehow any text was entered, but I don't think it was. I'm totally mystified, here!

New 2 GHz dual g5, Mac OS X (10.4.11), cable modem
  • sig Level 8 (35,785 points)
    Posted by Jona:

    'Your network settings have been changed by another app' - THE SOLUTION
    Posted: Sep 28, 2008 11:30 AM
    Reply Email

    This currently reported problem, which manifests after applying Security Update 2008-06, can be fixed permanently by removing the following preferences files:

    Go to Library/Preferences/SystemConfiguration and delete the following (suggest make copies to the desktop first if in doubt):

    com.apple.airport.preferences.plist
    NetworkInterfaces.plist
    preferences.plist
    com.apple.nat.plist

    All these files will regenerate as necessary when the associated system features are accessed. If you're using Airport or Internet Sharing you'll have to reestablish the appropriate settings, because these will have been lost when the preferences files are removed. Small price to pay, however for a permanent, and very simple solution to this irritating problem.
  • Rev. Robert Dobbs Level 1 (35 points)
    Thanks but no joy with this fix here. Has it worked for anyone else here?
  • Lythophaga Level 1 (5 points)
    Same here - didn't work. Will Apple address this or are we on our own?
  • Klaus1 Level 8 (47,755 points)
    These solutions have worked for many:

    I haven't had the problem myself, but this post by ejp1684 seems to have offer a solution:

    Once in the network prefs and the popup appears, place your mouse over the place where the "Show All" button is (behind the popup). Then, hit Return - which gets rid of the window and immediately the window is gone, click on the 'Show All" button. I then get a window asking me to save etc, the changes. You can click on any of them and you should be back in the prefs window. Then, when you select the Network prefs, you should be able to change things. If this doesn't work, I found that I had to use the mouse button to click on both the "OK" button on the popup, and then quickly switch to the "Show All" button - took me a few times to do it!

    Even if you can't change the settings, at least you won't have to do a hard shutdown.

    http://discussions.apple.com/thread.jspa?messageID=8112368&#8112368

    This post by MacStrong also provided a solution that worked for some:

    If you recently updated or run a disk utility on your Mac this may have altered your sharing preferences. Go to System Prefs>Sharing Prefs and go to Network Time. If you have it checked, uncheck it and then recheck it. I just fixed a Mac by doing this. If it is not checked try checking and unchecking it.

    http://discussions.apple.com/thread.jspa?messageID=8204758#8204758
  • Lythophaga Level 1 (5 points)
    Thanks for that; the second option seems to work. If I go back to Network at a later point the message is back but in the short term ...
  • Ercole49 Level 1 (0 points)
    Thanks, it works VERY fine - all troubles resolved. I agree re-enter settings is a small price. A tip: if you write somewhere seting BEFORE throwing plist files, the price is smaller and time wasted is zero.
    The problem doesn't show if preference panel requires password to change settings (the other iMac of mine got no troubles for this reason - verified).