6 Replies Latest reply: Oct 9, 2008 7:58 AM by MeanJoe0469
mr marbles Level 1 Level 1 (0 points)
Not sure if anybody is having the same issue as me, but it is slowly getting worse. Problem is simple, go to check my e-mail and get the spinning wheel with "connecting". Nothing ever happens. Just keeps saying "connecting". I am forced to the power off then back on to check/send e-mail. Getting to the point that I have to do this 10+ times a day. Have already done a restore, but it doesn't help

Anybody know what I can do to try and fix this? Never had any e-mail issues with my 2g iPhone and before 2.0. Nothing but issues since 3g and 2.0 and above...
  • Allan Sampson Level 10 Level 10 (123,370 points)
    How many email accounts are involved and when doing a restore, did you restore from your iPhone's backup, or as a new iPhone or not from your iPhone's backup?

    Email account settings are included with your iPhone's backup and if there is a problem with the backup, when restoring from your iPhone's backup you are restoring the problem.

    As a first step, I suggest deleting and recreating the account or accounts on your iPhone.
  • mr marbles Level 1 Level 1 (0 points)
    1) 3 e-mail accounts-2 pop and 1 .me
    2) Restored as a new iPhone
    3) Deleted all e-mail accounts an re-added. No help
  • Allan Sampson Level 10 Level 10 (123,370 points)
    I'm accessing a MobileMe account and a business POP account with the iPhone's mail client and no such problem.

    In that case, it is time to give AppleCare a call at (800) 694-7466, or make an appointment at an Apple Store if there is one nearby.
  • MeanJoe0469 Level 1 Level 1 (0 points)
    I am having the same issue while on Edge or WiFi. I cannot get connected to my exchange or Yahoo email. Spinning wheel of death indeed!

    Michael
  • Chris Fleck Level 1 Level 1 (0 points)
    Same issue here with my 3G. Everything was fine then last night I upgraded to itines 8 and synced. Now I cant send or recieve email from exchange or yahoo
  • MeanJoe0469 Level 1 Level 1 (0 points)
    I've discovered I actually cannot do anything involving the exchange account. I've tried to update the settings (SSL keeps getting turned on) and all that does it lock up the phone with the SWoD. I tried to delete the exchange account so that I can re-add it and again.. SWoD.

    Great job Apple, you'll make in-roads into the business world like this!

    Michael