11 Replies Latest reply: Feb 13, 2009 11:12 AM by OJ89
ucx Level 1 Level 1 (0 points)
I wanted to install Ubuntu on my MacBook Pro, and lets say due to an oversight, I ended up with no Ubuntu on my machine, but a Linux swap partition which the Mac cannot mount and cannot erase.
I've tried formatting the Linux swap partition, and then erasing it using disk utility. I even tired removing it after booting from the Leopard installation CD, but it would not remove the partition. Disk utility recognizes the partition as a Mac OS Extended (Journaled) volume, but cannot mount/erase/remove the partition.
I've tried using iPartition and Drive Genius, but none of those programs worked either.

After digging around in the terminal a bit, I found that the the Linux swap partition is not in the volumes directory of the system (/Volumes/), but is in the dev path:

After some googling, I tried using:
& sudo gpt remove -i 3 /dev/disk0s3

but i got the following result:
gpt remove: /dev/disk0s3: error: no primary GPT header; run create or recover

Its only a 205MB partition, so its not eating into my disk space, but BootCamp wont run until this partition is removed.

Anybody has any ideas on how to remove this partition?
Given a good set of instructions, I'd be willing to use the terminal or boot into single user mode and work the command line if that is necessary.

Thanks in advance

MBP, Mac OS X (10.5.5)