7 Replies Latest reply: Nov 8, 2008 6:59 AM by dog lover
sills0608 Level 1 Level 1 (0 points)
My internet had suddenly slowed significantly. Very slow loading. In researching how to correct or find the problem I went through the usual of emptying cache, history and so on. It did not affect the performance. When I went to system preferences and then network I keep getting a message that says my network settings have been changed by another application. When I click "ok" it pops back on and will not allow me to go any further to make corrections(not that I know what to correct) I finally have to force quit the application. What do I do from here? I am stuck and very frustrated by the slow speed of my laptop. Any help is greatly appreciated

15" MacBook, Mac OS X (10.4.11)
  • Mulder Level 6 Level 6 (8,980 points)
    This problem affects some people who installed the 2008-006 Security Update, but certainly not a large number of users. There are two work-arounds for it, one of which is this:

    1. Use the "Fast Fingers" keyboard and mouse method to break out of the System Preferences dialog loop. That is, be prepared to click on the correct button or press Enter quickly to get out of that endless loop. This may take a few tries until you can anticipate what it will say and when it will present a button.

    2. Duplicate a Location and go into Network Configurations. Use the new Location and switch a few things off and on without deleting anything.

    3. Click the Lock on the lower left of the window so that no changes can be made to the settings after checking to be sure everything was correct.

    There's also another option, in case that doesn't work for you.

    Mulder
  • Anim83d Level 1 Level 1 (5 points)
    So I wonder if everyone is having this issue, or just many people haven't noticed? Maybe it's only a few of us who haven't upgraded to 10.5, but this seems consistent. I have to Macs, a G4 Powerbook and a G5 PowerMac both are running 10.4.11, and both seem to have the same issue. I tend not to change the Network settings, but a few weeks ago I did, and this is when I noticed the issue.

    I was hoping that the most recent security release would fix the issue, but that isn't the case. Even after installing the latest security release, restarting, repairing disk permissions, the network settings still seem affected. I thought that the smart thing to do would be to click the lock to prevent changes, which works until the Mac is restarted. After restarting and doing nothing else before checking the network settings, I am presented with the same message "Your network settings have been changed by another application". Of course I have to do the press return for Ok and try to click the show all until I get the Apply button, then click the lock. This is very disturbing. It would seem this is a security risk of the highest order. And for now, I will just remind myself to check this and lock the settings after every restart, which is a big hassle.

    Hopefully this will get attention soon!
  • Anim83d Level 1 Level 1 (5 points)
    And there is another thread going on about this same topic under the 10.4 Discussions:

    http://discussions.apple.com/thread.jspa?threadID=1715241
  • Carolyn Samit Level 10 Level 10 (96,775 points)
    Hi sills,

    Try this for the "network message" ...

    Try this... go to System Preferences/Network. Click the gold lock icon bottom left of the window. If it's already open, click to close it, or vice versa. You will be prompted for your admin password. Just make sure to "lock" it.. Close the Sys Preferences pane and reboot.

    See if that helps... I found this possible fix here: http://www.macfixitforums.com/ubbthreads.php/topics/450792/YourNetwork_Settings_havebee

    If that doesn't do the job go here: http://discussions.apple.com/thread.jspa?messageID=8318865&#8318865 And read, "NoKaiOi"s suggestion ...

    Carolyn




    Message was edited by: Carolyn Samit
  • Ed Miller Level 1 Level 1 (45 points)
    I'm having the same problem; since just before the security update. It essentially renders the Network Preferences USELESS, as you can't make any change without doing the tricky fast fingers thing which is highly error prone and sometimes impossible.
    clicking the lock just makes it stable. It doesn't solve the problem for those that actually need to manipulate the settings (which goes for those of us that are actually mobile with our notebooks)
  • jephilli Level 1 Level 1 (10 points)
    I had the same problem. You have DNSchanger Trogan. Try this tool to fix your problem.
    http://www.dnschanger.com/
  • dog lover Level 1 Level 1 (45 points)
    I kept getting this also. As I have kids I thought it might have been them. I too have installed the latest updates.

    I called Applecare (as luckily I had 3 years cover-coming to it's end) and they firstly took the power cable out of the back for 5 minutes after I'd shut it down.

    Then I was asked to put the power cable in and start up while resetting the PRAM. Hold down cmd-alt-R-P while starting up. Wait for 3 chimes while holding keys then let go.

    Then I was asked to go into Macintosh HD-Library-Preferences. I was then asked to find the SystemConfiguration folder and to drag it to the desktop.

    Close all panes. Go to Apple logo (top left) then go to System preferences and use the assistant to carry on setting up as my ISP tells me how to with all the references they ask you to put in.

    So far I can get on. I will let you know if we still have problems.


    Just trash the old SystemConfiguration folder and all should be ok.

    Hope this helps. I'll be ringing them back if not.

    regards

    Jan