13 Replies Latest reply: Nov 11, 2008 2:50 PM by PaddyPatPat
Kiwi Jim Level 1 Level 1
I can not get my iPhone to connect through my wireless router. I have even tried a reset on my router. My laptop works fine, but my iPhone will not connect. I can see the connection, but i get an 'Unable to join the network' message each time i try to connect.

iPhone 3G
Solved by Andrew T. on Oct 11, 2008 6:02 PM Solved
Couple things that I see cause this1. Outdated Router firmware, So updating it to latest software will help. Contact Linksys for Firmware assistance.2. Changing WiFi Security. If your WiFi password is 5 to 10 characters, Switch it to WEP128 bit with a 13 character password. or WPA/WPA2 with 8 character or longer password.Also ensure that if you are using MAC address filtering, that you add your iPhone Wireless Address into the router.It can be found by going to Settings - General - About - Wireless Address
  • Andrew T. Level 4 Level 4
    Couple things that I see cause this





    1. Outdated Router firmware, So updating it to latest software will help. Contact Linksys for Firmware assistance.

    2. Changing WiFi Security. If your WiFi password is 5 to 10 characters, Switch it to WEP128 bit with a 13 character password. or WPA/WPA2 with 8 character or longer password.

    Also ensure that if you are using MAC address filtering, that you add your iPhone Wireless Address into the router.

    It can be found by going to Settings - General - About - Wireless Address
  • Richard Briscoe Level 4 Level 4
    I have a WRT54GL that I have connected to without difficulty. It is set up as a WPA-PSK with a lengthy key. I would have to double check the firmware on it. It may not be "the most recent", but it is fairly recent.

    Are you seeing the SSID? If not, go into the setup for the router and turn it on so that you can see it and connect.
  • Kiwi Jim Level 1 Level 1
    I have the latest firmware updates and i have tried all of your suggestions, but still nothing. I even removed the password and alowed all MAC address to enter just to see if that world work, but nothing.
    I have talked to Linksys, but everything they tried did not work.
    Is there something on the phone i can change?
  • Andrew T. Level 4 Level 4
    Nothing on the phone can be changed to make it work unless a Software update was released to fix whatever was preventing a proper connection.



    Can you connect to any WiFi networks at all? If so then it does isolate it to something with the router.



    Based on what you said. You go to Settings - WiFi - You see your network, Tap on it. And Unable to Join?

    So you never get a check-mark by the network name?

    If you do actually get a check-mark next to your network, tap on the Blue circle. Would be interesting to see what the IP address started with.



    Based on what you said when you disabled security, Did the iPhone no longer show a Padlock next to the WiFi network?


    Also try changing the SSID sometimes that oddly works.
  • Kiwi Jim Level 1 Level 1
    I have been able to connect to the network in the shop i got it from, no problem.
    I can see my connection, but when i tap on it, it will not connect.
    When i removed the security, the padlock went away, when i put the security back, the padlock came back again.
    Yep tried changing the SSID as well.
    I am at aloss on what else it can be, it looks like its the router, but its strange that my laptops can connect as wll as my Nokia phone. Its just this iPhone thats the problem.
  • Richard Briscoe Level 4 Level 4
    I would suggest flashing the router with the latest firmware again and then resetting everything from the factory settings. There are some occasions which I have encountered where the router would just get cantankerous, usually after a power outage. Flashing it again seemed to take care of it many times.
  • Kiwi Jim Level 1 Level 1
    Well i tried that but still no joy. Its a puzzler!
  • icebike Level 3 Level 3
    Try this...
    Go to airplane mode.
    Then go to wifi and turn wifi back on.

    Sometimes if a connection for mail gets started before wifi comes up it seems to block wifi. A push account started on Edge might do this.

    All the other words of wisdom I have seen:
    Use channel 1 thru 6 on the router. (lower is better).
    Lock the router to 810.11G.
  • Kiwi Jim Level 1 Level 1
    Tried and still no joy.
  • Dynamite DJs Level 4 Level 4
    Kiwi, did you unplug the routers power and reconnect?
  • Kiwi Jim Level 1 Level 1
    Yes did that as well as a full reset.
  • PaddyPatPat Level 1 Level 1
    expertise.macosx
    Mac OS X
    Hi Kiwi,
    I have the same problem as you. I got my router from snap. It's the same model number and it has been flashed to the latest firmware (my ISP confirmed that). I can connect to any other router I find and know the password for but I cannot connect to my own! There are three other computers that are connecting wirelessly to the router as well without any problems.
  • PaddyPatPat Level 1 Level 1
    expertise.macosx
    Mac OS X
    http://www.noodles.net.nz/2008/07/12/iphone-3g-and-linksys-wag54g-v3-incompatibi lity/

    Fixed!!

    You need to upgrade your router firmware to the latest Auzzie version 1.00.46 while in NZ we only get 1.00.23.
    The upgraded firmware adds the AES algorithym which you need in order to connect the iPhone.

    YAY!