12 Replies Latest reply: Nov 7, 2008 4:00 PM by Urban Ninja
treyprice Level 1 Level 1 (0 points)
On my Iphone 3g my apps will open for about 2 seconds and then close. I can't get anything to work other than what came on the phone. Any ideas?

Fast, Windows XP Pro
  • neuroanatomist Level 7 Level 7 (31,690 points)
    What version of the iPhone OS are you using? v2.1 was supposed to address this issue.
  • treyprice Level 1 Level 1 (0 points)

    I've tried the reset thing with holding down both buttons and it still doesn't work.
  • treyprice Level 1 Level 1 (0 points)
    This fixed it:


    There's something going on with the latest version of iTunee.
    This affects people with old and new version of firmware for iPhone 3G.

    What happens... All your apps stop working because they are no longer authorized for use, after a syncing with iTunes.

    The fix... Before doing a sync with iPhone, deselect all the applications. Sync (in effect, you're removing all applications from your iPhone). In iTunes, click Store / Authorize Computer, and enter your password. Don't worry, you won't use up any of your 5 alloted activations. Go back to applications and reselect all your applications. Sync. You're done and EVERYTHING WORKS !

    I figured this out when i tried the delete / restore technique mentioned before. iTunes gave me a message saying my computer was not authorized to restore the applications. Huh? So in fact it's iTunes causing the headaches.
  • jasoncowell Level 1 Level 1 (0 points)
    Brilliant!! You're a life saver!
  • Envision99 Level 4 Level 4 (1,165 points)
    You don't have to remove all the applications from your iphone though. Just by De-Authorizing your computer in iTunes then Authorizing then syncing your iphone will do the trick. I had the same problem and after googling around for a little bit I found the solution.
  • Carol Kusama1 Level 1 Level 1 (0 points)
    But I haven't connected my iPhone to iTunes since I downloaded 2.1 a while ago. Why all of a sudden today do the apps stop working & my friend is having the same problem? Doesn't make sense.
  • Envision99 Level 4 Level 4 (1,165 points)
    And a lot of problems with software never will make sense. There doesn't need to be one specific thing that happens that causes problems, it can be a variety of things.
  • SReese99 Level 1 Level 1 (0 points)
    I am a relatively new IPhone 3G user. I had the exact same problem. Tried re-synching the apps. Tried checking the apps individually and clicking "apply." Tried clicking "All applications" and clikcing apply. No go. Then, I deleted one app (just a coin flip app)to see what would happen when I re-synched. When I did, it brought up a prompt saying I didn't have permission to add the app. Hmmm. It was my computer with my I-tunes and all the apps were there but... I had loaded every app from the phone and not from Itunes.

    On a fluke, I clicked under "store" then clicked on "authorize this computer." BINGO! After that, when I synhed up, it loaded the "missing" coin flip app and all the rest worked.

    Try it. I think it wasn't recognizing my computer so was essentially de-activating all the added on apps.
  • Beth Elliott Level 1 Level 1 (0 points)
    Thank you for posting your solution here. Worked for me.
  • Eske Level 1 Level 1 (0 points)
    Thanks guys, your both onto it! Too easy
  • Carol Kusama1 Level 1 Level 1 (0 points)
    This issue is STILL happening now for the 2nd week! Apple better release a fix on this 2.1 glitch. My apps still quit out sporadically & I'm sick of this!
  • Urban Ninja Level 1 Level 1 (0 points)
    Did exactly what you said and it worked like a charm... Thanks for saving me!