3 Replies Latest reply: Oct 17, 2008 12:46 AM by nellycrock
nellycrock Level 1 (0 points)
I have a 14 month old MacBook Intel Core 2 Duo 2.0 Ghz, 1Gb Ram running the latest software OS X 10.5.5. The MacBook has all the latest software updates. The problem as you can see from the subject header is that both USB Ports have stopped working over the past week or so. I have tried restting the PRAM and SMC. I have also tried running USB Prober and have done a fresh install of Leopard but still no joy. I have looked in USB Profiler and nothing is showing? What could be wrong as both ports were working a short while ago.

I hope someone can help, many thanks in advance.

Macbook, Mac OS X (10.5.5)
  • Zlig Level 4 (1,340 points)
    Best if the MacBook is checked by a qualified technician - likely its a hardware problem.
  • JL1365 Level 1 (0 points)
    I agree with Zlig on this matter; seeking some pro help, such as the Genius Bar at the Apple Store. It could have occurred from either hardware failure or software issues (i.e. such as a recent software update). My Macbook lost it's dock station at the bottom of the screen due to software update, a simple reinstall of the update fixed the issue. I had another incident when the touch pad button wouldn't function, again, a software update fixed that, never sure why.

    If you have an Apple store near you, go online and book an appt. I've found even in San Francisco's busy store, I can often get in on the same day when I make a reservation on line.
  • nellycrock Level 1 (0 points)
    Thanks for your advise. I think it will have to be a trip to an Apple store. The weird thing is that powered devices i.e. my digital camera works so the usb cant deliver power for some reason.