Previous 1 4 5 6 7 8 Next 109 Replies Latest reply: Mar 16, 2009 3:47 AM by Liebrand Go to original post
  • ayons Level 1 (0 points)
    I had the same problems with some sites losing logins; read through this thread, and then fixed my problem as follows:
    1. Cleared Web Clip from Dashboard - went to Widgets and actually threw it away.
    2. Cleared out any widgets I wasn't using
    3. Installed the new Security Update
    4. NEW TRICK: Went to Safari > Preferences > AutoFill, then clicked on "Edit" for the Usernames and Passwords. I noticed a lot of the sites I was having trouble with were tagged as "Password never saved". I deleted all of these, then restarted Safari. Then, went to each of those problematic sites, typed in sign-in info, clicked "remember me".

    Worked. I'm getting remembered now at all the sites I had trouble with before.
  • Chris Brummel Level 1 (30 points)
    HUZZAH!

    It appears that the new Safari 4 beta fixed the problem for me. All the sites that I was having problems with now work correctly.

    - Chris
  • Mark C. Dorison Level 1 (20 points)
    I am having this problem even with the Safari 4 beta. Still unsolved for me.
  • Frozo Level 2 (270 points)
    Yep, me too. It seemed to be fixed on my laptop prior to Safari 4, and has ben working after installing. However, now my Pro is doing it all the time ever since I installed Safari 4, where it was perfect before the install. Something very strange about the inconsistency of this issue.
  • Liebrand Level 1 (0 points)
    Has anyone got any more news on this? I'm still having this problem, even with the nightly webkit builds.

    Another issue that might or might not be related is that I also seem to loose "memory" of wireless networks. I have a few that do not broadcast their SSID like the one in our office. Every now and then my macbook air simply wont remember the connection (even though it IS in the list of networks to remember), and I have to manually connect to it.

    These two problems (safari login cookies and wireless networks) suggest to me that the problem is indeed with the keychain. I've fixed permissions on my drive, and still no luck. But both of these systems use the keychain, and it would make sense that if they can't access it, they can't connect/remember login details...

    /Cheers,
    Jelte
Previous 1 4 5 6 7 8 Next