Previous 1 2 3 4 Next 109 Replies Latest reply: Mar 16, 2009 3:47 AM by Liebrand Go to original post
  • Hawaiian_Starman Level 7 Level 7 (21,415 points)
    Hi David

    Are you using any 3rd party add-on such as 1Password? If so, which version is installed in your system?
  • Mark Biech Level 1 Level 1 (5 points)
    I don't have any 3rd party software ... just Safari ... I have run keychain utility and have run first aid to repair some problems .. now re-entered user info on all sites ... will see if that works ....
  • zedboy Level 1 Level 1 (0 points)
    Yep, I've had the same thing going on for about two weeks now. Probably came with the recent Safari upgrades.
  • Ronald Hord1 Level 1 Level 1 (5 points)
    I am having the same problem but it only occurs about every 3 or 4 days. It will keep them for a couple of days and then it won't. It will out fill some of them but the automatic login won't work.

    This has gotten very frustrating and I may have to switch to FireFox.
  • Paul Heslop Level 1 Level 1 (110 points)
    Hi all

    I started getting this problem as soon as I upgraded to 10.5.6, and Safari 3.2.1. It's extremely annoying as my cookie file weighs in at 2MB, so I don't really want to have to re-enter all those passwords What's strange is that another user account I have on the same machine does NOT suffer the same problem, and has the same old cookie file as it always had. I don't have any third-party plug-ins installed, always use combo-updates, and use DiskWarrior occasionally. It's just very odd that each time I replace the cookie.plist file with my last good one from TimeMachine, it remains only until I log-out or restart. I even changed the file to read-only, but it still went...??? Firefox here I come, this is a fundamental usability bug that's wrecked my use of the internet, basically.
  • christiaank Level 1 Level 1 (20 points)
    Apparently (and I have confirmed) it's an issue with web clippings in the Dashboard.

    Every time you open Dashboard with a web clipping it resets the cookies - removing the web clipping fixes the issue.
  • Paul Heslop Level 1 Level 1 (110 points)
    Thanks Christiaan, deleting my webclip widget worked for me! Cookies have now survived a restart for the first time in a while...
  • dembow Level 1 Level 1 (90 points)
    christiaank wrote:
    Apparently (and I have confirmed) it's an issue with web clippings in the Dashboard.


    This is true. I deleted my YouTube Web Clip from the Dashboard and Safari seems to be working like before. Now, could it be that we all have some Web Clip in our Dashboard or the source to this problem lays maybe somewhere else?
  • Roving Eye Level 1 Level 1 (0 points)
    Let's all hope that this has sorted the problem. Thanks for all the help!

    I have deleted Webclip from my dashboard, (there were all sorts of others there that I hadn't asked for) and I shall see how it all performs. Perhaps installing one Dashboard widget actually does more than you asked - and includes a few others?

    Suffice it to say, I thought I had it all sorted before this handy piece of news, only to find that the machine had forgotten the log-in for THIS site! So it's all now under test. Cheers folks.
  • Mark Biech Level 1 Level 1 (5 points)
    Wait! .... I don't have any such web clips on my dashboard .... just the basic apps that have always been there ... so now what? .... that being said, I have run Utility KEYCHAIN ACCESS, then ran KEYCHAIN FIRST AID. It found problems .. I repaired them (took a couple of runs) .. now I seem to be ok ... try this and see if that helps ... Mark
  • dembow Level 1 Level 1 (90 points)
    Some users, in other cookie related threads, also recommended reinstalling Safari. It seemed to help them get rid of this annoying issue. Download Safari, then trash Safari from Applications folder and reinstall.
  • David Bourne Level 2 Level 2 (345 points)
    I had a web clipping from my iGoogle page that would show as a disabled youtube clip. I thought that was strange but didn't think anything of it. It would reset itself later in the day (maybe after l logged into google again...). I've deleted that web clipping but probably won't know until the new year if it worked,
  • Mark Biech Level 1 Level 1 (5 points)
    The Keychain First Aid seemed to help for a couple of days .... now back to the same problem. Logins gone!!!!

    Have now taken advice above and have downloaded Safari, trashed the original, reinstalled. Let's see if this works ... I am starting to know all my credit cards and ATM card numbers by memory!!!!
  • Mark Biech Level 1 Level 1 (5 points)
    Just went in to Safari and BAM .. all GONE!!! the reinstall did not work ... I GIVE UP!!!
  • cskemp Level 1 Level 1 (0 points)
    cookies aren't working right here either.
    started about two weeks ago.
    passwords aren't being effected, just have to login to everything all the time. like nytimes.com, almost every page i go to, i have to login.
    i have made sure i have no webclips on dashboard, this hasn't worked. i don't even use dashboard very much in the first place.
    i have trashed my cookies file in my library.
    i have cleared my cache.
    reset my preferences.
    all to no avail.

    apple? give us some love here, please!
Previous 1 2 3 4 Next