Previous 1 2 Next 21 Replies Latest reply: Oct 14, 2008 3:58 PM by LillyO'Neill
LillyO'Neill Level 1 Level 1 (0 points)
I can't unlock a .WAV item on my desktop! I think its a sound clip from a camera. When the info is brought up the lock option is ticked but I cant untick it as its not highlighted. Any solutions?
Thank you. You help would be greatly apprecited!

iBook G4, Mac OS X (10.4.11)
  • a brody Level 9 Level 9 (64,295 points)
    Welcome to Apple Discussions!

    Are you logged in as administrator? Check your Apple menu -> System Preferences -> Accounts.
  • LillyO'Neill Level 1 Level 1 (0 points)
    Yes I'm logged in administrator. When I select the info on the file it appears locked but not highlighted to make changes. I can see I am the owner too. However Permission to read and write is also not highlighted... If I drag in anywhere it will make a copy that is also locked. I can't do anything with it as it wont allow me too.
  • a brody Level 9 Level 9 (64,295 points)
    Is your desire to delete the file?
  • LillyO'Neill Level 1 Level 1 (0 points)
    YES YES YES! They are on my desktop and in another folder. I know how to empty the bin holding the prompt key whilst emptying, its just getting the folders unlocked in order to delete them or at least move them off my desktop.
    Thank you for replying.
  • a brody Level 9 Level 9 (64,295 points)
    Well, normally a folder on the desktop should be unlocked. It says something is wrong with your permissions, or some background application is running that has assumed ownership of the files. To force all such applications not to be running restart the Mac holding the SHIFT key. Also try repairing permissions with Applications -> Utilities -> Disk Utility -> select hard drive in Disk Utility's window and select First Aid.

    If after repairing permissions you can't at minimum send the file to the trashcan, and rebooting with the SHIFT key held down doesn't help allowing you to move the file to the trash, then:

    1. Backup your data*
    - 2. Remove any network connection.
    3. Dismount and physically disconnect any data devices that are not boot devices (drag their icon to the trash).
    4. Open Applications -> Utilities -> Terminal
    5. Type at the terminal window WITHOUT hitting any return key:

    sudo rm


    5. Drag an offending file into the terminal window. You can do with this folders too, but additional commands and risk needs to be assumed. Make sure there is a SINGLE space between the file path and the word "rm" by using the left/right arrow keys to navigate the cursor. Put the curser immediately after the path of the file with no spaces after the end of the path. Hit return.

    This will force delete the file once you enter your administrator password.

    Do this for each offending file.

    - * Links to my pages may give me compensation.

    Message was edited by: a brody
  • laundry bleach Level 5 Level 5 (6,880 points)
    [Repair Permissions|http://support.apple.com/kb/HT1452] will not do anything to items on the desktop. You may find [this article|http://support.apple.com/kb/HT2963?viewlocale=en_US] useful.
  • a brody Level 9 Level 9 (64,295 points)
    Good point, but file attributes can also be assigned externally. After all, once sudo gains foothold, every file is accessible that once was not before. If an external assignment file is in some way damaged, repairing it usually will solve problems such as these.

    Secondly, if a file was moved from a non-user assigned spot to a user assigned spot, its permissions may still be limited for the user. I.e., if you moved one of the Unix folders that are supposed to be invisible to your desktop, you already have done this. Only delete files you create by saving from applications, or applications you wish to uninstall that you were given that you no longer need.
  • LillyO'Neill Level 1 Level 1 (0 points)
    arrrh!! I've tried everything you said. Firstly when you restart do I hold the shift key all the time or just till a screen appears? Also I tried the repair thing no luck. I then tried the terminal option. All that came up was command not found.. I then kept trying it until it asked me for the password, I entered the password but it didn't type? So am I supposed to hit enter as nothing happened when I did but then if I do hit enter after the password same message comes up: command not found...
    The only other thing I can think of is if somehow I could place these single items into a folder I can delete the folder. But as I can't cut them all they do is copy.
    Any further suggestion? Thank you for replying so fast too.
  • a brody Level 9 Level 9 (64,295 points)
    Firstly when you restart do I hold the shift key all the time or just till a screen appears?


    All the time, until the startup screen says Safe Mode.
  • laundry bleach Level 5 Level 5 (6,880 points)
    When booting into [Safe Mode|http://support.apple.com/kb/HT1564] it can take a [long time|http://support.apple.com/kb/TS1884] - hold the shift key down until it has completed starting up.

    When entering a password in the Terminal no characters will appear - this is normal. Just enter the password and hit return.

    Best of luck.
  • LillyO'Neill Level 1 Level 1 (0 points)
    Nope tried everything again, safe boot, terminal, nothing still the same problem. When I put in the password at the terminal it just still say command not found.
    Any more suggestions? Or is there a way I can force them into a folder then drag the folder to the trashcan?
    thank you both for your help
  • a brody Level 9 Level 9 (64,295 points)
    Copy/paste what you are plugging into the terminal on the sudo rm line.
    We do not need to know your password.
  • LillyO'Neill Level 1 Level 1 (0 points)
    I can only drag the files to a folder in which it copies. They still stay on the desktop with more copies in the new folder. I can delete this folder then empty the trash using prompt.
    Sorry I dont understand when you say plugging into the terminal, I just go into vis utilities, then type sude rm, drag the file into it , press enter the type my password then it says command not found.
    Im just so fathomed everything I've tried is not working, I just cant seem to get them off the desktop. When they were in other folders I could drag them to the trash but not off the desktop.
    When I try and drag it to the trash it says its being used. I don't know what though because it even said that when I started up in safe boot.
  • LillyO'Neill Level 1 Level 1 (0 points)
    sorry just to confirm I type sudo rm what you told me... it was a type error.
Previous 1 2 Next