Previous 1 4 5 6 7 8 Next 109 Replies Latest reply: Nov 30, 2014 1:58 PM by muthannafromCO Go to original post
  • franksinatra2000 Level 1 (0 points)

    I tried the credit card/ microfiber, a DVD cleaning disk , blowing inside the drive and then finally caved and bought the compressed gas duster. It didn't work at first and i was starting to lose hope- but then i sprayed the crap out of it after my 5th try and even sprayed it while the disc was inside and it worked.



  • disappearingamerica Level 1 (0 points)

    Same problem here, but it only began AFTER I upgraded to Lion. I've been running Snow Leopard for a while with no problems on either of my two SuperDrives. But, as soon as I upgraded to Lion, they both went to crap. I'm trying the compressed air, but so far no luck. I'll try a CD cleaner disc next. But, because of the timing, I have a sinking feeling that Lion is responsible.

  • disappearingamerica Level 1 (0 points)

    Sorry for the double post. Firefox crashed when I tried to post the previous one and since I didn't see the post show up on the forum, I assumed it was lost. So I re-posted. Then, of course, the first post shows up. Hah. Go figure.


    Anyway, I've tried the air until I ran out. No dice.

    I have two SuperDrives and both were working well until I upgraded from Snow Leopard to Lion. Now neither drive will burn. And, when I do try to burn and get that error message, the Finder locks up and I have to relaunch the Finder. Every time.

    I'll buy a CD cleaner and try it, but I don't believe it's due to a mechanical failure, because the odds of both drives going out at the exact same time are astronomical. Though I'm getting the exact same error you all are, I believe my issue is due to a conflict with Lion.

    Waddya think?

  • Richard Schletty Level 1 (10 points)

    Right on! My superdrive in my MacBook Pro (MacBookPro3,1) was not recognizing blank Memorex DVD-R disks. I tried the thin plastic card with fiber cloth. No go. I then issued three mighty full-diaphragm blows with my lips pressed to the superdrive orifice. It fixed the superdrive. Now Lion recognizes the problem disks. I can burn DVDs.


    Interesting note: Before I blew into the superdrive, it was able to recognize blank Memorex LightScribe DVD+R disks, as well as blank CD-R disks. I was also able to play aleady-written CDs and DVDs.


    Be well, Apple lovers.

  • chipaway Level 1 (0 points)

    idnapper's suggestion (credit card wrapped in ipod cloth) worked like a charm. just to be sure i also slowed it down to 2x.


    thank you

  • dragonuv Level 1 (0 points)

    +1 for the cleaning cloth and credit card solution ! Had to try 3 times.

  • disappearingamerica Level 1 (0 points)

    Here is an update on the dual burner problem:

    "I have two SuperDrives and both were working well until I upgraded from Snow Leopard to Lion. Now neither drive will burn. And, when I do try to burn and get that error message, the Finder locks up and I have to relaunch the Finder."


    The solution for me seemed to be the combination of a Lens Cleaning disc and a new and different brand of blank DVD. I don't know what went wrong with the stack of blank Memorex DVDs I had been using for over a year, but they still didn't work even after I'd cleaned the lens. However, after buying some new Sony blanks, everything works fine. And this solution applies to both of my SuperDrives. They both stopped working at the same time, which suggested a software problem, but the simple act of cleaning the lens and using a different brand of DVD proved to be the correct solution. That makes me very happy.

  • stuartfrommaeystown Level 1 (0 points)

    Blowing air into the slot worked for me too!  But you can avoid the

    terrible environmental impact of the so called "compressed air" (which

    actually contains all sorts of harmful greenhouse gases) by using a

    hand pump of the type used to inflate basket balls, volley balls, etc.

    Just use the little "needle" attachment and insert it in the slot of

    your drive instead of your volley ball.  This is also cheaper, if you

    already have a pump like this.



    Obviously, be careful not to damage anything with the metal needle.

  • chrispaz Level 1 (0 points)

    Used the blower brush that I use to clean my camera lens, and it worked perfectly. Thanks a lot parkerpress.

  • disappearingamerica Level 1 (0 points)


    Well, it worked for a while. Starting to act up again.

    Still haven't gotten the 2nd drive to work.

    Maybe they're just too old to be fixed. They are from 2005, after all.

  • Parachnidox Level 1 (0 points)

    Macbook Pro Early 2008.

    Wrapping an Apple cleaning cloth around a credit card + blowing in air actually worked! Thanks so much guys

  • mojacarben Level 1 (0 points)

    Macbook Pro from early 2010. Never had a problem burning DVDs. Got he same error message about laser calibration on about 5 discs from a spindle that all worked perfectly before. Discs??? Drive??? Software??? Was convinced that it was due to an update overnight as I regularly burn DVDs and did one yesterday. In desperation tried blowing in the slot and then the credit card wrapped in Raybans cleaning cloth. Slid it back and forth a few times. Burned immediately afterwards on a disc from the same spindle. Go figure! Thanks all

  • Donald Morgan Level 6 (12,770 points)

    One thing to remember on the earlier CD/DVD Burners they were very picky about the blank media they liked. Many of us found that some of the lower cost Media was a problem like Memorex. However as time progressed the Burners did a much better job but still preferred Higher end Media like Maxell, Sony and the like. A shot of Air in them has never seemed to hurt and often solved the problem.

  • Arbor Friend Level 1 (5 points)

    I join the ranks of those frustrated with the error message:

    "disc can't be burned because the device failed to calibrate the laser power level for this media"


    Hardware Overview:


      Model Name:          MacBook Pro

      Model Identifier:          MacBookPro5,3

      Processor Name:          Intel Core 2 Duo

      Processor Speed:          2.66 GHz

      Number of Processors:          1

      Total Number of Cores:          2

      L2 Cache:          3 MB

      Memory:          8 GB

      Bus Speed:          1.07 GHz

      Boot ROM Version:          MBP53.00AC.B03

      SMC Version (system):          1.48f2


    MATSHITA DVD-R   UJ-868:


      Firmware Revision:          KB19

      Interconnect:          ATAPI

      Burn Support:          Yes (Apple Shipping Drive)

      Cache:          2048 KB

      Reads DVD:          Yes

      CD-Write:          -R, -RW

      DVD-Write:          -R, -R DL, -RW, +R, +R DL, +RW

      Write Strategies:          CD-TAO, CD-SAO, DVD-DAO


    System Software Overview:


      System Version:          OS X 10.8.5 (12F45)

      Kernel Version:          Darwin 12.5.0

      Boot Volume:          Macintosh HD

      Boot Mode:          Normal


    I've failed to solve this problem, despite two weeks of effort. I've tried just about everything suggested in the forum posts, shy of a complete reinstall and/or replacing the DVD drive. This is a 2009 15" MacBook Pro and I am out of the AppleCare plan, so investing loads of dough in a four-year-old machine is not all that applealing.


    1. Is it dust in the drive or dirt on the lens?

    > Tried compressed air     No change

    > Tried credit card and Mac cleaning cloth     No change

    > Bought a DVD drive cleaner and ran that     No change


    2. Is it the media?

    > The drive can read both CDs and DVDs with various types of files on them (zip files, all sorts of formats of text files, audio files, videos/movies)

    > Problems started when I tried to burn files on a Staples brand DVD-R disc

    > Switched to Memorex DVD+R discs     No change

    > I was able to burn files to an old CD-RW disc (from 2004)


    3. Is it the computer system or software?

    > All software is updated

    > Have the latest iOS update

    > Ran TechTool Pro 6 and everything checked out

    > I read somewhere about the possibility of needing to adjust software settings or computer preferences, but don't know where I saw that suggestion and have no idea what settings to change.


    If anyone (HELLO APPLE, ARE YOU LISTENING?) comes up with any concrete suggestions for solving my/our problem, I would appreciate it.

  • K Shaffer Level 6 (12,587 points)

    You could check and see about using an 'external optical super-drive' such as the USB Apple model that is listed on the Apple Store for $79. and is similiar to the external USB drive sold as a means to use DVD media with MacBook Air. Other users of MacBook/Pro & newer iMac that either don't have one built-in, or whose original one failed have used these. And this could be used to troubleshoot the issue, as a second or primary drive.


    These are said to work with install-restore discs &/or third party utilities on DVD that are used to boot the computer to restore, repair, and so on. And they also allow one to play DVD media.


    So maybe that is an answer of a sort. When a DIY repair using iFixit guides may be problematic or the replacement internal optical drive may be not cost effective.


    At some point if other hardware issues arise and the computer needs opened for other repair, the cost of having the optical drive done then would be a little bit more than that part itself, once the unit is opened for other repair. When I called to talk to a service advisor on the phone about a repair to one of my portables, the advisor suggested certain upgrades that would cost little over the parts, while mine was in for a logic board solder.


    Anyway, maybe this may help.

    Good luck & happy computing!

Previous 1 4 5 6 7 8 Next