3 Replies Latest reply: Oct 16, 2008 7:52 AM by Anish Sikri
Anish Sikri Level 1 Level 1 (5 points)
Hi,

I just recently got a first generation Ipod touch. When I hook it up to my itunes on my desktop, it shows up and I can transfer music extra on it.

But when I go to the Itunes Apps Store on the desktop and choose to buy an application, it buys it and says its downloading it. But after downloading it does not show up in the apps section of my itunes (desktop). And when I check the directory "C:\Documents and Settings\myusername\My Documents\My Music\iTunes\Mobile Applications" it is blank with the directory inside it - C:\Documents and Settings\anish\My Documents\My Music\iTunes\Mobile Applications\Downloads\applicationname.tmp

iTunes did not create the ipa files in the Mobile Applications directory at all. So I can't sync an application to the touch, as iTunes sees no application as there is no .ipa file of the application.

But if I go to apps store via the touch and buy it - it then downloads and installs it, and then I can sync it via touch to desktop easily.

But why can't I buy applications on the desktop iTunes and have it sync with my touch.

I have even deleted all the sync histories, backups and even completely restored my touch - (its running 2.1). Still the same issues.

I do not how to solve this.

If anyone can help me - that would be great.

-t

1st gen IPOD Touch, Windows XP Pro, Ipod Touch version 2.1
  • CasperGemini Level 5 Level 5 (4,305 points)
    Does the download complete, or do you receive any errors? I'm wondering if the issue is happening during the download process, or during the "processing file process." If the issue is happening during the processing of the file, it could be that there's an issue with your library file.

    Try the steps here:
    http://support.apple.com/kb/HT1451

    CG
  • Anish Sikri Level 1 Level 1 (5 points)
    Hi,

    I tried recreating the list as you mentioned, it did not work. Here is what I do, when the app is downloaded, and I go into its download folder, and then go into the applicationname.tmp folder and copy the "download.app" to the main directory of the mobile applications, and rename the file anyapplicationname.ipa and then I double click on that file, and it shows up in itunes application section.

    This is not the ideal solution, but why isn't Itunes proessing file properly. I only redownload the free applications till I get this sorted out, so that I can buy more apps

    Thanks,
  • Anish Sikri Level 1 Level 1 (5 points)
    Hi again,

    I just tested a fresh new install of itunes (latest 8.0.1.11) on another computer, authorized it and I did not connect touch to it. I just went to app store and bought a free app. And the same issue happened - it downloads the apps and stores the files in its temp folder, but does not process and create the ipa application file. And it does not show up in the my application section of itunes either.

    Could there be a problem with the latest version of itunes. I am absolutely running out of ideas...

    Can anybody confirm this bug or issue?

    Thanks

    PS - One application did process completely was the nytimes.com application. Out of everything else - only this one did work.