13 Replies Latest reply: Nov 6, 2008 2:21 PM by daygo140
GavinTan Level 1 Level 1 (0 points)
Hello Geeks,

I do not believe anyone is experiencing my problem but just in case one of you experts out there will know a quick fix for this.

My App Store icon is showing a number "3". That is how many apps on my phone that have an update available. I proceeded into the store and updated the apps on my phone. Done!

Problem, that was a few days ago. Ever since that update the number "3" on the icon has not reset and it's still showing although the apps have already been updated. Furthermore, iTunes today is showing me that there are apps available for updates but my App Store on the phone is not receiving a new list of updates.

So essentially the app store program on the phone seems to have the updates feature stuck. The update number counter for the icon is not resetting. The updates feature in the app store checks for updates but finds none although there is. Everything else is working, i.e. searching and installing apps.


Thanks!

Message was edited by: GavinTan

Windows Vista
  • 1. Re: App Store on iPhone - Updates Problem
    Cookdorf Level 1 Level 1 (0 points)
    I'm having the same problem!

    The App Store on my iPhone 3g (with newest firmware) shows that there are 2 updates available. When I click on App Store and then select updates, it shows nothing. It says loading, then loads a blank page where the updates should be. According to iTunes, all of my apps are up to date.. This is so weird. This happened on my previous iPhone (which got replaced yesterday) so I know it isn't the phone itself. Any questions feel free to post and i'll give all the info I can.

    I'd love to get this fixed!
  • 2. Re: App Store on iPhone - Updates Problem
    Envision99 Level 4 Level 4 (1,165 points)
    Hold the sleep button down until the power off slider appears and slide the bar over to the right. After the phone shuts off, hold the sleep button until the phone starts to power on. See if this fixes the problem.
  • 3. Re: App Store on iPhone - Updates Problem
    wilstev Level 1 Level 1 (0 points)
    I also have this problem, with a "2". At the time, I believe there were 2 updates. After updating the notification went away. However, I didn't realize it at first, but it did come back and never went away since then, and I get a blank screen when attempting to update as well.
  • 4. Re: App Store on iPhone - Updates Problem
    Cookdorf Level 1 Level 1 (0 points)
    Exactly as the poster above me.

    Here is some more info for you guys. If you need more, let me know!

    My 1st iPhone had this problem, did a full restore on it still had the problem, then had a hardware issue and exchanged it. The 2nd iPhone, got it, put old sim card in, updated the firmware via iTunes, then synced all of my music/apps (with all of them updated). And on the iPhone under App Store, it still shows 2 updates, even though iTunes says they are all up to date.

    In iTunes on my Macbook Pro, if I click on the applications, and select check for updates, it checks, then says no updates available.

    Here are some screenshots of my iPhone to help clarify..

    http://i178.photobucket.com/albums/w244/cookendorfernick/ShowsUpdates.png
    http://i178.photobucket.com/albums/w244/cookendorfernick/LoadingUpdates.png

    After you click App Store and click Updates, this is the screen you get after it loads.. no matter how long you leave it sitting on that screen. (and yes its been tried on different wifi's/no wifi.)
    http://i178.photobucket.com/albums/w244/cookendorfernick/AfterLoading.png
  • 5. Re: App Store on iPhone - Updates Problem
    randychur Level 1 Level 1 (0 points)
    My counter is also stuck and I'd like to know how to fix this as well.

    For now it seems the only way to get rid of the number is to delete offending apps, but that's not really a fix.
  • 6. Re: App Store on iPhone - Updates Problem
    jamesborr Level 1 Level 1 (0 points)
    Same problem here. The application in question is R.I.M Software's 12C Classic RPN Calculator. Even after the update was installed (which it acknowledges via the "Installed" button (grayed out) in the Update screen, it leaves it in the App Store Updates queue (which I believe to be the root of the problem). One can't re-install the update anymore (as App Store on both the iPhone and it's sync'ing computer both say that all updates are applied, but, one also can't delete it from the iPhones App Store Updates queue (which I believe to be the root of the problem.

    If one deletes it from the iPhone, it is also removed from the Updates queue and the counter resets to 0 (i.e. the alert is removed from the App Store icon). However, when one re-syncs it back to the iPhone, the installed update goes back into the Updates queue and the alert returns. So...., until this bug is resolved, I've deleted my $10 application from the iPhone...
  • 7. Re: App Store on iPhone - Updates Problem
    daygo140 Level 1 Level 1 (0 points)
    I am having the same issue with 2 specific apps. Obama for America and Say Who. I freshly installed both after a few minutes the App Store pops up the counter showing 2. If I go to try to install updates both apps ARE listed but when I go to try to install the button is grayed out and reads "installed". If I remove the apps, the counter disappears.
  • 8. Re: App Store on iPhone - Updates Problem
    NiKmishin Level 1 Level 1 (0 points)
    I've got the issue on my ipod touch 2g. The problems is with MazeFinger ver. 1.0.1 (from 16/10/2008). App Store says there is an update for it, but the first time I went to the updates in my ipod it said MazeFinger Installed. I tried to remove the application, but the notification wouldn't go even after restart. I did a full restore from iTunes, but it didn't help. Would be very useful if somebody said how to get rid of the annoying thing!

    Thanks!
  • 9. Re: App Store on iPhone - Updates Problem
    leapar Level 1 Level 1 (0 points)
    I am also having the same issue with MotionX Dice. I called Apple this morning and was advised they can't do anything at this point because it's only happening to one of my applications. I told them others were having the same issue with diff. apps. but until i have multiples they can't help me. They suggested I contact the support for the application for now.

    So i have deleted this application til a resolution has been resolved.
  • 10. Re: App Store on iPhone - Updates Problem
    Captain J Level 1 Level 1 (0 points)
    *** kind of answer is that? I am having the problem with the one app I purchased. The version I have loaded is newer than the update. Bafflement continues.
  • 11. Re: App Store on iPhone - Updates Problem
    Envision99 Level 4 Level 4 (1,165 points)
    It is a bs answer, I'm having the same problem now with "Say Who". I figured I'm just going to delete the app until they fix it then re-download it.
  • 12. Re: App Store on iPhone - Updates Problem
    swedechick Level 1 Level 1 (0 points)
    I am having the same problem with my iPhone 3G and the LiveJournal app. Since I've only had the phone for a week, I thought I was doing something wrong until now. Thanks for proving me not crazy. Now, if Apple'd take some notice too...
  • 13. Re: App Store on iPhone - Updates Problem
    daygo140 Level 1 Level 1 (0 points)
    What you can do is go to the App Store and pull up whatever app is giving you the issue then leave feedback by reporting a problem. I'm sure Apple will act on it quicker!