Skip navigation
This discussion is archived

Aperture freezes when trying to use vaults

7512 Views 21 Replies Latest reply: Jun 30, 2009 5:28 AM by bris-vegas RSS
1 2 Previous Next
aczyzyk Calculating status...
Currently Being Moderated
Oct 18, 2008 5:31 AM
I tried to delete a vault. Aperture froze and I had to force quit it.
I removed vault file manually from disk.
Since then Aperture slows down or freezes every time I try to open vault view pane or add new vault form menu. Other functions seem to work as usual.

I removed and then re-installed Aperture to fix it but with no luck.
So I think it is a problem within library.
Any ideas how to fix that?
MacBook, Mac OS X (10.4.9)
  • Jorgen Gustafson Level 1 Level 1 (20 points)
    Currently Being Moderated
    Oct 21, 2008 12:55 PM (in response to aczyzyk)
    I have the same issue on my iMac.
    PowerMac G5 Quad., Mac OS X (10.5.5), Intel iMac 24" and a TiBook at home.
  • Stu Coates Calculating status...
    Currently Being Moderated
    Nov 6, 2008 5:58 AM (in response to aczyzyk)
    I've had a similar problem. The only way I could find around it was to unmount the disks that I had the vaults on, launch Aperture and then remove the now "disconnected" vaults. Now re-mount the disks and recreate the vaults. This seems to be a major flaw in Aperture and has made me question its suitability as a mission-critical app.

    Stu.
    MacPro 8-core 3.0GHz, Mac OS X (10.5.5), 9GB RAM
  • BearsPaw Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 8, 2008 7:13 AM (in response to Stu Coates)
    Same problem here.

    Any attempt to Add or Update Vault causes Aperture to freeze.

    Does Apple read these posts?
    24"2.8GHz/4GB/500GB/SuperDrive/HD 2600 Pro, Mac OS X (10.5.5), Kensington 7 Port USB Hub + Billion3G Router+Aperture 2 + iWork 08
  • BearsPaw Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 8, 2008 7:46 AM (in response to aczyzyk)
    It's almost impossible to contact Apple about this issue.

    How about everyone sending feedback to Apple Aperture about this unbelievable problem?

    Does anyone know how to contact Apple directly by email?
    24"2.8GHz/4GB/500GB/SuperDrive/HD 2600 Pro, Mac OS X (10.5.5), Kensington 7 Port USB Hub + Billion3G Router+Aperture 2 + iWork 08
  • BearsPaw Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 8, 2008 9:33 AM (in response to aczyzyk)
    The following info found by Google,

    Try rebuilding your Aperture database by holding command-option while launching Aperture. A dialog will come up asking if you want to rebuild your library.

    This will ask, "Do you want to rebuild your library database?" and list three options - (Consistency check - Quit - Rebuild Now). A new screen opens - Aperture requires that you type your password.

    Both the consistency check and the rebuild seem to sort things out. But, I'm not able to view the vault.

    Aperture Help states, " Choose Window > Show Vaults (or press Shift-R). or  Click the Vault Pane button". Neither work.

    Google also found,
    Applications use preferences files to store the changes you make to application settings—via the Preferences dialog box, for example. But if preferences files become damaged, they can precipitate a crash. (Preferences files are stored in your user folder /Library/Preferences and are typically named after the application they belong to—com.intuit.quicken.plist is Quicken’s, for example.)

    Certainly, re-opening Aperture and at the same time holding down Keyboard Option & Command, then doing a consistency check, does seem to sort out Aperture.

    There seesm to be a lot of Keyboard shortcuts in Aperture that just do not work.
    24"2.8GHz/4GB/500GB/SuperDrive/HD 2600 Pro, Mac OS X (10.5.5), Kensington 7 Port USB Hub + Billion3G Router+Aperture 2 + iWork 08
  • BearsPaw Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 8, 2008 11:26 PM (in response to BearsPaw)
    Since rebuilding the Aperture Library Database, the Keyboard Shortcuts for Aperture now work as they should and I'm now able to view the Vault by selecting keyboard ⇑+R.

    When starting Aperture, Apple found it necessary to provide a facility to check the Consistency of the Aperture Library Database and to Rebuild the library database when required. A similar facility to rebuild the library database is also provided when starting iPhoto.
    To check the consistency or rebuild the library database of either of these Apple applications, simply hold down both the Keyboard Option and Command Keys when starting the application.
    These are the only two Apple applications that I have found to have this library database rebuild facility.

    Hope that this post provides some help.
    24"2.8GHz/4GB/500GB/SuperDrive/HD 2600 Pro, Mac OS X (10.5.5), Kensington 7 Port USB Hub + Billion3G Router+Aperture 2 + iWork 08
  • bluewater Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2008 6:33 PM (in response to BearsPaw)
    Thanks for suggestions. I did a consistency check and rebuilt the projects. Vaults still do not show or work. Only change was Aperature runs faster and i can quit normally after trying vault button, before it locked up and I had to force quit. Any other ideas anyone?
    Power Mac G5, Mac OS X (10.4.3)
  • Paul_Hunter Calculating status...
    Currently Being Moderated
    Nov 12, 2008 2:34 AM (in response to bluewater)
    Hi,

    I had a similar problem when saving to a vault on an external drive.
    The problem seemed to be that the drive was formatted in fat32.
    I copied all of the contents to another drive, re-formatted the drive as MAC OS Extended (Journaled) and restored. Vaults now work every time.

    May be worth a try.
    MacBook Pro, Mac OS X (10.5.4)
  • mikeoregon Calculating status...
    Currently Being Moderated
    Nov 14, 2008 9:49 PM (in response to Paul_Hunter)
    In my case Aperture would crash when I tried to create a vault. The solution was to erase and reformat the (new) external hard drive from fat32 to HFS with Disk Utility, then restart both my Mac and the hard drive. Now vault seems to work as intended.

    I also had my first album disappear after shutting down. The Option-Command rebuild returned it.

    Scary stuff, for a supposedly professional program!

    mikeoregon
    iMac Intel Core Duo, Mac OS X (10.4.11)
  • bluewater Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 7, 2008 6:29 AM (in response to mikeoregon)
    That is it. I independently discovered the same thing through trial and error (very frustrating for a professional program). Aperture simply does not like a fat32 configured vault. Once a fat32 vault is created, the vault button would freeze whenever that external hard drive was connected to the computer. When I dismounted that hard drive and restarted Aperture the problem would disappear.

    Bottom line: When using Aperature Vaults make sure the drive is configured to HFS+ ( ie Mac OS Extended Journaled).
    Power Mac G5, Mac OS X (10.4.3)
  • bsmaje Calculating status...
    Currently Being Moderated
    Jan 6, 2009 6:01 AM (in response to aczyzyk)
    I have the same problem here - when I touch anything in the Vault window in the bottom left-hand corner, Aperture freezes. Strangely, the drop-down menus still broadly work, but I can't do anything in the viewer or the inspector. I then have to Force Quit and restart Aperture in order for it to work normally.

    I have now deleted the vault from my network drive (which as per previous posts is probably configured as FAT32), but the freezing problem remains.

    Is there any way to solve this problem? It's a frustrating glitch in an otherwise very smooth package. And I would HATE to lose everything and have to rebuild my library, only to find that the vault hasn't been backing up properly.
  • pprioroh Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jan 19, 2009 6:19 AM (in response to bsmaje)
    I have the same problem - aperture freezing and vaults not updating but just giving a very quick flash of a dialog box then disappearing.

    All my disks have been HFJ/journaled - no fat32 at all on my computer.

    Anyone solve this problem?
    Mac Pro 3ghz/11gb/ATI x3870 & Imac 20", Mac OS X (10.5.6)
  • CoolKat5 Calculating status...
    Currently Being Moderated
    Feb 26, 2009 1:59 PM (in response to aczyzyk)
    I'm having a similar problem. Aperture crashes (shuts down) if I click the Vault Pane button. I have a FAT32 USB2 external disk where the vault is stored. Aperture crashed when I first created the vault. After I rebooted the MacBook, Aperture seems to have managed to update the vault which took over an hour. Twice since then it has crashed when I tried to access the vault pane. I've sent all three dumps to Apple. Hopefully they have someone working on it because this a big concern, and I'm an amateur, not a professional. If I depended on Aperture for my business I'd be even more concerned! I use referenced photos and have the photos backed up independently of aperture, but still I have a lot of time invested in creating and arranging the Aperture Library and feel vulnerable without a dependable backup.

    I'll try doing the consistency check on the library. Unfortunately I use this disk on a Windows machine as well, so can't re-format it in Apple format.
    MacBook
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.