8 Replies Latest reply: Dec 1, 2008 8:24 AM by vpatrickd
phendrickson Level 1 Level 1 (0 points)
I used to be able to play music using iTunes. Since we upgraded to 8, I can no longer play music. I click the play/pause button, but the time elapsed indicator for the song doesn't run.

I am running Vista.
I started the genius sidebar, but it took up a great deal of CPU and it kept going to the iTunes Store. (I then turned of the genius, since it was obviously thinking entirely too much.)
Yes, I can sync my iPod and listen to music on it.
No, iTunes does not respond to verbal abuse. Believe me, I've tried!
If I convert the song to mp3 and use Windows Media Player, I can listen to the music. (No, it's not the speakers.)
Oh, and yes I did the windows open and shut thing, reboot (many times) and even uninstalled and reinstalled iTunes.

Any ideas?

Windows Vista
  • vpatrickd Level 1 Level 1 (0 points)
    same problem here.
    Mine's a bit more complicated. Some songs are playable, but it wasn't smooth music (so many noises and cuts). Some songs are perfectly fine. And some doesn't even play at all. I've also tried re-installing iTunes.

    And again.. they work perfectly fine on Windows Media Player. And no, I don't want to use WMPlayer as my music player. So please address this issue ASAP.
  • laurel007 Level 1 Level 1 (0 points)
    I too have now experienced the exact same problem. I have also done all of the same courses of actions. Do you or anyone know of the solution? As, so far no-one has been able to help me.
  • beef4dinner Level 1 Level 1 (0 points)
    Repair Quicktime in Add/Remove Programs
  • hykaiaxgun Level 1 Level 1 (0 points)
    same thing just happened to me. Yesterday worked fine, today nothing. I just trashed itunes 8 and reinstalled 7.6 and also reinstalled quicktime just for good measure. Works perfect now. Sorry Apple but really, take that piece of *&&^% off the market until you get your act together.
  • mhrd1088 Level 1 Level 1 (0 points)
    I've been having the same issue...however repairing QuickTime in the add/remove programs panel didn't help me. I have tried uninstalling and reinstalling iTunes also, and it still wont play. The play button turns to the pause symbol, but no music plays and the counter doesn't change. Hopefully there will be a fix soon.

    Message was edited by: mhrd1088
  • vpatrickd Level 1 Level 1 (0 points)
    Still not working after repairing quick time.
  • SWII Level 1 Level 1 (15 points)
    Hello
    I had this same problem after disabling genius, apple store suggested I repair Itunes. went to the control panel and did so. all works fine now, music plays, able to purchase from store. hope this helps.

    Message was edited by: SWII
  • vpatrickd Level 1 Level 1 (0 points)
    Still had the same problem after repairing iTunes and QuickTime. Apparently the problem is with QuickTime, I've tried playing my music using QuickTime and the playback was horrible. (works fine with WinMedia player).

    Any other ideas?