1 2 Previous Next 15 Replies Latest reply: Nov 9, 2008 6:24 PM by hakujin
Tony Mallis Level 1 Level 1 (30 points)
I hope that there is someone who can help with this problem.

I have a MBP and a Macbook both running 10.5.5

I am trying to network them at home. I have a D-Link 524UP Wireless Router.

When I go into System preferences (on either computer) and turn on file sharing I can see that computer appear in the other's Finder sidebar. BUT, I can't get any drives or folders to actually appear in Finder next to the networked computer.

Finder sees the computer that I'm trying to connect to (in the sidebar) and for a few minutes tells me it's "connecting..." but then comes up with a "Connection Failed" message.

Screen sharing on either computer works fine.

Help please!...this is driving me nuts

Oh...and a screen shot of one of the finder windows is here:
http://i204.photobucket.com/albums/bb193/tonesterau/Picture2.png

You'll notice that the connection failed on the shared computer.

Message was edited by: Tony Mallis

MacBook Pro 2.16 GHz Intel Core 2 Duo, Mac OS X (10.4.9), 2 Gb RAM
  • 1. Re: Sharing between 2 macs...help please
    Zlig Level 4 Level 4 (1,340 points)
    Have you tried connecting as the administrator of the computer to which you are trying to connect?
  • 2. Re: Sharing between 2 macs...help please
    Tony Mallis Level 1 Level 1 (30 points)
    How would I do that???

    Message was edited by: Tony Mallis
  • 3. Re: Sharing between 2 macs...help please
    Zlig Level 4 Level 4 (1,340 points)
    No just use the "Connect Aa" option and login as the Adminstator of the other machine. You would need the login and password of this machine to do this.
  • 4. Re: Sharing between 2 macs...help please
    Tony Mallis Level 1 Level 1 (30 points)
    Well I tried that and nothing happens after I hit the"Connect As" button...had me confused as to what it was referring to, since it appeared to do nothing on clicking.
  • 5. Re: Sharing between 2 macs...help please
    Zlig Level 4 Level 4 (1,340 points)
    Hi Tony,

    Just tried it now between my iMac and Macbook sharing the same network and internet connection. In my "system preferences > sharing > file sharing" I clicked the "options" button (bottom right) and have "Share Files and Folders Using AFP" and "Share Files and Folders Using SMP" both checked. You can configure the "USERS" in this window as to how much access you would like them to have (i.e. Admistrator: Read and Write etc.)

    Mine comes up as "Connection Failed" but then I click the "Connect As" button and insert the Administrator Name and Password (of the computer to which I am trying to connect) and it works.
  • 6. Re: Sharing between 2 macs...help please
    Tony Mallis Level 1 Level 1 (30 points)
    Zlig
    Thanks for the response

    I have done just as you have described. I made sure I switched on both share by AFP and SMP.

    I see the guest computer in finder sidebar. But nothing else. It attempts to make a connection but after a few minutes it comes up with "COnnection Failed".

    And, just as you described, I click on "Connect as" but nothing appears. THere is no login dialogue box or anything to prompt me for a username and pwd.

    This is getting too frustrating.

    Could it be a 10.5.5 issue or a router issue?

    Message was edited by: Tony Mallis
  • 7. Re: Sharing between 2 macs...help please
    Zlig Level 4 Level 4 (1,340 points)
    Tony, is the Firewall enabled? If so try disabling and try again.
  • 8. Re: Sharing between 2 macs...help please
    Tony Mallis Level 1 Level 1 (30 points)
    Well, I tried again when I got home tonight and guess what?? It works! I first tried with the firewall disabled and then with it back on and it worked. (I suppose that disabling the firewall shouldn't make any diference as the firewall automatically allows AFP connections anyway.

    So I have no idea what I wads doing wrong last night but tonight all is OK.

    Thanks for your help!

    Next question.....

    I can see the drives of each connected computer BUT I cannot see the bootcamp partition or the FAT32 partition of an external hard drive (the MAC OS partition comes up OK). I am assuming that AFP cannot connect to networked drives? Am
    I correct and if so is there any way to connect to FAT32 drives?
  • 9. Re: Sharing between 2 macs...help please
    Zlig Level 4 Level 4 (1,340 points)
    Hi again. As I understand it the only way you can see a Bootcamp partition is for the Mac to be started up in Windows. I'm not much of a Windows person so I stand to be corrected. Perhaps someone with more experience in this area can help or, better still, post this as a new query in the "Windows Compatible" section of the Discussions.
  • 10. Re: Sharing between 2 macs...help please
    trickster41 Level 1 Level 1 (0 points)
    Hi Zlig, I was reading through this post as I have the exact same issue. I tried everything as recommended but I can't get past 'connect as' I don't get anything. My firewall is not on or rather it is set to allow all incoming connections.

    I appreciate any help with this as it is taking too much time to figure out and therefore very frustrating. lol
  • 11. Re: Sharing between 2 macs...help please
    Byram Christensen Level 1 Level 1 (20 points)
    I am having the same problem - When you click the "Connect As" I get no window or anything. On other machines -( I have several) the login window with a user & PW comes up (imac - 4 months old w/ 10.5.5).

    Message was edited for typo by: Byram Christensen
  • 12. Re: Sharing between 2 macs...help please
    Zlig Level 4 Level 4 (1,340 points)
    Hi could you start by going through the points above (SMB and APF checked etc) - once you confirm we can take it from there.
  • 13. Re: Sharing between 2 macs...help please
    trickster41 Level 1 Level 1 (0 points)
    Hi Zlig, Unfortunately my other computer is having problems. It is a iBook G4 running leopard. We restarted it and it wouldn't come back from that. I will shelf this problem until we fix the laptop. We have tried several steps to fix the iBook. I believe he went on to a discussion board and did what was recommended. Ie, insert the installation disk but nothing worked.

    Thanks anyway,
    Karen
  • 14. Re: Sharing between 2 macs...help please
    Zlig Level 4 Level 4 (1,340 points)
    Hi sorry to hear that - I hope its something small causing your problem
1 2 Previous Next