11 Replies Latest reply: Jan 13, 2009 10:42 AM by flipsix
MelindaC Level 1 Level 1 (0 points)
iTunes 8 won't let me burn a disc. It gets as far as finalizing and then freezes. I have wasted to discs with this problem. I have been able to burn discs before, but now it is not working. Just last week I burned a disc with no problem. I am using8 8.0.1. I thought about downgrading to iTunes 7, but then I won't be ab;e to play video, which is why I upgraded to 8 anyway. Does anyone know a fix for this or is this an apple bug? Thanks ahead of time for any help.

iMac 17" 2 Ghz Tiger and Macbook 2GB white with Leopard, Mac OS X (10.5.4)
  • Carolyn Samit Level 10 Level 10 (98,320 points)
    Hi Melinda,

    For starters, are you using CD-R not CD+R ?? Also, try a different media. I had this happen also, went from using Sony to Verbatim and that did the trick.

    And go here: How to backup your media in iTunes

    Carolyn
  • MelindaC Level 1 Level 1 (0 points)
    I know it can't be the disc because I have a bulk pack of about 100 blanks that I have been using and it has always worked. Thanks for your input though. Anyone else have any other suggestions??
  • MelindaC Level 1 Level 1 (0 points)
    bump
  • Diane Wordsmith Level 5 Level 5 (5,995 points)
    I think we need to narrow down whether the issue is with iTunes or with your burner.

    Can you burn a disc a all (as in through another program)? Can you burn through Finder? You might also try logging in under another user account on your mac and see if you can burn. It could be a problem with your User account. Do you get an error message or does it just freeze up?
  • TheGuyintheProjectionBooth Level 2 Level 2 (195 points)
    I just realized that I am running 8.01 and I did not update it. So I am just getting over that shock, but . . . I have noticed that since the beginning of 10.5.x that anything to do with burning any kind of media has become hit of miss. And that has been with Toast, iTunes, iDVD, iMovie . . .

    Once I get over the shock of being in iTunes 8.01, which would explain why things sounded so crappy this afternoon, I will try burning some discs with this version and report back.

    Good luck on what you find . . .
  • MelindaC Level 1 Level 1 (0 points)
    I don't have another burn software and I only have one user account. Its worked in the past and now it just freezes and I have to force quit to get out of it. It burns the songs and then the last couple won't play because it freezes. It freezes at the finaling disc stage.
  • TheGuyintheProjectionBooth Level 2 Level 2 (195 points)
    First and no I did not update. I did it on it's own.

    Nope. Didn't work. The first try the disc processed in a second and popped out unburnt. When I put in back in it was considered a blank disc. iTunes was totally unresponsive and had to be forced quit. The second time I took the disc the new window that used to be in the Prefs popped, I set my settings and hit burn. My list was checked, the disc was "initialized", it said that the first song was being burned which took a second. The it says that it is finalizing the disc longer before it should. Sits there for a while . . . still finishing . . . . still . . . still . . . . finishing . . . . still . . . . I'm thinking the way it was with the iDisc and your write would take a second but the "finalizing" was the actual write that would show a spinning candy bar for the time it actually takes to write. Still finalizing. Still finalizing . . . . Oh and the first one after the disc ejected all windows became unresponsive, the app would not quit and had to force quit. Still finalizing and I have no idea what is happening or how long this is going to take. I'm not getting anything like we use to get in the progress window; showing each song as is was being processed and burnt with a time and progress thermometer.

    Yup. Burning in iTunes 8.0.1 is broken.

    Oh, still finishing.

    20 minutes later . . . still finishing . . .

    40 minutes . . . . still finishing . . . .

    Tried to stop it and it says that it will break the disc if I do and gives the option to or not.

    iTunes screwed up my library ages ago and this might be the perfect reason to dump everything and start over with 7.2 that was the last best version that I remember.

    Still finishing . . . .

    Stopped the disc. It says it is Canceling and it may take a minute or two. If that is on the Disk Util scale this could be a month.

    10 minutes still canceling . . . .

    Since the disc is supposedly trash, I'm Force Quitting iTunes . . . .

    Trying to eject via the keyboard, it won't. My second burner ejects just fine. Saved this post and will restart to see if the disc will eject. Be right back . . .

    The disc ejected right before the desktop came up. And when mounted came up as a bank disc which the OS tried to burn, did, and it failed at the finish. Ejected it and remounted it, it came up as a blank disc that I then burnt some stuff that failed during finish. then in Toast it saw it as a blank disc and burnt some stuff and failed during the lead out. So I son' think it's completely iTunes, but had noticed in 10.5.x I can no longer burn on the run like I use to in 10.4.x. I did more testing with other media and applications (up to date) and nothing works as is used to. So . . . .

    Apple so sad. I remember in OS9 every update was new, exciting, you'd have cool new features and a faster smoother running machine and it didn't leave a mess. Oh well . . . .
  • ParkerApple Level 1 Level 1 (0 points)
    Did you ever solve this problem. I have been frustrated by this for quite some time. I have not seen a solution. I don't think I will be downloading any more updates.
  • dddangelo Level 1 Level 1 (0 points)
    I don't have a MAC so this may not be helpful. I also burned some songs and then it said Cancel, although behind that message it said that the disk was finalizing. Well, I ignored the cancel message and let the DVD (I don't do CDs because I always lose too much info.)Did anyone have the symbol ! at any songs? I can't find a thing on here about it. Every song that was not in AAC format didn't burn and had the ! mark in front of it. I didn't get 200 out of 1200. When I tried to make them all ACC, or find out why they didn't burn, I got the same message with both tries - that I-Tunes couldn't find the songs. I bought most of them from their store! Did I need to make them AAC as soon as I bought them? Some of you mention finding songs on the hard drive, doing things manually (I don't know how), or using outside software. I'd appreciate any help. Thanks, Dawn
  • spotzkw Level 1 Level 1 (0 points)
    Did you ever get it to work?
    I'm having the exact same problem with 8.0.2.
    Incredibly frustrating.
  • flipsix Level 1 Level 1 (0 points)
    does anyone havea solution for this problem yet?