Previous 1 2 3 Next 40 Replies Latest reply: Nov 2, 2009 12:54 PM by Lany
Mike Matthews Level 1 Level 1 (10 points)
Hi:

Within System Preferences > Date & Time > Time Zone, the time zone is stuck on GMT--which results in the Apple Time Server producing the incorrect time for my time zone (Pacific time).

So where is the file that this system preference writes to? I assume deleting that file will allow me to reset this preference properly. (Creating a new user didn't solve the problem, nor did deleting /Library/Preferences/.GlobalPreferences,plist.)

Otherwise, it looks like we're headed for an erase and install.

TIA
mm

Mac OS X (10.5.5)
  • LarryHN Level 9 Level 9 (70,855 points)
    Try "your username" ==> library ==> preferences ==> com.apple.clock.plist

    Drag it to the desktop and see if that will help - if it does not you can return it to the preference folder

    LN
  • Barry Hemphill Level 8 Level 8 (36,970 points)
    Hello Mike:

    I hunted around and could not find the preference file that controls the time zone either.

    If you decide you need to reinstall, I strongly suggest you NOT do an erase and install. An archive and install gets you - essentially - to the same place without the risk.

    Barry
  • nerowolfe Level 6 Level 6 (13,070 points)
    Mike Matthews wrote:
    Hi:

    Within System Preferences > Date & Time > Time Zone, the time zone is stuck on GMT--which results in the Apple Time Server producing the incorrect time for my time zone (Pacific time).

    So where is the file that this system preference writes to? I assume deleting that file will allow me to reset this preference properly. (Creating a new user didn't solve the problem, nor did deleting /Library/Preferences/.GlobalPreferences,plist.)

    Otherwise, it looks like we're headed for an erase and install.

    TIA
    mm

    Before you do an erase and install, drag the entire preferences folder onto your desktop and reboot.
    If that fixes it then you simply drag the files back one at a time until the problems recurs and you know which file was bad.
    if this does not work, do the same thing with the system preferences folder.
    If you are intending an erase and install, it really does not matter, and you may just fine the bad file and avoid a reinstall.

    Also see if running in the safe mode has the same problem

    Message was edited by: nerowolfe
  • barnamink Level 1 Level 1 (10 points)
    I had this problem, and after unsuccessful attempts by Apple's support to diagnose it, I figured it out myself. The problem was with the /etc/localtime file. It was a directory, instead of a symlink. I think Tiger (which is just what I migrated from) used to have it as a directory, whereas Leopard changed it to a symlink. Long story short, if you erase / rename your /etc/localtime, and then set the timezone, it will start working.

    You will need to enable the root user for this, so be sure you know what you're doing. But once you're root, just do a

    cd /etc
    mv localtime localtime.old

    Then set the time zone again, and this time it will remember it.
  • tubes_rock Level 1 Level 1 (0 points)
    This has COMPLETELY resolved the issue. This was the exact problem I was having, and in 20 seconds, this fixed it. Thanks, barnamink!
  • Mike Matthews Level 1 Level 1 (10 points)
    Thanks for the note.

    Unfortunately for me, I had to get an erase and install going before your post arrived. But if it helped solve someone else's problem, you get the Solved Points.

    mm
  • davidjulian Level 1 Level 1 (0 points)
    Hi, I have the same problem, but do not understand your fix? Can you dumb it down for me?
  • davidjulian Level 1 Level 1 (0 points)
    Sorted, finally got the root password accepted so it would authorise the change to the localtime file.
  • jeremydb Level 1 Level 1 (0 points)
    thank you so very much.
  • Spencer Filichia Level 1 Level 1 (0 points)
    I too would appreciate the dumbed down version of this fix. I've been trying to get this solved for well over a month and this is the first thread that I've seen that actually has a fix that someone has confirmed to work, so I'd love to know exactly how to do what is being suggested.
  • Spencer Filichia Level 1 Level 1 (0 points)
    I think I've figured out what you are talking about using the terminal, but I can't find the directory or file you are referring to. Within the "etc" directory I get a list of the following files, non of which are "localtime"

    6to4.conf notify.conf
    6to4.conf.applesaved ntp.conf
    X11 ntp.conf.applesaved
    afpovertcp.cfg openldap
    aliases pam.d
    aliases.db passwd
    appletalk.cfg pear.conf
    appletalk.nvram.en0 periodic
    appletalk.nvram.en1 php.ini.default
    authorization postfix
    authorization.cac ppp
    bashrc printcap
    crontab profile
    crontab.applesaved protocols
    csh.cshrc racoon
    csh.login rc
    csh.logout rc.common
    cups rc.netboot
    daily rc.shutdown
    defaults resolv.conf
    dumpdates rmtab
    efax.rc rpc
    find.codes rtadvd.conf
    fonts rtadvd.conf.applesaved
    fstab services
    fstab.hd shells
    ftpusers slpsa.conf
    gettytab slpsa.conf.applesaved
    group smb.conf
    hostconfig smb.conf.applesaved
    hostconfig.system_default smb.conf.template
    hostconfig~ snmpd.conf
    hosts ssh_config
    hosts.equiv ssh_config.applesaved
    hosts.lpd sshhost_dsakey
    httpd sshhost_dsakey.pub
    inetd.conf sshhostkey
    inetd.conf.applesaved sshhostkey.pub
    kcpassword sshhost_rsakey
    kern_loader.conf sshhost_rsakey.pub
    kern_loader.conf.applesaved sshd_config
    mach_init.d sshd_config.applesaved
    machinit_peruser.d sudoers
    mail syslog.conf
    mail.rc syslog.conf.applesaved
    master.passwd ttys
    memberd.conf ttys.applesaved
    moduli weekly
    monthly xgrid
    motd xinetd.conf
    named.conf xinetd.conf.applesaved
    named.conf.applesaved xinetd.d
    nanorc xinetd.d-migrated2launchd
    networks xtab

    Was wondering if anyone could identify one of these files as possible ones to rename or erase?
  • lmacy Level 1 Level 1 (0 points)
    Actually you do not need to enable the root user. Use the Finder's "Go to Folder..." command to open the /etc folder and drag the localtime folder to the trash. You will need to authenticate as an admin to do this. Then just open System Preferences and set Date and Time settings.

    It appears that this only happens in a migration to Leopard, but I can not be sure.

    Larry
  • yoojin's apa Level 1 Level 1 (0 points)
    Thanks,

    Although I did not follow your directions exactly (as some of the people below are trying to figure out) . . . I just used the "got to folder" option under the "go" menu in the finder and went to "/etc/" -- I then just deleted the "localtime" folder (which apparently should not be a folder, but a symlink whatever THAT is). Then I could reset the time zone in system preferences. It works now.

    hope that helps someone.

    -yoojin's apa
  • Paul Koning Level 1 Level 1 (35 points)
    Actually, you don't need to do this as root. Just do it as an administrator, with the "sudo" command:

    cd /etc
    sudo mv localtime localtime.old

    and the rest is the same. Works nicely, thanks for the help!
Previous 1 2 3 Next