13 Replies Latest reply: Nov 4, 2008 12:35 PM by KOENIG Yvan
James Mol Level 3 Level 3 (685 points)
Can anyone help us out on this one? My son has a project for a class and need to center the numbers in a table and have the decimal points aligned. We have tried everything but cannot get this to happen. Left aligning in the inspector gets the decimal points aligned, but the numbers are not centered. We tried right indents, alignment of decimals, but nothing changed the numbers in the table. Centering will not align the numbers. We tried decimal tabs but they seem to do nothing in the table and it seems you must set the tab in each cell. Below are a sample of the numbers used. If anyone can figure this out, please let us know.

Thanks

12.6
4.0
3.0
5.7
24.0
18.0
ps. can anyone share how to past a table or pict so I can show you what I mean?
Thanks

Power Mac Dual 1.4GHz G4; iMac Core 2 Duo, Mac OS X (10.5.5), 2GB Ram, SATA RAID external drives; 1GB Ram
  • Jerrold Green1 Level 7 Level 7 (29,950 points)
    James,

    By formatting a Table's Cells to Number with 1 decimal, your content will align on the decimal if you also select Right text Alignment as in this example.



    Is this what you had in mind?

    To post a graphic, you must use a server such as Picasa or any of several others to host the file and then enter a link in your post. If you search the Discussions you will find complete instructions.

    Jerry
  • James Mol Level 3 Level 3 (685 points)
    Thanks for the tip. Getting it aligned is the first part, now the numbers need to be centered in the column aligned to the decimal. As soon as you choose Center text Alignment the numbers center viacharater width, not by decimal.
    I spent some more time trying to get this figured out and from what I can tell, there is no way to do it with the content formatted to Number. If you change the formatting to text, set the tab to decimal via the T or Text pane, then set right paragraph indent you can get really close to a centered decimal alignment.
    I guess this is one of those feature that not to many people would use. I haven't used it but a few times in the years I was using Word (with Work I think I just copied part of Excel to the Word doc) and my the only reason my boy needs it is because that is the way the lab needs to be formated - of course the teacher uses Office.
    I would still like to know if there is a way to do it within the table, so I will leave this question open for a while.
    Thanks for the short answer on the graphic inclusion, I will research more in the discussions.
    Jim
  • Level 8 Level 8 (41,790 points)
    As far as I know, there is no 'center the decimal character' feature available.

    Yvan KOENIG (from FRANCE mardi 28 octobre 2008 12:17:14)
  • Jerrold Green1 Level 7 Level 7 (29,950 points)
    Jim,

    Here's a rather simple workaround:



    I have created white space to the right of the data column by adding an empty column. Then I set the left border of the new column to None.

    Hope this solves the second part of your problem.

    Jerry
  • James Mol Level 3 Level 3 (685 points)
    Thanks, it seems to confirm my suspicions.
  • James Mol Level 3 Level 3 (685 points)
    What a great idea! Much better than retyping all the data.

    Thanks for your input, I will pass the information along to my boy.

    Jim
  • Level 8 Level 8 (41,790 points)
    BRAVO.

    This is the kind of tip which I like.

    Yvan KOENIG (from FRANCE mardi 28 octobre 2008 14:02:32)
  • 153957 Level 2 Level 2 (485 points)
    Another option which is not as easy as the solution with the white border.. and this one limits your font choice:

    Set the Cell Format to Text.
    Make sure that every cell has the same amount of characters before and after the decimal.
    So that if there is a cell with 12.0, and one with 6.0, add a space before the 6.0, that way is also has 2 before the . and 1 after it.
    Then change the font to a Fixed-width font; Courier/Monaco
    Then just choose center alignment, and they should be aligned properly..
  • Level 8 Level 8 (41,790 points)
    Alas, this doesn't guarantee that the characters will be correctly aligned on a printed document.
    The Jerry's tip works perfectly on paper as well as on screen.

    Yvan KOENIG (from FRANCE mercredi 29 octobre 2008 12:15:23)
  • Caitlyna Level 1 Level 1 (5 points)
    I've been looking for decimal alignment in tables as well. I can insert a tab by typing 'option-tab' and can add a Tab that applied in the cell in the normal way of clicking on the ruler bar, then clicking the tab until it becomes a decimal tab stop. Presto, the numbers align on the new decimal tab just as they are supposed to.

    Unfortunately, once I click on another cell, the 'option-tab' disappears from the cell and it returns to the original cell alignment (left, center, right).

    Since tables are created, to a large degree, to handle numbers, the lack of a workable decimal alignment is a serious flaw, and judging from the manual (yes, I RTF manual) tables are intended to handle in-cell alignment on tabs, it just doesn't handle it properly.
  • Level 8 Level 8 (41,790 points)
    This problem was reported in # 5945809 :

    19-May-2008 09:10 AM Yvan KOENIG:
    Hello

    I found a behavior which I feel as a bug.

    In Pages, at least when the app is used with the French settings (decimal comma) the decimal tab doesn't behave as a decimal one but as a tabtoright one.

    Attached are a sample file and a screenshot.

    Yvan KOENIG


    'bugtabdeci.zip' was successfully uploaded

    I sent a complementary layer today.


    03-Nov-2008 04:30 PM Yvan KOENIG:
    As I got no news, I add some words.

    In the Help of Numbers, it is stated that we may apply tabs in table cells :

    +Setting Tab Stops to Align Text+
    +You can align text at specific points by setting tab stops in a text box, table cell, or+
    +shape. When you press the Tab key (or Option-Tab when you’re working in a table cell),+
    +the insertion point (and any text to the right of it) moves to the next tab stop, and text+
    +you type starts at that point.+
    +You can work with tab stop settings by manipulating the tab symbols on the horizontal+
    +rulers. You can see symbols for existing tab stops on the horizontal ruler when you click+
    +View in the toolbar, choose Show Rulers, and then select some text on a page.+

    Alas, these tab stops don't work.

    If we enter a tab in front of a number, the tab is removed.
    If we apply the format "text" to the number, the tab removes but then the decimal tab behaves as a tab to the right one.

    It resemble to a bug.

    Yvan KOENIG (from FRANCE mardi 4 novembre 2008 13:32:42)
  • Jerrold Green1 Level 7 Level 7 (29,950 points)
    Yvan,

    This Pages Table which works as described in Pages Documentation, when pasted into Numbers loses Tab behavior. Even within Pages though, behavior is erratic and sometimes can not be duplicated. This is why I did not recommend the method to the OP.

    Jerry

  • Level 8 Level 8 (41,790 points)
    Thanks Jerry.

    It appears that the problem in Pages is, at least partly, a localisation problem.
    With the decimal comma it doesn't work. The tab characters are automatically removed.

    I will add a few words to my report.

    This day is a great day.
    For the first time, I received a message from Bugs Hunters saying that one of the bugs which I reported was killed. Alas, the info is under Non Disclosure Agreement so I am not allowed to tell which it is. I will just say that it's linked to AppleWorks 6.

    Yvan KOENIG (from FRANCE mardi 4 novembre 2008 21:32:23)