Previous 1 2 Next 15 Replies Latest reply: Nov 1, 2008 6:51 AM by TD109
TD109 Level 1 Level 1 (0 points)
I have a big problem with my iTunes library. It seems that several songs have
developed an exclamation mark beside them and therefore cannot be "found" when
trying to play them. The library is contained on an external hard drive and the
songs are there but can't play them on my songlist. I have one playlist that
has the exclamation marks beside every song and therefore the complete playlist
is useless. Can anyone help me with this problem? Is it a setting that has been changed or something more serious?

Dell Inspiron 6400, Windows XP, Main router Linksys G
  • Attitude Level 1 Level 1 (115 points)
    Check Preferences > Advanced. Check the music folder location, and ensure the tickboxes "Keep iTunes Music Folder organised" and "Copy files to iTunes Music Folder..." are ticked.
  • TD109 Level 1 Level 1 (0 points)
    Thanks for the reply. I checked this and both boxes were ticked. I tried highlighting a song on my music list and same problem: as soon as you highlight a song, the exclamation mark pops up to the left of the title and the following message window comes up - "The song "(song title)" could not be used because the original could not be found. Do you want to locate it?" But it does not locate it. This all came about when I plugged in a new iPod Nano, up until then everything worked just fine. Any suggestions as to why the exclamation mark pops up?
  • Katrina S. Level 7 Level 7 (24,095 points)
    When you pugged in the new nano, did Windows change the exHD letter on you?

    That would cause all the "! original could not be found" problems. iTunes expects the music files to be on drive E: and now they are listed under drive F:....because windows gave drive letter E: to the nano.
    That's just for example, of course I don't know what your actual drive letters are.

    You need to eject the nano, go into Windows and set the drive letter back on your exhD to whatever it was before, then restart iTunes. Make sure it can see all the music and tehn plug your nano back in.
  • TD109 Level 1 Level 1 (0 points)
    Thanks Katrina. I hate to sound stupid but where in Windows would I go to check
    the exHD letter? Under My Computer the exHD is letter "F" and as far as I can
    remember that hasn't changed but maybe it has changed in another location or file for iTunes.
  • Katrina S. Level 7 Level 7 (24,095 points)
    You can find out what itunes thinks it should be by opening the itunes libary.xml using WordPad.
    (If your library is very large, it might crash notepad)

    It should be about the 10th line down, after <key>Music Folder</key>

    The XP path is
    \Documents and Settings\username\My Documents\My Music\iTunes\iTunes Music Library.xml
  • TD109 Level 1 Level 1 (0 points)
    Hi Katrina: Sorry I couldn't check out your suggestion this morning but I had
    to leave for work. Have checked out the XP path that you gave me but it doesn't
    tell me anything about the exHD letter. I guess I'm not computer savy enough to
    figure this one out but I do appreciate you taking the time to try and help me
    out. I guess I'll leave it for now and tackle it again when I'm not so frustated with this whole mess. Thanks again.
  • TD109 Level 1 Level 1 (0 points)
    Hi Katrina. Will try this again if you don't mind. I got in to WordPad (had never used it before so had to fumble around) and located the line <key> Music Folder <key>. The next line reads as follows:
    <string> file://localhost/C:/Documents%20and%20Settings/Barbara/My%20Documents/
    My%20Music/iTunes/iTunes%20Music/ </string>.
    What does all this tell you?
    This has been really frustrating as I have 68 GB of music that I can't play.
    Good thing I didn't get rid of all my CD's etc.
    Hope you can shine some light on this.
  • jeska20 Level 1 Level 1 (0 points)
    I have the same problem. I have songs that were once playing on my library, and now have the exclamation point. When I click 'locate,' I am able to locate the files; they are in a different location than what is on the preferences-> advanced-> ITunes music folder location. However, I changed this to the folder in which they are actually located, and I still get the Exclamation. I can manually locate each song individually, but is there a quicker way to do this?
  • Katrina S. Level 7 Level 7 (24,095 points)
    +What does all this tell you?+

    Ugh, it looks like iTunes couldn't find the exHD so it reverted back to the default C: drive location
    C:/Documents and Settings/Barbara/My Documents/My Music/iTunes/iTunes Music/

    Are there any other recent library files anywhere on your P (C: or F: drive)?
    Search on *itunes library.itl*
    If so, you can press *& hold* the shift key while starting itunes and see if those ones have all your music without the ! marks.

    You can easily rebuild a blank library by dragging all the music back over into the iTunes window from Win Explorer, but you'll loose all your ratings, placounts, and playlists....
  • TD109 Level 1 Level 1 (0 points)
    Hi Katrina: I ran search for iTunes Library.itl and all that came back was
    the C:/documents and settings etc.
    Is this what you meant for me to do?
    When I open iTunes no exclamation marks come up until it tries to play a song
    and then the exclamation mark comes up beside the song.
    I'm afraid when it comes to the tech end of things I'm a bit of a dummy.
    What do you suggest as my last resort?
    I really appreciate your patience trying to help me solve my problem.
  • michant2 Level 1 Level 1 (30 points)
    Sounds like you need to change where itunes is looking for your music. In iTunes, click Edit>Preferences and then click the Advance tab. Make sure the iTunes music folder location has the directory for your external hard drive. If not, click the change button and browse to the external hard drive. Sometimes, when windows updates, it changes iTunes back to the default C:/documents and settings/anthony/mydocuments/music etc. and I have to go into iTunes and change it back to Y:/music which is my external hard drive.

    Got to My Computer and note what drive letter is assigned to your external hard drive and make sure you point iTunes to the appropriate folder.
  • Katrina S. Level 7 Level 7 (24,095 points)
    What do you suggest as my last resort?

    You have two options:
    1) You can click on each song with the ! and browse to your exHD and show itunes where it is. This will of course be very tedious and take a long time.

    2) You can rebuild your library. Press and hold the start key while starting itunes. Choose the ption to create a new library. Name it something easy like "New itunes". Then go to your exHD and drag the top-level music folder over into the itunes library window.
  • TD109 Level 1 Level 1 (0 points)
    Thanks for the suggestion. I went in and changed the location to "F" which is
    my external HD. Is this the only thing I have to type in or should there be more
    to the path? If I just leave it at "F" I still get the exclamation mark when it
    tries to play a song.
  • racecars4me24 Level 1 Level 1 (20 points)
    You have to make sure the external hard drive is plugged in securely before opening itunes!!
Previous 1 2 Next