7 Replies Latest reply: Jun 5, 2009 12:02 AM by ibopyoubopwebop
Alfredo1900 Level 1 Level 1 (0 points)
On the "old" MacBook Pro (my kid has one purchased earlier this year) there is an option in preferences to disable the touchpad whenever the mouse is connected. However, I have not been able to find this option on the new MacBook Pro I have now for my use or indeed any way to disable the touchpad. When I am using my notebook at home I use a mouse most of the time and also run into problems when typing and a finger brushes the touchpad and causes the cursor to move (frustrating). Maybe I am overlooking something; would appreciate any help since I am a new Mac user and still getting accustomed to the OS. One other thing, is there a utility for a Mac similar to CCleaner which deletes all cookies, temp files, copied text, etc from the computer (also has the option to overwrite files up to 7 times). Thanks in advance for any suggestions or assistance.

15" MacBook Pro (new version), Mac OS X (10.5.5)
  • Mac Medic (be@MacOSG.com) Level 6 Level 6 (17,290 points)
    By default, it should be off when you plug your mouse in. Here are instructions on turning it on. Check this preference file and see if it is set at "0." The file may be corrupt.

    1. First, you need to modify a "hidden" preference file. To show hidden files, use a free utility like OnyX.

    2. Once you can see hidden files, navigate to your User preference folder and look for .GlobalPreferences.plist. Note the file has a "." in front of it to signify it's hidden.

    HD > User > Library > Preferences > .GlobalPreferences.plist

    3. Open that preference file with a text editor and find "com.apple.mouse.ignoreTrackpadIfMousePresent" and change the valuse from 1 to 0.

    4. Log out and log back in. You should be all set to use the trackpad again.



    Dave M.
    MacOSG Founder/Ambassador  An Apple User Group  iTunes: MacOSG Podcast
    Creator of 'Mac611 - Mobile Mac Support' (designed exclusively for an iPhone/iPod touch)

  • Michael Klouda Level 1 Level 1 (5 points)
    I am replacing an older 17" Macbook Pro with a new 15" MacBook Pro (late 2008 version) due to some hardware issues on the 17". One issue was the death of the trackpad button. To get around this I disabled the trackpad through the system preferences and only used a mouse.

    When I migrated all the settings went with me and I can not reenable the trackpad when the mouse is present since the option is no longer in the system preferences. So I did a search and got here.

    One issue that I am having is that the .GlobalPreferences.plist file is not editable by any appliation I have. It appears to be binary. I did read some ways to convert, edit and convert back, but then I ran across this option:

    Use the defaults write -g com.apple.mouse.ignoreTrackpadIfMousePresent 0 command to set the value without editing the file. I have just tried it and need to log out and back in to see if this worked. But wanted to share it as a possible option.
  • Mac Medic (be@MacOSG.com) Level 6 Level 6 (17,290 points)
    Exactly what command are you entering in your Terminal?



    Dave M.
    MacOSG Founder/Ambassador  An Apple User Group  iTunes: MacOSG Podcast
    Creator of 'Mac611 - Mobile Mac Support' (designed exclusively for an iPhone/iPod touch)

  • brian_b Level 1 Level 1 (20 points)
    defaults write -g com.apple.mouse.ignoreTrackpadIfMousePresent 0

    Would be the terminal command
  • Shrui Level 1 Level 1 (0 points)
    I've tried the above suggestions making sure to either type or copy the above commands exactly.

    Still however its had no effect.

    I'm new to macs so therefore haven't used Terminal commands before. Is there anything else I should be doing.

    Is there any difference if your using wireless mice? (sorry, don't have a corded one on hand to test)
  • astolier Level 1 Level 1 (0 points)
    had the same problem on my new macbook; downloaded "sausage fingers" from apple web site and solved the problem
  • ibopyoubopwebop Level 1 Level 1 (0 points)
    dear brian_b,

    i was trying to disable my trackpad when my mouse was plugged and someone sent me this link in
    which you were mentioned:
    http://www.tkjune.com/2008/11/07/enabledisable-touchpad-on-new-macbook-when-mous e-is-present/

    i did go into Terminal and copy and pasted you what was written, logged out logged in but nothing happened. but now i'm worried that i may have pasted only part of the command. stupid of me!!!
    but wanted to know if you know enough about Terminal to negate commands or reset it to
    its default status...

    sincerly,
    stef./.\