9 Replies Latest reply: Nov 6, 2008 1:50 PM by Beth Bales1
Michael Sullivan Level 1 Level 1 (55 points)
I have a corrupted user in Leopard.
So I am copying all the files I need over to a new user.
Both are administrators.
Can I take a whole folder (Docs) and tell it to change all the files in Docs to give me read/write permissions or do I have to do each one separately?

Intel iMac 20", Mac OS X (10.5), http://luv2globetrot.com/
  • nerowolfe Level 6 Level 6 (13,070 points)
    Michael Sullivan wrote:
    I have a corrupted user in Leopard.
    So I am copying all the files I need over to a new user.
    Both are administrators.
    Can I take a whole folder (Docs) and tell it to change all the files in Docs to give me read/write permissions or do I have to do each one separately?


    I would first be sure you have a complete backup of the system before proceeding.
    If you are sure that there are only docs or other user-generated files in the folders, then you can right click them and select Get Info and unlock it.
    Under Name, enter the new user account name with Read & Write Privilege
    At the very bottom you will see a little gear, just to the right of the +- buttons.
    Click it and you will see "Apply to enclosed items"
    Select this and that should do it.
    Again, this is a very powerful function, and I strongly suggest first having a full backup of the system before proceeding.
  • Michael Sullivan Level 1 Level 1 (55 points)
    Thank you, perfect fix.
  • Király Level 6 Level 6 (9,560 points)
    I would say NEVER click the "apply to enclosed items" button on a system-created folder like Documents. It will propagate the Deny Delete ACL and you will need to enter your password to subsequently delete any of those files.

    Terminal is a much better way. Do this (where "foo" is the short user name of your new account):

    sudo chown -R foo (hit spacebar, drag folder into Terminal window, press return)
    sudo chown -R u+rwX (hit spacebar, drag folder into Terminal window, press return)
  • Michael Sullivan Level 1 Level 1 (55 points)
    The second line
    sudo chown -R u+rwX (hit spacebar, drag folder into Terminal window, press return)
    gives me the error:
    chown: u+rwX: Invalid argument
    can you double check that, should it not have user name listed in that line?
  • Király Level 6 Level 6 (9,560 points)
    Sorry, I typo'd. The second command should be chmod and not chown.
  • Beth Bales1 Level 1 Level 1 (95 points)
    I have a similar issue -- though not from a corrupt user. In my case, I copied a documents folder WITHIN my "documents" folder (it's where I stash just about all my word processing items; I've always done it this way, through 15, 16 years of Mac ownership) from my iMac to my new MB.

    BUT -- there are permissions issues and it's a mess.

    Can I do the "apply to all" to that folder, given that it's not created by the system? I frankly don't understand "propoagate" nor "deny delate ACL." What is ACL, anyway?

    Thanks in advance. This is vexing me.
  • nerowolfe Level 6 Level 6 (13,070 points)
    Michael Sullivan wrote:
    The second line
    sudo chown -R u+rwX (hit spacebar, drag folder into Terminal window, press return)
    gives me the error:
    chown: u+rwX: Invalid argument
    can you double check that, should it not have user name listed in that line?


    Fortunately that second erroneous command is harmless. But it is a good reason for having a backup as I first suggested. Especially when copying and pasting terminal commands from these boards, it's possible that a bad command can destroy your system.

    The method I suggested, while it has its issues, is safe. In fact you might see if deleting one of the files does require a password. If it does, this could have been addressed later.
    Again, always backup your system before doing any of these things.

    Message was edited by: nerowolfe
  • Király Level 6 Level 6 (9,560 points)
    Should be fine. First open a Get Info panel for the folder in question, and see if there are any "custom" permissions set on it. If not, you are good to go. If yes, it is a good indication that ACLs are set on that folder, and you should go carefully from there.

    ACLs are a special system of file/folder permissions that overrides the regular UNIX permissions. They were first introduced in Tiger as a user-enabled option, but Leopard was the first OS X to make use of them extensively by the System.

    A "deny delete" ACL setting is put on many system-created folders, like your home folder, your Documents folder, etc. This is to prevent accidental renaming or deletion of them. If you try to trash your Documents folder, you can, but you will be prompted to enter an admin password.

    Clicking the "apply to enclosed items" button on one's Documents folder will set the "deny delete" ACL to all of its contents, meaning you will need to enter an admin password to subsequently delete anything inside.
  • Beth Bales1 Level 1 Level 1 (95 points)
    Thank you so much! That was the clearest explanation yet for my difficulties, and I now have a much better understanding of the situation. (It also explains why this has become a problem only since having TWO machines running Leopard, as opposed to inheriting a folder on my previous laptop that got placed there when both machines were running pre-Leopard systems. Heck, I was probably on Panther when the folder first made its way to a laptop.

    I went ahead and changed permissions on the laptop, since it's so new, and I figured if anything went wrong I can easily start over. I think it said i had mixed permissions, but I didn't see anything about "custom." (And by the way, as soon as I changed it, I no longer was seeing that I had locked versions of files, or copies, or whatever.)

    Now I'll try it on the desktop, which is my main machine. Then I'll sync the two and I should be good to go.

    Thanks again. This was very vexing.