12 Replies Latest reply: Nov 11, 2008 4:40 PM by danben
B.rivett Level 1 Level 1 (0 points)
All of a sudden my safari won't open, it just bounces, and nothing happens so i have to force quit. I have already tried re-installing and it does not work, i have also created a new account and safari works fine on that,

Please Help..

Macbook 2GHz Intel Core Duo, Mac OS X (10.5.5)
  • Hawaiian_Starman Level 7 Level 7 (21,415 points)
    Hi

    Welcome to Apple Discussions

    If Safari opens with no problem in the other User Account, you may have a corrupted preference file affecting your primary user account. Go to the Finder. There, navigate as follows:

    HD>Users>Your User Account>Library>Preferences. Inside that folder, move the com.apple.safari.plist file to the desktop, then restart Safari. If Safari opens, then you'll need to reset any custom preference setting.

    If Safari fails to open, move the preference file back to its original location.

    Post back
  • neth Level 1 Level 1 (0 points)
    I had exaclty the same problem out of a sudden. What you worte, solved it for me, thank you!
  • B.rivett Level 1 Level 1 (0 points)
    i have tried everything you have said but this still doesn't work, any other ideas

    Message was edited by: B.rivett
  • Hawaiian_Starman Level 7 Level 7 (21,415 points)
    Other factors affecting Safari specific to a user account: Cache, Cookies, Bookmarks and History. It's possible too the alias in the dock is corrupt. Did you try opening Safari by double clicking Safari.app in your Applications folder? If not, try it. If no go...

    Go to the User Library>Caches> and move the com.apple.safari file to the desktop. Same routine as the previous suggested (restart Safari, etc). If no go, move the folder back etc.

    Next, move the Cookies.plist file found in your User Library>Cookies folder to the desktop. Restart Safari. If Safari opens, you have a corrupted cookies file. Safari creates a new one on the restart. If no go, move back to the original location, then next step.

    Last step: move to the desktop the Safari folder (same Library), which holds bookmarks, history, etc, and restart Safari. Restart Safari. If no relief, move the folder back, replacing the newly created one. If it does work, then you'll need to move one file at a time back to its original location (I'd start with History, then Bookmarks etc), restarting Safari each time to isolate the problem file. When Safari opens, you found the culprit.

    Post back
  • B.rivett Level 1 Level 1 (0 points)
    no they still don't work, is there anything else i could try,
  • angel_devil Level 1 Level 1 (0 points)
    help...
    after I just installed the updates to mac, safari couldn't work. browser doesn't open. tried the above method but found out that 'com.apple.safari file' is missing from User> Library>Caches>. how to solve problem?
  • Hawaiian_Starman Level 7 Level 7 (21,415 points)
    I'm wondering if hard drive corruption is contributing to this problem. Go to your Applications>Utilities folder and open Disk Utility. Highlight your HD on the left, then select "verify disk" on the right. Let me know if any errors appear.
  • B.rivett Level 1 Level 1 (0 points)
    yeh i did verify disk and it says that the HD is ok
  • Hawaiian_Starman Level 7 Level 7 (21,415 points)
    Disk Utility is not the most reliable utility for HD corruption. More sophisticated repair utilities such as Disk Warrior or TechTool Pro are much better barometers.

    If you live near an Apple Store, someone at the Genius Bar can check the drive for corruption. Otherwise....

    you are left with two choices:
    Reapply the 10.5.5 Combo Update
    Archive and Install the System

    Try the Combo Update first. Sometimes the Update rewrites a corrupted file. If you go this route, make sure you "repair permissions" via Disk Utility when the install/restart is completed.
  • Rachel R Level 6 Level 6 (18,700 points)
    ..
  • iBod Level 7 Level 7 (29,340 points)
    Hi,

    Since the other user account works fine, you may want to check for any files in these locations as well:

    Hard drive > Users > Your Username > Library > InputManagers (this folder may not exist)
    Hard drive > Users > Your Username > Library > Internet Plug-Ins
    Hard drive > Users > Your Username > Library > Fonts

    If there is anything present in those, drag the contents to your Desktop to temporarily disable them and then retry Safari. If that works, start moving things back to where they were one at a time and restart Safari each time to find the culprit.
  • danben Level 1 Level 1 (0 points)
    I had the same problem and yesterday I tried all of the solutions given, but that didn't help.
    I reserved myself to using Firefox because I didn't want to move everything to a new user account (which would have fixed it).

    But today I saw the new video chat for Gmail and when I installed the plugin for it, suddenly Safari was fixed and would open normally!

    I have no explanation for it, but it is painless and probably worth a try.