7 Replies Latest reply: Dec 21, 2008 8:55 PM by cwinicky
iSync & iCal Level 1 Level 1 (0 points)
Help please! I just attempted to restore my iPhoto library using Timemachine from a backup to my new MacBook and now get the following message: " CAUTION: The iPhoto Library is locked on a locked disk, or you do not have permission to make changes to it."

How can I restore permission back to me and view my files? After I receieve this error message the program quits and I cannot get back into it.

MacBook, Mac OS X (10.5.5)
  • Old Toad Level 10 Level 10 (130,045 points)
    Is the message referring to the existing library or the one you're trying to restore? If it's the existing one see if you can't move it to the desktop and the use TM to restore it. If you can't move it to the desktop because of the message problem download and run BatChmod on the iPhoto Library folder with the settings shown here, putting your administrator login name in the owner section and Staff in the group section. You can either type in the path to the folder or just drag the folder into that field. Now try TM again.





    TIP: For insurance against the iPhoto database corruption that many users have experienced I recommend making a backup copy of the Library6.iPhoto (iPhoto.Library for iPhoto 5 and earlier) database file and keep it current. If problems crop up where iPhoto suddenly can't see any photos or thinks there are no photos in the library, replacing the working Library6.iPhoto file with the backup will often get the library back. By keeping it current I mean backup after each import and/or any serious editing or work on books, slideshows, calendars, cards, etc. That insures that if a problem pops up and you do need to replace the database file, you'll retain all those efforts. It doesn't take long to make the backup and it's good insurance.

    I've created an Automator workflow application (requires Tiger or later), iPhoto dB File Backup, that will copy the selected Library6.iPhoto file from your iPhoto Library folder to the Pictures folder, replacing any previous version of it. It's compatible with iPhoto 6 and 7 libraries and Tiger and Leopard. Just put the application in the Dock and click on it whenever you want to backup the dB file. iPhoto does not have to be closed to run the application, just idle. You can download it at Toad's Cellar. Be sure to read the Read Me pdf file.


    Note: There's now an Automator backup application for iPhoto 5 that will work with Tiger or Leopard.
  • saxtonstudio Level 1 Level 1 (0 points)
    I'm beside myself here with frustration. I too have the "Caution: The iPhoto Library is locked, on a locked disk, or you do not have permission to make changes to it" message.

    I have checked my sharing & permissions. I've verified disk and tried verifying permissions (it seems to go on and on and on). I have deleted the iPhoto.lock data thing. I have downloaded BatCHmod and tried that. I've looked in TM for prior version of iPhoto (none came up).

    Am I missing some critical element or step? How the do I get iPhoto to "unlock" and open up??? Should I re-install an earlier version of iPhoto? Can you help?
  • Terence Devlin Level 10 Level 10 (134,915 points)
    Download iPhoto Library Manager and use its rebuild function. This will create a new library based on data in the albumdata.xml file. Not everything will be brought over - no slideshows, books or calendars, for instance - but it should get all your albums and keywords back.

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one.

    Regards

    TD
  • saxtonstudio Level 1 Level 1 (0 points)
    You are my hero.

    It's busy rebuilding. When it's done doing its thing, I'll check back in to let you know if all went well or not.

    Thank you!!!
    Pat
  • saxtonstudio Level 1 Level 1 (0 points)
    Fantastic! Thank you SO much!

    Pat
  • cwinicky Level 1 Level 1 (0 points)
    I have a similar situation. I had a powerbook g4 and lost the hard drive. I was able to recover everything including my iphoto library which is on an external hard drive. I have purchased a macbook and I am trying to at least get my photos into my iphoto library. I can get into the library and see the iphoto but it won't let me import...it is greyed out and when I try to copy it to my hard drive it says that same message....It is locked or you don't have permission. I am wondering if that solution you offered would help me get my pictures unlocked on my hard drive and on to my new mac. Any help you could give would be greatly appreciated, thanks!
  • cwinicky Level 1 Level 1 (0 points)
    You are now my hero too! I tried it and it worked! All 1842 of my family pictures I have now on my macbook....thank you thank you!