Previous 1 2 Next 20 Replies Latest reply: Apr 12, 2009 3:27 AM by Kmop
elad berger Level 1 Level 1 (65 points)
Hello every one and thanks for the help so far.
Can someone PLEASE help with "application/x-ms-wmp"? I'm trying to watch some videos on a website and it keep telling me that I don't have the right MIME. Same thing happens with firefox.
I installed flip4mac studio pro HD and went to QT preferences and MIME setting and ticked Windows media and nothing makes any different?!

Please help

Cheers
Elad

macBookPro, Mac OS X (10.5.5)
  • Mulder Level 6 Level 6 (8,980 points)
    Have you tried unchecking the WMP selection in the MIME Settings… > Video list? That list is for what types of media you want the QuickTime plugin to handle, not the Flip4Mac plugin. I have Flip4Mac installed, it's not selected in QuickTime preferences, and it works perfectly well.

    Mulder
  • elad berger Level 1 Level 1 (65 points)
    Hi Mulder, thanks for the reply,

    I tried that and no different still giving me the "The page has content of MIME type “application/x-ms-wmp”. Because you don’t have a plug-in installed for this MIME type, this content can’t be displayed."

    Cheers
  • Mulder Level 6 Level 6 (8,980 points)
    Where do you have the Flip4Mac plugin installed: /Library/QuickTime or ~/Library/QuickTime? That can make the difference. Also, have you tried repairing permissions?

    Mulder
  • elad berger Level 1 Level 1 (65 points)
    I repaired permissions and no different.
    In Library/Quicktime I have : Flip4Mac WMV Advanced.component, Flip4Mac WMV Export.component, Flip4Mac WMV Import.component, and in ~/Library there isn't a Quicktime folder.

    Elad
  • Mulder Level 6 Level 6 (8,980 points)
    Then I would try downloading and installing RCDefault App. Then open System Preferences > Default Apps, click on the Apps tab, the scroll to the bottom of the list and from the last few entries, choose WMV Player. To the right of that list, select all the URL types and extensions that you want Flip4Mac WMV Player to handle.

    Quit System Preferences, then logout and login again and test it in Safari.

    Mulder
  • elad berger Level 1 Level 1 (65 points)
    Thanks Mulder
    I did that. All the ticks in WMV Player were ticked apart from URL rtsp. there is no "application/x-ms-wmp" to tick only video/x-ms-wmp.
    I restarted and tried and it gave me the "you don't have the MIME type..." again.
    With RCDefault, under MIME Type, I added the "application/x-ms-wmp" and chose WMV to handle it, restart, and again no different.

    Elad
  • Mulder Level 6 Level 6 (8,980 points)
    Hmmm…try creating a new User Account and test to see if it works with Safari there. If not, then the problem is system-wide. If it does work, go back to your primary user account and remove the com.apple.Safari.plist file from ~/Library/Preferences. Then restart Safari and see if that makes any difference.

    Mulder
  • elad berger Level 1 Level 1 (65 points)
    didn't work,
    thanks for your help anyway.

    Elad
  • Djkoh Level 1 Level 1 (0 points)
    Hi there,

    Just open /Library/Internet Plug-Ins/Flip4Mac WMV Plugin.plugin/Contents/Info.plist in any text editor find the string WebPluginMIMETypes and add under <dict> tag the following:

    <key>application/x-ms-wmp</key>
    <dict>
    <key>WebPluginTypeDescription</key>
    <string>Windows Media Plugin</string>
    </dict>

    Restart Safari - issue should be solved for now.

    Djkoh
  • elad berger Level 1 Level 1 (65 points)
    Thanks Djkoh
    Now the warning doesn't come up anymore, but I still can't play the windows media content that's on that webpage.
  • Djkoh Level 1 Level 1 (0 points)
    Can you share the URL?
    I will try to check it.
  • elad berger Level 1 Level 1 (65 points)
    Thank you very much.
    It's a website in Hebrew: http://www.mako.co.il/news. In the right side you'll see a video that can be played, but instead it says "to install windows media player click here".
    I do have filp4mac installed.

    cheers
  • killa_z Level 1 Level 1 (60 points)
    im having the exact same problem, i have flip4mac installed too and i have altered my quicktime prefs

    the url im trying is: http://www.channel4.com/video/desperate-housewives/catchup.html

    when you go to play the episode (click play episode) the message appears....

    any help appreciated
  • Klaus1 Level 8 Level 8 (45,415 points)
    Don't bother!

    This from Channel4:

    "Will I be able to access 4oD on my Mac?
    Unfortunately not at the launch of 4oD.

    This is an industry-wide issue caused because the accepted Digital Rights Management (DRM) system used to protect online video content, which is required by our content owners, is not compatible with Apple Mac hardware and software. The closed DRM system used by Apple is not currently available for licence by third parties and there is no other Mac-compatible DRM solution which meets the protection requirements of content owners. Unfortunately, we are therefore unable to offer 4oD content to Mac users at this stage."
Previous 1 2 Next