13 Replies Latest reply: Apr 16, 2009 9:51 AM by Apostata
woojoo Level 1 Level 1
Hello:

I'm an experienced Mac user of four years, and I've replaced my iBook with an Aluminum 2.0Gh Macbook just yesterday. I love the trackpad, but I seem to have a problem with two-finger scrolling: It doesn't scroll with two fingers. The cursor doesn't move, either, when I'm attempting to scroll with two fingers.

The other gestures work fine, including the other two-fingered gestures. I've tried looking in the new Trackpad preferences, but I can't seem to find any options there.

I've migrated my data from my iBook prior to use. I had iScroll 2.0 installed at one point in time in my iBook, but I've uninstalled it.

Thank you,
-woojoo

Macbook Aluminum, Mac OS X (10.5.5)
Reply by Carbonfish on Nov 15, 2008 12:43 PM Helpful
Hi Woojoo,

I responded to another person about this same issue in another thread a couple of days ago. This is a fairly easy issue to fix. If you migrated your files, folders, and preferences from an older machine that had a PPC architecture (a pre-Intel iBook, or PowerBook, etc.) it will bork the two finger scrolling on your new trackpad. To fix it, you can either reinstall the trackpad preferences from the install disk, or I think (although I didn't try it) you can just rename that file and reboot, and the system will reset the default.

Either way, this is a known issue with an easy fix.

I too migrated all of my stuff from my late 2005 iBook to my new MacBook and the only thing that didn't work on the trackpad was the two-finger scrolling.

I just restored all of the default system preferences in the Library>Preferences folder, but you may want to be more selective than that.

If you want more complete info., a quick Google search will net you more specifics.

Anyway, hope that helps.

KC

All replies

  • Carbonfish Level 1 Level 1
    Hi Woojoo,

    I responded to another person about this same issue in another thread a couple of days ago. This is a fairly easy issue to fix. If you migrated your files, folders, and preferences from an older machine that had a PPC architecture (a pre-Intel iBook, or PowerBook, etc.) it will bork the two finger scrolling on your new trackpad. To fix it, you can either reinstall the trackpad preferences from the install disk, or I think (although I didn't try it) you can just rename that file and reboot, and the system will reset the default.

    Either way, this is a known issue with an easy fix.

    I too migrated all of my stuff from my late 2005 iBook to my new MacBook and the only thing that didn't work on the trackpad was the two-finger scrolling.

    I just restored all of the default system preferences in the Library>Preferences folder, but you may want to be more selective than that.

    If you want more complete info., a quick Google search will net you more specifics.

    Anyway, hope that helps.

    KC
  • woojoo Level 1 Level 1
    Thanks! I issued the following terminal command and logged out/in

    defaults write -g com.apple.trackpad.scrollBehavior 2
  • Carbonfish Level 1 Level 1
    You're welcome.

    KC
  • Jarl Morten Level 1 Level 1
    I ´ve got the same problem. Ibook G4 to a new Macbook. But Don´t know how to solve this problem. Need a basic step by step...
    Anyone who can help?
  • w7ox Level 4 Level 4
    See woojoo msg just above. Go into terminal and type what he shows.

    I believe that's what I did a few weeks back.

    Phil
  • ajmal kernain Level 1 Level 1
    Sweet woojoo,

    totally worked
  • Ottawa Mac Level 1 Level 1
    Woojo & Carbonfish - worked for me too!

    Problem: no scrolling after migration from PPC G4 to Intel MacBook.

    Thank you!

    John
  • Joe Levy Level 1 Level 1
    Wouoooo!

    THANK YOU SO MUCH WOOJOO

    YOU ARE WONDERFUL.

    YOU DELIVERED ME FROM A HUGE FRUSTRATION I FELT SINCE I BOUGHT MY UNIBODY ON NOVEMBER 2008.
  • JonathanCohen Level 1 Level 1
    Thanks! You saved me! Now if anyone can figure out how to make the trackpad click be quiet enough that it can't be heard in the next house, I'd be happy for that, too.
  • Weilone Level 1 Level 1
    Thanks,

    Worked like a charm.
    The problem started after the latest MobilMe sync. Still sorting out SMTP outgoing issues.

    Again you're a life saver.
  • Robert Dievendorf Level 1 Level 1
    Wow! Same problem...migrationg from PB-G4 to MacBook Pro (late 2008). Pasted the command string you provided into Terminal and two finger scrolling now works. Thanks
  • Snaggy Level 1 Level 1
    Awesome thank you! The Terminal command worked for me too.

    That was driving me nuts trying to figure it out.
  • Apostata Level 1 Level 1
    This is an award-winning tip - had the same issue when I migrated to a new MBP.

    That said, speaking of Trackpads, can anyone tell me how to get dragging to work (?!). In the video tutorial they double-click on the top of a window which allows them to drag the window afterward...but when I do that the window minimizes to the tray (which is normal, right?).