2 Replies Latest reply: Nov 15, 2008 6:32 PM by David Yeh
David Yeh Level 1 Level 1 (55 points)
A while back, I installed the .flv 3rd party Quicklook plugin available from http://homepage.mac.com/xdd/software/flv/

Is anyone else using this? I installed it in ~/Library/Quicklook; I had to reset the Quicklook plugins with qlmanage -r from the Terminal, but it worked initially. Somewhere along the line (I'm not sure when, since I just happened to try it for the first time in a long time today), it stopped working-- all quiklook does is throw up a generic icon preview with no video preview. I do have Perian installed, and the movie plays fine with QT Player. I'm up to OS X 10.5.5 now. Looking for some help... I also emailed the author, but the web page is all in Japanese, so I'm not sure well my English email will be comprehended...

Thanks.
  • Francine Schwieder Level 6 Level 6 (19,040 points)
    I have both Perian and flv.qlgenerator (version 0.1 creation date 11/3/07) installed, and just checked an .flv file, a Finder Preview showed up, and it also played in QuickLook. However, I installed it here:

    /Library/QuickLook/flv.qlgenerator

    Not in my home folder, so it would work for all users. I do not recall having to do anything with the Terminal with the 8 plug-ins I installed in /Library/QuickLook.
    Francine


    Francine
    Schwieder
  • David Yeh Level 1 Level 1 (55 points)
    Thanks for the tip; I moved it to /Library, and it is working now. It didn't do anything initially, so I did another 'qlmanage -r' in Terminal, and it started working. I'm not sure where I read to do that, but apparently it helps to kickstart things, although I think Finder figures it out eventually, or maybe a restart would do it too. I'm not sure why it stopped working in ~/Library, since I thought that was a legitimate location, but OK.

    Just some interesting asides: I moved it back to ~/Library to test it, and it worked for a while, until I restarted the computer. Maybe the plugin info was cached somewhere so it worked temporarily even with the move. After the restart, I had to to move it back to /Library. Also, curious about the qlmanage command, I looked at its other options, which includes qlmanage -m to list currently loaded plugins. With the plugin in ~/Library, it is actually listed as loaded, but it just doesn't work. After moving it to /Library and doing a qlmanage -r, qlmanage -m still reports it as being in ~/Library, but it actually works. After a restart, it then reports it as being in /Library (and it still works). All very confusing to me, but bottom line is, it does appear to work in /Library as you suggested--thanks.