6 Replies Latest reply: Dec 6, 2008 3:13 AM by William Kucharski
Staim Level 1 Level 1 (0 points)
I have a Wi-Fi network at home. It is added to my list of preferred networks in Network Settings of Mac OS X. When it was open and unsecured the connection to the network was automatical when I start MAC OS or go out of sleep mode. Now I have WPA2 encryption on this network and I cannot make it to connect automatically. I have tried everything, but it doesn't connect on startup. I must press Airport button and select my network, then the window asking for password appears (the password is stored, so I must press only OK button), but I must do this every time I go out of sleep mode. Please advise how can I do this automatically?

Macbook, Mac OS X (10.5.5), Wi-Fi Trendnet TEW-632BRP
  • Björn Herrmann Level 4 Level 4 (2,495 points)
    Hi and Welcome to  Discussions,

    does removing the network from the list of known networks not work? After doing this, it should act like a completly new network. Additionaly I'd delete the saved password(s) from the keychain, just to be sure the problem isn't coming from there.

    To do so

    1) Open Sys Prefs/Network/AirPort/More Options and remove the network from the list.
    2) Open /Applications/Utilities/Keychain Access.app and delete the entry with your AirPort network's password
    3) Select the network, enter the password and click to save the password.

    That should do it!
    Björn
  • Staim Level 1 Level 1 (0 points)
    Hi there and thank you for your reply. I have tried everything, but now when I turning my macbook on I see notification that preferred networks not found and list of found networks (my router is listed there). Network is added into list of known networks, but still does not connect automatically.
  • Björn Herrmann Level 4 Level 4 (2,495 points)
    Hmm, I once had this problem when the network was added the way you used. Try removing it once again and adding it NOT via the popup list that you mentioned, but manually via

    Sys Prefs/Network/AirPort/More Options/

    There add it with the little + icon and select the option to remember all networks the computer was connected to.

    Hope this helps!
    Björn
  • Staim Level 1 Level 1 (0 points)
    Tried this (I have even renamed my network SSID on router) - no luck. I get the same message that Preferred Networks are not found.
  • Staim Level 1 Level 1 (0 points)
    Finally I have found the solutution myself by searching the Google again and again.

    It seems to be a very strange bug in OS X. When I moved System Prefences.app out of my Applications folder to another location automatic connection to any preferred networks do not work.

    The solution I found (and it worked for me):

    - turn AirPort off
    - delete every preferred networks
    - delete all AirPort Keychains
    - move System Prefences.app back to Applications
    - reboot macbook
    - connect to a preferred network from the scratch

    Maybe it will be useful for any other who will face this problem.
  • William Kucharski Level 6 Level 6 (14,890 points)
    In the future, *don't do that*.

    Moving any Apple applications to locations other than those where they were installed is a recipe for a troubleshooting nightmare.