5 Replies Latest reply: Nov 17, 2008 7:22 PM by Gregory Mcintire
m2lowe Level 1 Level 1 (0 points)
This morning I tried using my trackpad button on my White Macbook, however it was unresponsive. I usually use the tap to click option on the keypad, however when I'm tracking items I use the physical button. What surprises me even more is that I haven't been using my keyboard/trackpad for a while since I've been using my mac with an external keyboard/mouse and monitor. Could any of you offer any insight on what might be happening to my MacBook and what my options are to getting it repaired? It's currently out of warranty. Thanks.

White Macbook 2.0Ghz, Mac OS X (10.5.5)
  • 1. Re: MacBook Trackpad Button Stopped Working
    Gregory Mcintire Level 4 Level 4 (2,170 points)
    I doubt there is anything wrong with it hardware wise.

    Try restarting the computer if you have not already.

    Try logging in as a different user. Create a new User Account in System Preferences>Accounts if you don't have another User account already.

    Go to System Preference>Keyboard & Mouse and make a change of any kind, close the window then reopen it and change back your setting to how it was or to how you want it. Sometimes I have found this to help with some types of preferences. Just a change then change back abain can straighten out the prefs file.
  • 2. Re: MacBook Trackpad Button Stopped Working
    m2lowe Level 1 Level 1 (0 points)
    Greg, thanks for the reply.

    I didn't think it was a hardware problem at first, however even when booting into Windows via Bootcamp, I have the same problem. I have also tried the steps you've described below.
  • 3. Re: MacBook Trackpad Button Stopped Working
    Gregory Mcintire Level 4 Level 4 (2,170 points)
    Does the trackpad work if you boot up using the install DVDs. Remeber though that it will of course not have any of your settings for tracking such as tap to click.

    I don't think I understand your original post where you say you used the trackpad for tracking and the button to click. Do you mean your trackpad still works for moving the mouse arrow around the screen?

    Maybe your problem is hardware. It is much more often a software issue though.
  • 4. Re: MacBook Trackpad Button Stopped Working
    m2lowe Level 1 Level 1 (0 points)
    I will try using the install DVDs and see if I can click. I'll let you know if it works.

    And for my initial post, sorry I made a typo -- I meant to say that I use the button a lot when I'm dragging things. The trackpad still works fine for everything, it's just the big physical button that is unresponsive.
  • 5. Re: MacBook Trackpad Button Stopped Working
    Gregory Mcintire Level 4 Level 4 (2,170 points)
    I misunderstood your entire problem. I though you meant the trackpad did not work for clicking on things by tapping it.

    Yes, the physical button can be a bit flakey for a lot of people. On thing that will cause it to quit working is for it to get debris built up underneath it. This happens to me occasionally. I have always been able to clean it out well enough by putting a vacuum cleaner hose to it and clicking it and tilting it and moving the hose around to do the best I can at getting the little specks of whatever out and it has always worked for me so far.