7 Replies Latest reply: Feb 17, 2009 8:24 PM by Jester5613
SK1 Level 1 Level 1 (15 points)
My database seems corrupted. When syncing to iPhone, it says over 100 songs were not transferred to the iPhone because 'they couldn't be found' - I had deleted them a couple weeks ago from the Music folder. They were unprotected MP3 files.

The tracks appear in no normal playlist - not Music or any other standard playlist. But, If I create a smart playlist and config it to have all songs added within, say, the last 60 days, there are the tracks. But, even the folders in the music folder (I use c:\music as my main folder for all mp3s, and other music/videos) are gone, yet the library thinks they are still there.

How can I undo this? Or, how can I rebuild my library from scratch, having iTunes add everything (purchased as well as mp3's) in my c:\music folder?

Thanks for any help you can give,

sam
iTunes for Windows v8.0.1.11

Windows Vista
  • 1. Re: How to rebuild corrupt iTunes database
    Susan Dennis Level 1 Level 1 (30 points)
    I'm having this exact same problem...anybody have the solution?
  • 2. Re: How to rebuild corrupt iTunes database
    dermodmoore Level 1 Level 1 (0 points)
    Same here! Over a hundred missing tracks. Surely if one or two files are renamed, then iTunes knows how to rebuild the library based on the existing music files on my hard drive?
  • 3. Re: How to rebuild corrupt iTunes database
    ltcmurray Level 1 Level 1 (0 points)
    Can't wait to see the answer to this one. problem started with the latest update (for windows) to itunes for me...

    I booted up iTunes a few days ago and noticed that quite a few of my albums were coming up as dead links. I checked the folder I consolidated it all to and found, for example: Instead of the "Foo Fighters" folder containing mp3's and album folders, there's no such file to be found, instead the folder is filled with "new" files and folders with random titles such as folder: "CÆô╙q.╬P", file: "┘"₧xñ2db.9'δ", and other garble'd things. Right-click<Properties shows that some of these folders and files range up to 4 gigabytes of... nothing! Attempting to open any of these folders displays error messages, "Folder is not accessible, the file name, directory name, or volume label syntax is incorrect."

    the next time I boot up the machine, completely different folders and songs are messed up and the original ones are back to normal.
  • 4. Re: How to rebuild corrupt iTunes database
    Buegie Level 6 Level 6 (13,330 points)
    SK1,

    If you truly deleted the MP3 files from the PC, then they are gone unless you have backup files somewhere else. Look in your "c:\music" folder to verify that they physically exist on the PC.

    If not, you'll need to "re-acquire" them.

    If they are on your PC, then within iTunes:
    1) File->Add Folder
    2) Navigate to your folder with the MP3s
    3) Select it and let iTunes add them to your Library

    If your files are not on the PC, the what iTunse has is just the song "reference" (i.e. - a pointer), not the actual song itself. If the song plays within iTunes, the find out where it is on your PC (right-click -> Get Info). If you get the "!" indicator, within iTunes, then iTunes does not know where the file is: it may be on the PC or you may have deleted it.

    Post back w/more info.

    Best of Luck Buegie
  • 5. Re: How to rebuild corrupt iTunes database
    Rhaen Level 1 Level 1 (10 points)
    Hi all, this may be another possibility: I am also having problems in general in that every time I try to transfer a song from my itunes to my iphone, i get the little information sign and it won't transfer. This includes previously purchased audio books as well. Then, when i tried to play them in itunes, i got the "could not be found message" as well. Most of the music and books are on my ipod. So, I'm wondering if i do an ipod to pc transfer, will that take care of the problem? Please advise. Thanks!!!!
  • 6. Re: How to rebuild corrupt iTunes database
    DWC888 Level 1 Level 1 (0 points)
    I have folders full of MP3's in my library that have "disappeared" from my iPod...I can play them from iTunes but they don't get copied on to my iPod anymore. anyone know what to do about this?
  • 7. Re: How to rebuild corrupt iTunes database
    Jester5613 Level 1 Level 1 (0 points)
    PLEASE HELP ME!!!!!!!!!! i just got a new labtop (hp t6400) and i tryed to sync my ipod to it. it only took purchased songs. i tried to use a 4gb memory stick to transfer the rest from my imac to the labtop but i got exclamation points next to every song (563) and none of my 8 purchased videos work! i synced my ipod and restored it and resynced it but itunes deleted everything off the ipod and wont put anything back on! help me im about to bash my new labtop and desktop mac against my head