1 2 Previous Next 20 Replies Latest reply: Mar 3, 2009 9:25 PM by Agent Riley
LennyX Level 1 Level 1 (0 points)
I'm trying to update to the 2.2 firmware but I keep getting the following error message:

+The iPhone "iPhone could not be restored. An unknown error occurred (14).+

I'm using the latest version of iTunes (updated it just an hour ago) and the latest version of Leopard.

I've tried to do a DFU restore but that's giving me the exact same error. Any ideas on how to fix error 14? Googling gave me nothing.

Black MacBook, Mac OS X (10.5.5)
  • 1. Re: iPhone software update 2.2 error
    Brndn00 Level 1 Level 1 (5 points)
    Same thing happened to me, except I have an iPod Touch 2G

    I downloaded firmware 2.2 then connected my iPod and it tried to update but then said error
  • 2. Re: iPhone software update 2.2 error
    Brndn00 Level 1 Level 1 (5 points)
    I found a crude but working solution.

    However, it will only work if you have another computer that is not currently synced with your iPhone or iPod Touch.

    Go to the other computer & download & install iTunes 8.0.2.20 (the latest at the time)

    Then connect your iPhone or iPod to the new computer with the new iTunes

    If you have the same problem as me, it will probably tell you that iTunes had found a device in recover mode and it will ask you to restore it.

    Click restore on the home page and it will ask you to download Firmware 2.2 (also the latest at this time) -- Do so

    It should then proceed to restore the iPhone or iPod to original factory settings.

    It will then download the Firmware and you should be all set to go

    It is safe (at least for me it was) to go back to the other computer (the one that wasn't working before) and resync all your personal information (that is, if you backed it up)

    Hope this helps, it worked for me
  • 3. Re: iPhone software update 2.2 error
    lertg Level 1 Level 1 (0 points)
    I face the same problem. I tried using another to Sync and restore but to no avail. Anyone can help?
  • 4. Re: iPhone software update 2.2 error
    imaninja Level 1 Level 1 (0 points)
    hmmm,

    I have my iphone synched with my laptop.
    I used the same laptop to update my phone and it worked fine. I guess I got lucky.

    Cheers
  • 5. Re: iPhone software update 2.2 error
    LennyX Level 1 Level 1 (0 points)
    Actually, I'm away from home at the moment which is where my iMac is that my iPhone usually syncs with. I don't think it should make a difference though because all I'm trying to do now is restore it to the factory defaults. I'm about to try it on my girlfriends MacBook to see how that goes...

    Does anyone know what error 14 actually means? I still haven't found an answer to that
  • 6. Re: iPhone software update 2.2 error
    alabanco Level 1 Level 1 (10 points)
    So is it ok ? shall we update it or wait till the update will be okay at last.
  • 7. Re: iPhone software update 2.2 error
    LennyX Level 1 Level 1 (0 points)
    This problem seems to be pretty rare so updating should go fine for just about everyone. Thousands of people have probably had no problems at all.

    I tried restoring on my girlfriends MacBook and it didn't work. I did it using the same firmware file that downloaded on my computer so that's just about the only thing that could be the problem now. I can't re-download the huge firmware file again until I get home. I'll post here with how it goes.
  • 8. Re: iPhone software update 2.2 error
    LennyX Level 1 Level 1 (0 points)
    Ok I'm back at home on my iMac and I've re-downloaded the firmware. It's restoring fine this time. I guess error 14 means there's something wrong with the firmware you've downloaded...

    If you need to delete your previously downloaded firmware, open Finder, press CmdShiftG and paste this in the box that comes up:
    +~/Library/iTunes/iPhone Software Updates+
    Delete whatever is in there and then click restore again in iTunes and it will download the firmware again.
  • 9. Re: iPhone software update 2.2 error
    lariverdog Level 1 Level 1 (0 points)
    I've just spent the last 3 hours fixing this error.
    Cause (according to apple): Too many people logging in to get the download can cause file error. Solution: wait a few days before doing any download.

    Ok, how I fixed my problem after working on it for hours.
    I hope you did a backup (sync) before you attempted the download. If not, you are screwed.
    Assuming you have a PC, because I can't help you if not.
    Here goes:
    go to another pc and do another revision download. You should then be able to update the phone abeit in a clean state.
    Go to the orginial pc that had the problem. Open the Itunes window.
    Open Edit
    Open Preferences
    Open Devices tab
    Click disable automatic syncing for Iphone
    Click ok
    Note the device backup window on this screen. It should have a date and time prior to the attempted software update. If not, you are screwed.
    Close that window.
    Plug in iphone and let it do whateve it does
    Right click on the iphone icon on left side
    Click restore from backup.
    this worked for me
    if you did not do a backup, you will not be able to retrieve your phone book or calendar unless you have backed them up in some other way.

    hope this helps others, I am back fully functional again
  • 10. Re: iPhone software update 2.2 error
    Sirmausalot Level 1 Level 1 (15 points)
    When you say the problem is rare, what information do you base that on as the software has only been out FOR ONE FRIGGEN DAY.

    Proud owner of a 2.2 Brick
  • 11. Re: iPhone software update 2.2 error
    LennyX Level 1 Level 1 (0 points)
    I base that on the fact that thousands of people dugg news of the update on digg.com and hundreds have commented in forums on forums with no problems. The issue does seem to be a corrupt download so just re-download it and restore again. Just because it happened to you it doesn't mean it's common
  • 12. Re: iPhone software update 2.2 error
    Lutterop Level 1 Level 1 (0 points)
    Are you by any chance working on a remote home directory (i.e. a home directory stored on a Mac OS X Server)?

    I had the same problem while working in my profile stored on my Mac OS X Server. When I logged in the local Administrator account the iPhone restored on the first try.

    iPhone 3G no sim-lock upgraded from firmware 2.1 to 2.2
  • 13. Re: iPhone software update 2.2 error
    N4T7NB Level 1 Level 1 (0 points)
    when i tried to update, there was an error code with 5 or 6 numbers and my ipod just went to a blank lit up screen. then i restarted and it tells me to connect my ipod to my itunes and i plug the usb in but the ipod keeps the screen and my itunes doesnt pop up with the ipod tab.
    -Nat
  • 14. Re: iPhone software update 2.2 error
    Gocannon Level 1 Level 1 (0 points)
    I, too, fall in the category of now having an iphone brick. Apparently the solution is to wait a few days and try downloading the wonderful firmware again (on a different computer). And then you get the pleasure of having the phone restored to its factory condition - wiping all custom settings. Excellent!!

    My question is why do I have to wait a few days? Is it because the servers cannot handle the load? If so, Apple is propogating more iphone bricks by not taking down the "upgrade" immediately and fixing the server issues. The same thing that happened to my download will continue happen to others "for a few days".

    It is extremely poor network programming to cause such a fatal error. I'm really starting to get tired of Apple's incompetence.
1 2 Previous Next