11 Replies Latest reply: Jan 16, 2009 9:23 AM by Leland Clayton
ZakMb Level 1 Level 1 (0 points)
Mac OS X 10.5.5
iTunes 8.0.2 (20)
2 iPhones: 2G & 3G

- iPhone 2G upgraded without any problem to firmware 2.2

- iPhone 3G: "Unkown error has occured (1602)" (translated from french message: "+Une erreur inconnue s'est produite (1602)+")

The iPhone 3G is now freezed on the USB connect to iTunes screen. Have tried several hard reset without success. The iPhone is not detected by iTunes.

I have created another user account on my MacBook, without any success.

I have also tried on a PC running Windows XP without any success.

Is there a way to flash the firmware ?

I am an iPhone user since the begining (after a long experience on Windows Mobile) this is the first time I'm experiencing such a problem with an upgrade . Ithink, I'm not the only user in this case, how can we escalate this issue to Apple.

Thanks.

Macbook, Mac OS X (10.5.5)
  • ZakMb Level 1 Level 1 (0 points)
    Update:

    Have tried several times. By using a new account on my MacBook, I had a change to enter iPhone recover mode. I accepted the recover mode, the firmware was downloaded and after the Unpacking step, I got : "Unkown error (2006)"
    This is what the iPhoneUpdater log file is saying:

    <iPhoneUpdater.log>
    2008-11-23 01:31:25.000 iTunes[112:20b]: restore library built Oct 22 2008 11:02:50
    2008-11-23 01:31:25.000 iTunes[112:20b]: iTunes: iTunes 8.0.2
    2008-11-23 01:31:25.000 iTunes[112:20b]: iTunes: Software payload version: 5G77
    2008-11-23 01:31:25.000 iTunes[112:10fe7]: command device request for 'getenv radio-error' failed: 2006
    2008-11-23 01:31:25.000 iTunes[112:10fe7]: radio-error not set
    2008-11-23 01:31:25.000 iTunes[112:10fe7]: unable to open device_map.txt: No such file or directory
    2008-11-23 01:31:25.000 iTunes[112:10fe7]: error setting configuration descriptor: 0xe00002ed
    2008-11-23 01:31:25.000 iTunes[112:10fe7]: <Recovery Mode Device 0x19f127b0>: Recovery mode failed (result = 2006)
    2008-11-23 01:31:25.000 iTunes[112:20b]: device disconnected (isDFU = 0)
    2008-11-23 01:32:50.000 iTunes[112:20b]: iTunes: Restore error 2006
    </iPhoneUpdater.log>

    Any help would be appreciated.

    Thanks.
  • Lawrence Finch Level 7 Level 7 (30,270 points)
    The 1602 error is a USB connection error. For some reason you are not getting a good USB connection. Connect directly to the computer, not through a hub. Restart the computer. Unplug other power-consuming USB devices (not keyboard or mouse). Make sure the phone is fully charged.
  • ChenMama Level 1 Level 1 (55 points)
    Hi, try a different USB port may help.
  • ZakMb Level 1 Level 1 (0 points)
    I have only 2 USB ports on my MB, one is used by an USB mouse. I'll follow your advice by:
    - unpluging the USB mouse
    - charging the iPhone

    Will have another try later.

    Thanks.
  • chino Level 1 Level 1 (60 points)
    Change the AUTO-LOCK to NEVER in settings and try again.
  • mindcraft Level 1 Level 1 (0 points)
    hey i just experienced the same problem... midway thru my 2.2 update, i got an error. and then my restore failed, got a "usb to itunes" screen of death on my iphone.

    i unplugged iphone, closed itunes, changed my usb to another port on the pc, replugged iphone, then restarted itunes... i got the option to restore iphone again, and it worked. not sure what exactly the deal was, but basically it deleted everything from my iphone and made me start from scratch. atleast my phone isn't a brick, but i still wasted about 4hrs of my time doing all this, just to get 2.2 firmware.

    hope this helps -- good luck
  • ZakMb Level 1 Level 1 (0 points)
    I don't have a chance to set the AUTO-LOCK option. My iPhone is freezed on "USB to iTunes screen" without any possible alternative then shutting it down and up.
  • ZakMb Level 1 Level 1 (0 points)
    I have tried this, unfortunately it didn't fix the issue. Note that I am using Mac OS and an iPhone 3G. I have heard that 2.2 firmware include an update to the Baseband component which could explain error message in the iPhoneUpdater log file !?

    Thanks.
  • littlekid440 Level 1 Level 1 (0 points)
    one possible solution - download the upgrade file from apple or another third party website. Hold shift while clicking on the restore button on itunes and it should work. if not download it from another website. I had the same problem and after 30 min got it working. good luck.
  • Raleigh D. Level 3 Level 3 (715 points)
    ZakMb,

    Have you tried a different USB cable?

    You might also want to try downloading the 2.2 software again. You can achieve this by trying the restore in a different user account on your Macbook. Instructions on how to do this are found in article http://support.apple.com/kb/TS1275 , along with other good troubleshooting recommendations.

    If that does not resolve the issue, you might try taking the iPhone to an Apple Store. If it's deemed a hardware failure, they can offer a repair.

    Hope this helps,

    Raleigh
  • Leland Clayton Level 1 Level 1 (15 points)
    I had this problem when I updated to 2.2 as well. Put the iPhone into DFU mode and iTunes should see it.

    Go into iTunes and make sure the "Automatically sync when this phone is connected" box isn't checked. Quit iTunes, Plug in the phone, if it turns on turn it off. After it turns off wait 5 seconds. Push and hold the home and power button for 10 seconds. After the 10 seconds release the power button but keep holding onto the home button for another 10 seconds. The phone should be now in DFU mode. Launch iTunes and it should tell you the phone is in recovery mode. From there you can restore the phone.