2 Replies Latest reply: Nov 28, 2008 3:20 PM by Michael Conniff
Jmar Gambol Level 1 Level 1 (5 points)
Every time I restart with the Leopard firewall on I'm asked at startup if I want to allow "mDNSresponder" and "configd" to do stuff. This only started happening after I installed RealPlayer 11 while the firewall was on. I'd rather not have to be asked every restart. Any suggestions?

MacBook (late 2008), Mac OS X (10.5.5)
  • ifire Level 1 Level 1 (5 points)
    I had the same problem, in my case after leaving my Al PowerBook G4 sleeping until the battery went flat.

    Try following the instructions at the bottom of:

    http://aviflax.com/post/os-x-tip-dont-deny-incoming-connections-to-configd/

    I checked the original file (/Library/Preferences/com.apple.alf.plist) and found it was totally corrupt (full of binary, rather than an XML file). After I copied the version from /usr/exec/ApplicationFirewall and restarted, the firewall was reset to "Allow all incoming connections", then setting it to "Set access for specific services and applications", which is how it was before, no longer produced the annoying configd requests on startup.
  • Michael Conniff Level 7 Level 7 (33,125 points)
    ifire wrote:
    I checked the original file (/Library/Preferences/com.apple.alf.plist) and found it was totally corrupt (full of binary, rather than an XML file).

    For a while now, OS X has been keeping its preference files in binary, so it is unlikely it was corrupt. There is a straightforward utility, plutil, to convert between the formats, but either format will work.

    Mine is currently in binary:
    macbook:~ michaelc$ file /Library/Preferences/com.apple.alf.plist
    /Library/Preferences/com.apple.alf.plist: Apple binary property list