1 2 Previous Next 15 Replies Latest reply: Feb 17, 2009 7:04 PM by pseudo_spunk
Banjoboyslim Level 1 Level 1 (0 points)
Ok, this morning my computer stopped recognizing my cd drive all together. My friend then went into some folder and deleted some files that is supposed to make Vista 'more stable'. After that my computer worked just fine. But now I go into itunes and I get a message at startup saying: "Warning! The registry settings used by the iTunes drivers for importing and burning CDs and DVDs are missing. This can happen as a result of installing other CD burning software. Please reinstall iTunes." I've reinstalled more than once, but to no avail I'm still frustrated out of my mind! Please help. Thanks.

PC, Windows Vista, Pretty Good Machine
  • 1. Re: "Warning! The registry...."
    esoteric76 Level 1 Level 1 (0 points)
    I am getting the same exact error. Dell won't help me because it's iTunes related and not "their problem." I am able to burn on Roxio but not iTunes, which doesn't make much sense to me. Has anyone figured out how to fix this error message?
  • 2. Re: "Warning! The registry...."
    peteol Level 1 Level 1 (0 points)
    I'm having the same problem and reinstalling iTunes has not solved it. I'm not able to burn a DVD with Roxio either. What's wrong and what can I do about it? Thanks!
  • 3. Re: "Warning! The registry...."
    sben Level 1 Level 1 (0 points)
    I have the same exact problem. I updated iTunes, reinstalled iTunes--no help. What can I do to fix this problem???
  • 4. Re: "Warning! The registry...."
    Peter11050 Level 1 Level 1 (0 points)
    I am also having the same registry issue. How can we get Apple to acknowledge the problem?
  • 5. Re: "Warning! The registry...."
    Tikihaha Level 1 Level 1 (0 points)
    This has only occured since I upgraded to iTunes Version 8. It stopped me from burning normal data CD's (have Roxio, Windows XP, etc). So I fixed that be re-enabling burning to my d:/drive, but ever since then I get the same error message when I open iTunes. I can still import CDs - just cannot burn them.

    There is NO burning tab at all under "Preferences" - it has gone. When I put a blank CD into my drive, it tells me that I have no burning software. I can burn fine from a number of different other programs - even tried going into "My Music" and could drop some iTunes files directly to my D:/drive and they burned.

    Just not from iTunes. It's all disabled and broken and there is NO HELP.

    No option for burning under preferences.

    Everything else on my system works fine.

    I have gone to the other "burning" support in other forums, gone into regedit, checked the DMA properties, etc. etc. and it's all for nought.

    *Can we please get a resolution? This is all because of Version 8!!*
  • 6. Re: "Warning! The registry...."
    Leareth Level 1 Level 1 (0 points)
    I too, have the same bloody problem, this has happened before, but I fixed it. But since the upgrade to the newest version... >.< de nada.
  • 7. Re: "Warning! The registry...."
    vintagedream Level 1 Level 1 (0 points)
    Don't feel bad as I am having the same problem. I've also uninstalled and reinstalled the Apple software, made registry changes and everything that was recommended but with the number of complaints I've seen I strongly suspect it's with Apple's software itself and there is nothing we can do until Apple gets enough complaints and finally addresses it. It's been months that this has been happening and many people complaining and still no response. I even tried going back to an older version when it did work and that didn't help. It's good enough for us to pay money for music, videos and many other things offered but when there is a major problem in their own software they ignore it until they overwhelmed with complaints. It use to be when software companies backed up their software and offered FREE support but now they charge for support and actually charge quite a bit for it with no guarantee's your problem will be fixed. Roxio has done the same darn thing as has most computer software companies. Maybe if we stop buying they will pay attention. So Sad!
  • 8. Re: "Warning! The registry...."
    nada123 Level 1 Level 1 (0 points)
    Same deal here, any ideas?
  • 9. Re: "Warning! The registry...."
    ms610337 Level 1 Level 1 (0 points)
    I am having the same problem. I actually apple and was on the phone with then for over an hour. They tried to help me fix the problem but it never was fixed. I don't think they realize that it is there fault and is blaming it on us.
  • 10. Re: "Warning! The registry...."
    Sean S-S Level 1 Level 1 (0 points)
    Try reinstalling the CD Drive's software. I had a similar problem and I reinstalled the software for it and it worked. This is probably not an error with iTunes, but with your PC's software.
  • 11. Re: "Warning! The registry...."
    Tikihaha Level 1 Level 1 (0 points)
    I FOUND A POSSIBLE FIX!!

    I had this same warning message and could not burn CDs in iTunes (and no, it wasn't my driver's hardware as my computer is 3 months old and everything is up-to-date).

    See:

    http://discussions.apple.com/thread.jspa?threadID=1793281&tstart=0

    (1) Basically, search on your c:\drive for a hidden folder called "x86".

    (2) Save it to your desktop

    (3) Open folder x86, and find a file called GEARAspdiWDM Setup Information (.ini file).

    (4) Right-click and select "Install".

    (5) Reboot your computer, and this fixed my iTunes!! Yippee!!!

    Thanks to Denali_uk, a fix (for some, if not all) of these problems has been located! Hopefully this may work for you.
  • 12. Re: "Warning! The registry...."
    mattpenn Level 1 Level 1 (0 points)
    The fix worked.
    I just opened the x86, found the file and clicked reinstall. That did it. Rebooted and off she went.
  • 13. Re: "Warning! The registry...."
    Peter11050 Level 1 Level 1 (0 points)
    Can anyone tell me where I can find a file on the C drive labeled X86. I am running Windows Vista. Thanks
  • 14. Re: "Warning! The registry...."
    Richbo Level 1 Level 1 (0 points)
    I am having the same problem with the registry settings error message. I tried using the fix posted on the forum but i cant find that file in Windows Vista. Has anyone fixed the problem in Vista. Rich
1 2 Previous Next