Skip navigation
This discussion is archived

Unable to slide to answer

5749 Views 9 Replies Latest reply: Apr 1, 2009 3:20 PM by AamirB RSS
success2be Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 25, 2008 11:40 AM
This has already happened to me twice in 1 week. I get a call, when I slide the on-screen slider, it bounces right back to the original position before I have dragged the slider all the way to the right. It keeps doing that when the phone's ringing making it frustrating. After sliding about 4 to 6 times, the phone finally unlocks to answer the call.

Anyone else has similar issue? I can perfectly slide to unlock just fine. Only had the slide problem when trying to answer a call.
Macbook 2.2Ghz, Mac OS X (10.5.5), iPhone OS v2.2
  • Gregory Cost Calculating status...
    Currently Being Moderated
    Dec 4, 2008 7:00 PM (in response to success2be)
    Same problem, no solution yet.
  • SASprof Calculating status...
    Currently Being Moderated
    Dec 4, 2008 7:05 PM (in response to success2be)
    yup. happened to me several times. seems random. only happens about 5% of the time. but drives me crazy. i've missed calls because of this.
    PC, Windows XP
  • Matt2.0 Calculating status...
    Currently Being Moderated
    Jan 4, 2009 1:19 AM (in response to success2be)
    Just bumping this issue (here and on Apple feedback). Running latest updates, no cases or skins for the phone. Like you say, 5% or so of calls are impossible to answer. Not good as I am often on call for work and must be reachable.

    I have noted that my iPhone will not display the name of at least one of the callers in this situation (just his number), despite all his details being in Contacts. I suspect this has to do with some bug in the software matching a caller's number with data in Contacts.
    Alu MacBook 2.4GHz 4GB; Cinema Display 23''; 500GB TC; 3G iPhone 16GB, Mac OS X (10.5.6)
  • jammiccar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 4, 2009 1:53 PM (in response to success2be)
    Similar issue: on my partner's 1st gen iphone he (often) can't slide to answer, no movement at all. 6-8 times and then it will slide.
    macbook, Mac OS X (10.5.6)
  • ride1992 Calculating status...
    Currently Being Moderated
    Jan 4, 2009 3:44 PM (in response to jammiccar)
    I noticed that nobody mentioned that they tried a reset, holding the sleep/wake button and home button down at the same time until the Apple logo appears, ignoring the option to turn off the phone.
    It's worth a try.
    Dell XPS, Windows Vista
  • viskwal Calculating status...
    Currently Being Moderated
    Jan 23, 2009 12:26 PM (in response to ride1992)
    Mine just started to behave the same way. I'm missing calls all the time sudenly.

    the slider works perfect to unlock the screen, yet I cannot slide to answer any calls...
    a phone should be capable of answering calls.

    I got a first generation iphone, always treated very well, never fallen, nothing that could harm it.
    No software, nothing, just plain install, and all of a sudden this just started happening for no apparent reason.

    I did try a reset (sleep and home until it reboots), I could answer the first call, and from the second call it misbehaved again.

    Anybody have any idea, or suggestions ? I'd hate to go back to a nokia....
  • Hudsoninbama Calculating status...
    Currently Being Moderated
    Jan 25, 2009 4:00 PM (in response to viskwal)
    New to the forums as far as posting but have browsed here for months. Has helped with multiple problems over 4 iPhones I have owned (yes, 4).

    I too have had a phone with this same problem. To me it seems that it is a corrupt file in the phone associated with particular contacts. the reason I say this is because not all calls acted this way, at least in my case.

    The phone I had with this problem was a 8gb 1st gen iPhone. Here are some of the things I tried and why I think it is a system file issue:

    Restored the phone to factory settings (was 2.1). After the restore was complete I placed a few calls and had a few calls returned with no problem. I decided to
    restore my contacts, pics, etc and after doing so the phone went back to it's old ways. Would not allow me to answer when calls received.

    Decided to wipe the phone again and restore to original 2.1, after that all was good again. Did not do a restore for contacts, had to input them in manually but at least the phone doesn't have the issue with not being able to answer the phone.

    The phone in question was unlocked and did have Cydia installed. Don't know if something from it caused the problem to begin with but I have reloaded Cydia again and have not had an issue.


    Hope some of my babble helps, was very frustrating to have a phone you can't answer.
    Toshiba M200, Windows XP
  • Laing Calculating status...
    Currently Being Moderated
    Mar 23, 2009 2:01 AM (in response to viskwal)
    Me too - exactly the same problem. Very frustrating!!!!
    Mac Mini Core Duo, Mac OS X (10.4.6), Also have G3 iMac; G4 iMac and 12" G4 iBook in household.
  • AamirB Calculating status...
    Currently Being Moderated
    Apr 1, 2009 3:20 PM (in response to success2be)
    This is an issue that plagued my phone as well. After searching some of the other forums, I did find a solution which solved my problem.

    The issue is with ringtones!

    If your contact is assigned a CUSTOM ringtone that gets wiped for some reason, you would not be able to answer calls for that contact. On an incoming call, the software searches for the ringtone and if not found, it locks up.
    Change the ringtone( or restore the ringtone file in itunes and sync) and the problem goes away immediately.

    For myself, the problem started when I restored my phone from a previous backup... I am assuming this can also be an issue when updating firmware.

    Hope this helps.
    Thinkpad T61, Windows Vista

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.