1 Reply Latest reply: Nov 25, 2008 5:08 PM by nerowolfe
cometboy Level 1 Level 1 (0 points)
i desperately need help now.. I have three accounts on may iMac "Leopard OS". what happened was i tried to edit the host file settings in administration account which could be found in this link

http://osxdaily.com/2007/03/19/block-access-to-specified-sites-by-modifying-etch osts/

so when i switch to the other accounts, I can't access all the sites that ask for password like yahoo mail and gmail. it only says connection error, the server was interrupted...but what I only tried to change in the Host File settings was to redirect www.youtube.com to my local machine (127.0.0.1) because I want to block this site in all the browsers just like the link shows. How could I solve this connection error?! By the way, there is no connection error on my administration account. It only happens on the two other accounts. Any help will do. Thanks!

iMac, Mac OS X (10.5.5), Host File and Server
  • nerowolfe Level 6 Level 6 (13,070 points)
    cometboy wrote:
    i desperately need help now.. I have three accounts on may iMac "Leopard OS". what happened was i tried to edit the host file settings in administration account which could be found in this link

    http://osxdaily.com/2007/03/19/block-access-to-specified-sites-by-modifying-etch osts/

    so when i switch to the other accounts, I can't access all the sites that ask for password like yahoo mail and gmail. it only says connection error, the server was interrupted...but what I only tried to change in the Host File settings was to redirect www.youtube.com to my local machine (127.0.0.1) because I want to block this site in all the browsers just like the link shows. How could I solve this connection error?! By the way, there is no connection error on my administration account. It only happens on the two other accounts. Any help will do. Thanks!


    Welcome to Apple Discussions:
    First the article is not very good, because the first thing to do when editing any system file is to make a backup of the file because "stuff" happens.

    The hosts file is global. It applies to all browsers and all users. If what you did only apples to one account something is wrong. You may have reset the permissions on the file.
    It should look something like this:
    -rw-r--r-- 1 root wheel 434538 Aug 24 2007 hosts

    If you are not really experienced in editing files then you may need to start with a new default hosts file.
    Restore the original and see if everything is back to normal.

    The editor you use is important. Some editors mess up the Unix files, making them unreadable to the system.

    Message was edited by: nerowolfe