1 Reply Latest reply: Nov 26, 2008 4:15 PM by 80HD
80HD Level 1 Level 1 (0 points)
I tried installing the 2.3 update as I have with all the past firmware releases. This time however, my Apple TV restarted, then said update failed giving me the option to restart/run diagnostics/factory restore.

Diagnostics were ok, so I restarted and re-downloaded the update. It failed again and after a factory restore, still will not install.

Worst of all, I gave up 2.2 for 1.0 thinking my most recent firmware was corrupted. Now I really need that update

40gb Apple TV, Windows XP Pro
  • 80HD Level 1 Level 1 (0 points)
    I found the solution so this response is for others who run into this issue.

    It turns out that the Apple tv is able to tell when the hard drive has been replaced. The fix is not the easiest thing in the world to pull off, but shouldn't be a problem if you have already been messing the with the hard drive.

    The fix that worked was to replace the factory restore partition of the Apple tv with the 2.3 firmware and then run a factory restore. It seems that the hardware check only runs while in upgrade and not restore mode.

    more info
    http://www.semthex.com/viewtopic.php?f=2&t=1171

    <Edited by Moderator>